"Just Type" Beta Testers

teletype

#243

Self patching into Run = more sounds. Also try audio into Run and adjust the audio oscillators amplitude + waveshape.


#244

First impression: huge—complete?—stability improvement on original features!


#245

JF works great, thank you @Galapagoose. No problem whatsoever with the 3.0.3.


#246

Finally getting around to updating. Has anybody posted a script or two that puts Just Type through its paces yet?


#247

Are there any Youtube video exploring the possibilities of Just Type?


#248

I would love to see some cool Just Type recipes


#249

I tried “Geode” mode for the first time last night and was completely floored.

I see a lot of people asking for examples and scripts. Try the following:

  1. Set Just Type’s panel to “Shape” instead of sound.
  2. Set the envelope shapes to rapid attack. Crank up the frequency to turn the outputs into thin triggers instead of wider envelopes.
  3. Type JF.MODE 1 to enable Geode mode.

Geode mode is essentially a clock multiplier with variable quantization. To explore (I did this in live mode…):

  1. JF.VOX 1 1 -1 will set the first trigger output to generate at the base clock rate (set by JF.TICK).
  2. I used JF.VOX 2 2 -1 and JF.VOX 3 4 -1 to set the next two outputs to x2 and x4 clock multiples.
  3. Here’s where things get really fun. Try various divisions of JF.QT to quantize these clocks to a grid. If you do JF.QT 4, all three clocks will be strictly quantized to each other and in phase. Now try JF.QT 3 or JF.QT 5. Then, try changing the base multiplier on either channel.

That was my first exploration. For the patch, I just did an extremely basic bongo patch where channels 2 and 3 were triggering an Optomix. This allowed me to hear exactly how the quantization was working.


#250

Tore apart a patch today so I figured I’d try to update.

I’m trying to follow the firmware update instructions, but I don’t even seem to be able to get to the bootloader startup position. Knobs fully CCW, sound/cycle, etc. but when I power up, Just Friends is just acting normal, 6N isn’t pulsing, nothing seems to change when I play the sound file.

I have an original Just Friends (pre-ordered it :slight_smile: ) - run jack hasn’t been fixed, not sure if that’s an issue, but I’d love any suggestions. It’s like it can’t even enter whatever the bootloader mode is…

Thanks!


#251

Did you have a cable in the run jack when you power on? As a test - turn off your system, turn all knobs full left,switch to sound/cycle, put a dummy plug in run. Turn on your system. Does the 6n blink?


#252

Yes, doing all that. It blinks once when I turn it on. No pulsing as described on the website though.


#253

If it blinks on/off you should be good to go with your audio. Or you mean it blinks 1 time then stays off? Did you try your audio at different levels? The first time i tried it was too loud and i had to cut back until the 4n and 6n responded. When you first play the audio 6n should flicker. When theres a change in audio 4n flickers, then it goes back to 6n. These are the 2 that flicker at different times when loading the audio.


#254

If it’s not blinking when you first turn it on, make sure the RUN cable is connected to your sound source before turning on.
If you still have the problem, you’ve probably got a grounding issue - what is the sound source? Does it run on batteries? If so try it with the power connected (or not) to see if that helps.
You’ll need to power cycle each time to check.


#255

I also had that issue, and it worked after I turned all knobs a bit away from CCW and then back to CCW - the knobs were at full CCW before, i had checked to make sure, but apparently something didn’t register correctly? No idea what it was exactly, but that was what did the trick for me, maybe it’s worth trying.


#256

Could you update the latest one sheet manual to your website? Its causing a bit of confusion on MW between V2 and V3 run settings.


#257

@Galapagoose Sorry for the delay, I was out of town. I’ve tried resolving it by being sure I’m on a grounded outlet and still no luck. I’ve tried connecting the run jack to both my laptop’s audio out and my cellphone’s audio out. Neither seem to be impacting the Just Friends in a way that it’s flashing properly.

@x2mirko - did you do the knob movement and back to CCW while you were powered down or powered up? I’ve tried both and it doesn’t seem have an impact, but just curious.


#258

@Galapagoose I wonder if you’d consider adding a command to Just Type Synthesis mode that would allow for setting the note on a channel without triggering the envelope. I just got a grid/ansible last week and one of the first things I found myself wanting to do was use Kria with JT Synthesis. To that end, I’ve successfully modified the Ansible firmware to add a KR.CV command for reading CV directly from TT ((Teletype) CV from Ansible while running Kria on TT), but I’d really like to control gate lengths from Ansible as well!


#259

Hey folks. I’m very excited to start playing with Just Type but the cable (about 8") isn’t quite long enough for my current case layout and I was hoping not to change it. 12-16" might do.

I’m not versed in electronics and don’t want to bother Galapagoose. Will any 2x3 ribbon cable of the appropriate length do? I’ve ordered one but don’t want to wire things up and possibly short one of the modules. :upside_down_face:


#260

Following the run up of excitement surrounding the release of the new firmware and Just Type I thought we might see more of what others were doing with the setup.

I was also hoping a repository of Teletype scenes for Just Type might start to emerge, is anyone doing any deep exploration of this combination? As for me, I finally just sent triggers from the Teletype to the Just Friends over the iC2 connection - magic is starting to happen.


#261

Interesting. My approach so far has been to see the Just Type commands as an end point to teletype code, rather than CV and Gate out, allowing polyphony. I haven’t yet explored it much further than that and would be interested to see what people have come up with.

Using it as the basis of a ‘polyphonic synth’, Just Type does lack one feature, it is hard to get individual voices to have individual filters, that each respond to their individual envelopes. This is where a lot of polysynths shine, but of course this would be way beyond the scope of JF! One trick I’ve been using is this:

  1. Passively mix all the JF outputs into a single filter
  2. Take the JF Mix out to an envelope follower (I use Cold Mac)
  3. Patch the envelope follower output to the filter FM input

You then get dynamic filter modulation which is related to the volume. The shared filter means that the behaviour it’s more like a Poly 800 than a Juno 6 but it’s a handy technique. In theory if you had 6 filters and 6 envelope filters you could do each voice separately.


#262

@Galapagoose There appears to be a bug on the new firmware, as discovered by someone over on Muffwiggler.

In Sound mode, Intone CV input is behaving weirdly - you get limited variation in the amount of intone change and at higher CV levels in appears to reverse.