"Just Type" Beta Testers

teletype

#263

@ghost
Fixed this and uploaded a new firmware here.

Appreciate if you would send it on to the folks who were asking!


#264

Thanks for the speedy response and update. I’ve passed it on.


#265

Heard reports that some folks missed the slower speeds of the original firmware, so there’s a new v3.0.4_slow which is closer to the original ramp times of the original firmware.

The overall pitch range of v3 is slightly narrower (it was too difficult to tune without a FINE control), so it won’t get quite as slow, but something like 15 second cycles in shape mode, down to slower than 1 minute with negative CV into TIME. That’s for IDENTITY out, so you can get down to 6minutes from 6N…


Just friends not so slow anymore
Mannequins Just Friends
#266

God bless you! This is great. Thanks. :slight_smile:


#267

Oh, nice… since I have two I can have it both ways :kissing_closed_eyes:


#268

@Galapagoose I think I’ve found another bug.

In Just Type synthesis mode, using transient (also cycle, although I rarely use this)- notes get stuck on if the attack section is too long. E.g Intone 12 o clock, time 9 o clock. Occurs with both JF.NOTE and JF.VOX . If you turn intone a little CCW or time CW you can stop this from happening so it seems to be a factor influenced by the combination of the 2. I’m using the latest firmware (non slow version)

This is a shame is it prevents nice slow attack envelopes being used, which I have a particular fondness for…


#269

Are others having this issue with just type?


#270

Yes, I have the same issue too.


#271

I have seen this happening as well, in synthesis/transient mode


#272

I noticed this behavior just this morning. Intone was around 12 and time was around 9/10.


#273

Mine get stuck last night in when i was in sustain/shape position but i don’t remember what i was doing with my TT… :sweat_smile:


#274

Not going to be fixed til January I’m afraid. Other priorities.


#275

No problemo, glad it’s on your radar. We can’t expect every fix from you to happen in under 24 hours… :smiley:


#276

So, I’ve been running into a strange issue. I have a Just Friends module that I recently got and I think it’s running a newer firmware, as it seems to respond to Just Type/Teletype commands. I’d like to make sure it’s totally updated though…

I haven’t been able to get it into either calibration mode or firmware update mode. I tried recycling the power quickly, plugging my case (Pittsburgh Structure 208) into a different wall outlet, as well as using a WMD Soft Start module I have to plug in the module power. Also tried plugging run into my phone instead of motu interface in case there was some grounding issue. Has anyone run into this? The module is just starting up normally and all the lights are lit/blinking as usual.


#277

Having an issue — I just updated Teletype to 2.1.0 and Just Friends to 3.0.4 without problem. Both modules function on their own. However, any JF command freezes Teletype. I’ve double checked the i2c cable orientation, and discovered I initially plugged it the wrong way around. When I unplugged the i2c cable, the JF command I entered in live mode cleared, but any subsequent JF command froze Teletype.

Any help or hints would be much appreciated. I’d love seeing these two communicate, there’s just so much potential!


#278

how many devices are on your i2c bus? if more than 3 you need a powered busboard.


#279

A single one. (20 characters)


#280

and you power cycled your modular after making sure the i2c cable was correct? do you have a second i2c cable to test with?


#281

Yep, I’ve power cycled and tried both with a regular 2x3 cable and a 2x8 power cable. I have an analog scope on hand if that can help figuring out what’s going on.


#282

try downgrading your firmwares to confirm the physical connections are working