"Just Type" Beta Testers

teletype

#283

I’ll try Teletype 2.0.0. I can’t seem to find anterior releases of Just Type?

EDIT: Teletype 2.0.0 + Just Type 3.0.4 yields same result. Also tried a third cable.
EDIT: Reinstalling Just Type 3.0.4 also did nothing.


#284

Is it possible with Just Type to have variable wave shapes per output? IE outputs 1-3 would be a standard sign wave and 4-6 would be more of AD envelope shape? I just read through the manual and skimmed this thread but didn’t really find an answer to my question so I was hoping someone might be able to provide some insight.


#285

The wave shaping is global.


#286

Gotcha that’s what I thought, thanks!


#287

@Galapagoose - is there any other way to update the firmware? I’ve tried several times and can’t get the firmware update process to work. Tried using my computer and phone, disconnecting/reconnecting power, but I still just get regular behavior in my Pitts 208 case. I’d like to install the slower version and also keep up with any bug fixes.


#288

The other approach requires a custom edge-connector adaptor, st-link, and setting up the whole toolchain, so it’s probably easier for us to troubleshoot the audio bootloader…

What behaviour are you experiencing? Is the module entering bootloader mode at startup? Is the audio process failing somewhere? Which hardware version are you running?


#289

Bought the module last month from Control, so it’s probably the very latest version. I followed the instructions and when I boot, the lights are blinking/pulsing. It behaves as if you had set the knobs to their lowest setting. There’s no indication that it has entered any sort of firmware update / bootloader mode since it functions the way it would normally. None of the troubleshooting steps seemed to produce different behavior.


#290

To confirm you’re in sound and cycle mode? Does the RUN jack work correctly? It sounds like it could be an incompatibility with the power supply.


#291

Yeah, using sound/cycle and RUN works fine…I re-read the directions a bunch of times to make sure I wasn’t screwing up, haha. I think it is most likely something related to the power supply. Can’t remember if I tried it, but I have a WMD soft start module (adds a buffer to the rails so they should power up evenly) that I could attach to the power connector.


#292

Oh yes, do try the soft start! Hopefully that will solve the problem. It’s a difficulty with tuning the bootloader – you want it to skip past it as quickly as possible so there’s no noticeable lag when you turn the modular on. However, the quicker it is, the less time there is for the reading of the pots to settle to accurately choose the mode.

Let me know how it goes, as it would be good to have a list of cases that cause issues so I can make an effort to tune it to work for all.


#293

I’m going to play devils advocate and reserect this question. Last night playing geode mode I couldn’t help but think about how much fun it would be to have a second JF in synth mode


#294

So, I tried with the soft start and it didn’t make a difference… I bought that thing since I had trouble with an Audio Damage module, but it never fixed any issue for me.

I would be curious about the other way to do this w/ adapter/toolchain/etc, as I don’t see any other way around this besides getting another small case to try with. May do that at some point just to have a second case for testing/etc, but not at the moment.


#295

was casually bumming through this thread, and was like “i wonder where this guy lives, maybe someone’s near him w/ a different case to try?” and noticed you live in pittsburgh. which is where I live. Followup, if you want to try another case and didn’t mind meeting a random someone off of an internet forum send me a DM. I’m in Lawrenceville, and had luck w/ this update at least the one time i got mine updated.


#296

Awesome, that’s really kind of you! I’ll DM you.


#297

Listen to this stunning composition using Just Type: https://youtu.be/GTuIdIta8Bg


#298

super cool track!
JF is doing the 4 voice chord and mangrove the upper sound?


#299

I think so. I wish I was the author of the track. I am only an admirer.
I just put in my order for a TeleType myself (already have a Just Friends), see if I can make equally beautiful pieces of music!


#300

Actually, if you look into the comments, the author has written a bit of a patch note about the piece. The chords are Just Friends reading through 4 Teletype patterns.


#301

paging @ellips_s. beautiful stuff.


#302

hi hi hi everyone. thanks for all the kind words on the piece, thanks to @Dan_Derks for bringing my attention to the discussion happening here, and thanks to @nschutten again for the kind words and sharing it in this thread. feeling very humbled and blessed to be a part of this great community :purple_heart:

some background: my musicianship was developed on the guitar, which remains to be my go-to instrument for composition. i love open, drop, and spread voicings, which are so easy to do on the guitar, but without the combo of just friends and teletype, incredibly tricky on modular (assuming you even have the number of oscillators, vcas, envelopes to acheive basic polyphony anyways). simply put, the power of these two modules is just so incredible and inspiring.

as i said in my comment on the video, and what others have figured out, they are four voice chords, with each note being called from it’s respective tt pattern. the other trick here is using one trigger to advance the four patterns, but using delay prefixes to call the other voice scripts. this is how i get the guitar inspired “strumming.” the idea and implementation of this is so simple, but the effect is so profound that this is probably my favorite modular-only composition to date. i’m glad you all are enjoying it too.

although this is a thread for just type, for reference of what else is happening: one mangrove + my trusty delay pedal is the high melodic line, another is the kick. a self patched cold mac is the crackly noises. white whale is clocking the chord changes and sequencing the mangroves.

i’m happily sharing my teletype scene below to hopefully inspire others. I probably did some commands in live mode to shorten the trigger pulse length, and my memory fails me on what exactly i was doing with TXo in this patch, but it’s essentially using the param knob to set both attack and decay of the envelope. i typed this here quickly so apologies for any glaring errors, and also any tips and ideas on making this code more efficient in less space are always welcome and appreciated for future work :slightly_smiling_face:

I:
L 0 3: PN.END I 3
JF.MODE 1; JF.GOD 1
JF.SHIFT N -3; M 25
L 1 4: TO.ENV.ACT I 1
L 1 4: TO.CV.SET I V 8
L 1 4: TO.TR.P.DIV I I

M:
A PARAM; B ABS - 16320 PARAM
A + 10 >> A 4;  B + 10 >> B 4
L 1 4: TO.ENV.ATT I A
L 1 4: TO.ENV.DEC I B

1:
TO.ENV.TRIG 1

2:
JF.VOX 1 N PN.NEXT 0 V 4
DEL 30: SCRIPT 3
DEL 60: SCRIPT 4
DEL 90: SCRIPT 5

3:
JF.VOX 2 N PN.NEXT 1 V 4

4:
JF.VOX 3 N PN.NEXT 2 V 4

5:
JF.VOX 4 N PN.NEXT 3 V 4

6:

7:
TR.P 4

8:
L 1 4: TO.TR.P I

patterns:

 0 5 9 16
-5 0 2 7
-5 0 4 11
-1 2 4 7

Latest tracks + videos