"Just Type" Beta Testers

teletype

#123

Baha no honestly it’s been great - we have been listening to it for hours. But yeah. Also want to be able to do other stuff with it too is the thing.


#124

That sounds awesome…

Sound a little bit like one of the ADC inputs is not connected and is floating. Do any of the jacks or knobs do nothing?


#125

sounds like a power starve - i would check your cable and whatever power you are using. You have enough juice?


#126

for clarity

how many JFs can be used simultaneously for JT maneuvers with 1 teletype? is that dependent on other modules adressed on the same ii bus?

sorry if this has been asked & answered before


#127

I was wondering the same thing. It would be cool to get a pair together.


#128

Please email service@whimsicalraps.com – seems like something’s happened to that module, as it obviously wouldn’t have passed QC like that!

Unfortunately the DC characteristics of the audio rate inputs and outputs aren’t precise enough to do this kind of thing. Additionally, for all the RUN modes I try and make sure the 0v dummy-cable setting is a sweet spot of the module. Plus in STRATA the +/-5 range is essentially a traditional sustain control which felt like a nice alternative functionality.

Previously all channels were cycling, but now only ID is cycling & the other channels are in transient mode, driven by the EOC from ID & their trigger inputs. There’s a lot of weird things right now because the triggers are only tested ~1.5khz but I’m working on a solution to that.

Come on folks! Let’s get one working well before opening that can of worms!


#129

I’ve found another issue with Sustain mode: On closer inspection, both sound and shape in Sustain mode also always complete the upwards ramp regardless of gate length i.e. performing a complete cycle before allowing retriggering. If you release the gate before the upwards ramp is complete, it will still go all the way up. This behaviour extends to STRATA mode also.

Thanks for the explanation, makes perfect sense. I actually tried to achieve this using manually tuned levels from pressure points and the results were not as cool as I’d hoped anyway. So no loss :smiley:


#130

Sorry bout that…got mine updated and listened to floom a bit before going to work. Planning to test typed commands when i get back

This is really exciting!


#131

Can anybody help solve this in terms of x? My math brain is failing me at this hour…

y = a*x + (a-1)*(b * log2(x+c) + d)

y, a, b, c & d are all known constants.


#132

Typing it into Wolfram Alpha as is (link) gives a root for x, which is pretty scary-looking at first glance, but should be fine once you replace the constants with their actual values.


#133

I tried Wolfram to solve for x and it ran out of “free computation time” and asked me to buy premium…


#134

I just spent a few hours playing around in the synth mode. Everything works great on TT 2.0.0
Thank you.


#135

Thanks for the heads-up about Wolfram - I never knew it would solve equations and give derivates etc.

I’m presently trying to solve for the discontinuities in a retriggered sustain envelope. If it’s precisely at any of the settings (100% log, or 100% triangle) it works perfectly, but as it fades between the two, there is a discontinuity that fades in and out. Alas it doesn’t seem possible to solve for it directly - so I’ll see if a reverse-lookup search can be fast enough not to blow up the whole system…


#136

Try this:

x=
−0.30103abc − ad + 0.30103bc + d + y / 0.30103ab + a - 0.30103b


#137

Spent another couple of hours in synth mode. This is my favorite update of any firmware ever.

In synth mode, FM input does not respond to CV. The FM knob does do its job, but the input does nothing. Is this normal behavior, am I missing something?


#138

This is my favorite update of any firmware ever.

could not agree more!


#139

New beta posted 09/01. Looks like we’ll be shipping new units Monday instead.

Full notes & download link

This update corrects all of the abovementioned bugs. The sustain-discontinuity thing is still in development.

Big difference - calibration procedure has been added so you can (very easily) calibrate the v8 TIME jack (and remove the FM jack DC offset that was causing the freezing envelopes mentioned above). Please let me know how you go with that procedure. Obviously pictures would be an easier way to explain the settings, but that won’t happen til monday. Let me know if it’s unclear / doesn’t work.

Also - try out JF.TUNE! It let’s you reconfigure the ratios of the different channels so you can make all kinds of weird chords (and then all the grey area in between). You could even set it so it’s 6 sequential octaves, or perhaps 6N is a sub-octave to ID etc… many possibilities! Also - that setting will persist between sessions (your tuning table is stored in flash) so if you could confirm that’s working it’d be great!


#140

just tried the calibration procedure a few times, after flashing the latest firmware, and failed every time. I can easily switch to the calibration mode (identity lit) , but then it seems to be stuck in this mode, after following the exact steps, with no led feedback indicating the steps (identity always lit).
also, a few seconds after I switch to the calibration mode my ii connected teletype freezes (I wanted to use it for the 2V reference).
btw the update is fantastic, and the calibration sounds simple enough, I hope I’m not making a very obvious mistake!

edit: TT was sending ii commands to JF during calibration, stopping that solved this issue.
however, now after ending calibration by switching to sound , expecting normal behavior, there is no response from JF, outgoing signal or led. after flashing the older firmware functionality is normal again.


#141

im having a similar issue. I’m on v1 hardware with no run jack update. The previous beta i loaded without issues. The first step looks ok with loading the firmware. The only difference here is that when the previous beta finished all the led blinked. On this beta it doesn’t do that - it goes to 1 lit led for the start of calibration mode. During calibration i do get led feedback with each led lighting up per step. Its just at the end when finished the unit doesn’t work at all. I reflashed with the previous beta to get it to work. I tried this 4 times and still can’t get it to run the latest firmware. There seems to be some issue getting out of calibration mode and getting it to read the latest firmware. For the 2v i was using an offset/attenuator from the isms case measured with an o’tool.

yes, this is what happens to me


#142

@derz @mlogger: Can either of you check if there is negative voltage at the outputs in sound mode?