"Just Type" Beta Testers

teletype

#143

o’tool shows very small amounts on some of the outputs, around -0.02 V


#144

yep, same issue here. when I flash the 8/28 version (‘main.wav’), it updates fine (lights flash, I turn off system, unplug, acting normal). but trying to go to 9/1, after flashing the identity light is lit and stays that way, and after restarting, I get almost no response from JF, just a few flashes when flipping the switches, but no response to triggers etc.

edit: ah shit i need to read a bit better. “(nb: if you’re flashing the firmware, calibration mode will run automatically after flashing is complete)”

let’s give this another go…

edit 2: okay now it’s flashing identity LED and 5N led. gonna try beta-c @Galapagoose


#145

Ok - I think it may be due to a previous version writing data to flash & spoofing the test.

Here’s beta-c with a more robust initialization test routine.

(one aside: you could try running JF.TUNE 0 0 0 to reset the tuning table)


#146

@Galapagoose, beta-c updating just fine on run-fixed JF! previous version was not working, as others reported.


#147

@Dan_Derks ah fantastic. I think the prior beta from last year may have set some bytes in flash too which the new version was misinterpreting as “i’ve already been setup”. It now checks to make sure the tuning ratios aren’t x/0 (ie. infinite pitch!), and re-inits if they are.

Just to note, whether your JF had the RUN update applied will have no impact on the functionality or flashing procedure.


#148

so far, both JF2bb and JF2c keep resulting in an identity led staying on and the 5n led flashing. it works when I flash it back to the 8/28 revision


#149

beta-c runs fine !
after the firmware flash + calibration MIX had no signal for some reason, with all other outputs working fine. after power cycle everything seems to be ok.
thanks @Galapagoose


#150

Is this after the audio file has finished?

  • You play the audio file (the 5N and 4N alternate flashing).
  • Sound file finishes
  • ID led lights and the module is unresponsive?

#151

yep! file finishes, then ID led solid on and 5N flashing for both 2bb and 2c

edit: it looks like it’s still updating almost, but it just stays that way


#152

Definitely sounds like it’s still trying to update. How are you playing the audio to the module?


#153

via audacity. 16 bit 48k mono from macbook headphone out, connecting exactly as described in the firmware update how to


#154

Right, I’m thinking perhaps the file isn’t finishing completely? It sounds to me like it’s still in the bootloader (so long as the 5N is still flashing at the same rate as in bootloader mode), so can’t be the new code, but rather the processing of the audio file.

I’ll upload another wav to see if anything changes…


#155

wait, no, I got it using 2c! I tried it out of audacity. I think perhaps it wasn’t loud enough, or something was happening with audacity. in calibration mode now.


#156

Lots of bugs to report with JFbc I’m afraid:

Being in Cycle/Sound mode seems to always be in Floom mode even without run patched.

Floom mode issues:
When turning FM manually CCW - no FM (or intone modulation) is added
When patching CV to FM it works both positively and negatively BUT both seem to be adding doing standard FM whereas I would expect negative CV to cause Intone modulation?

Plume mode is likewise always engaged with sound/sustain despite no run input (However PLUME seems OK in itself) Same story with SPILL - always engaged.

Shape Bugs:

Shape/Transient - seems to be OK. SHIFT seems OK

Shape/Sustain - Not working correctly - Not holding high sustain plateaux. If ramp is completely CCW creates a weak negative envelope. If ramp is between full CCW and 9 o clock creates weakly positive envelopes. On the plus side, STRATA seems to work well! (and the envelopes look great!)

Shape/Cycle - Not functioning: There is no cycling at all. However, VOLLEY seems fine

Is everyone else experiencing all these issues? I reflashed the firmware a 2nd time just to be sure and the issues still remain.

As for calibration: Before calibrating tracking was pretty much perfect over 4 octaves. After calibrating it loses about 11 cents over 4 octaves so slightly worse but no bad so I’m not too bothered. I actually tried to skip calibrating because of this but I couldn’t seem to get JF to function at all without going through the calibration.


#157

WRT Calibration, I wasn’t totally clear: The ‘captured zeros’ at step 8 - does this mean all knobs fully CCW? Or should we move some to 12 o clock? I left all fully CCW - just wanted to check this wasn’t the reason for this odd behaviour…


#158

@ghost @Galapagoose I have these issues as well.
additionally , in just type synthesis mode, some of the JF.TR triggers are skipped. also, is it normal in this mode that the channels are triggered without sending a ii or hardware signal?


#159

Sounds like RUN isn’t being detected at all - I’ll check the soundfile on my v1 module.

re: calibration, it’s a good idea to connect your voltage source, set to 0v for the ‘zeroes’ setting. Then switch to shape and turn the voltage to 2v. Let me know if that is better? I can also add a ‘factory reset’ somehow… If anyone has suggestions on how to make these mode selections less confusing i’d be happy to hear!

also on calibration: this is for the CV jacks only (not the pots). I’ll make this clearer in the docs.

//
Ok- apparently I uploaded a firmware for v2 hardware with the different run jack implementation… will fix momentarily.

//
Sorry for the mixup!
Here’s JF2d.

This also adds support for negative tuning for JF.TUNE (allows you to force oscillators to run backward so RAMP behaves inversely).
Now the INTONE-FM modulation will reflect any non-standard JF.TUNE settings too.


#160

Side comment: you’re running a really solid beta here, @Galapagoose. Thank you for the great work.


#161

this one is working for me :slight_smile: I just stuck with the 2v for calibration and all looks good so far.

the first time i tried with 2v then unplugged and put in 0v for the zeros and the sound was all over the place, so went back with the original 2v all the way. (maybe i shouldn’t have unplugged?)

i think it might be a good idea to keep the firmware procedure and calbration procedure as 2 complete separate processes instead of both together as one file.

my word - the Floom sounds like i have a Hertz Donut in there :slight_smile:


#162

Still getting exactly the same issues described above with JF2d.