"Just Type" Beta Testers

teletype

#163

just to confirm: Synthesis Mode auto-triggers itself, yes? I wanted to clock the pulses with timed triggers from Teletype, but that’s proving hard to do with this default behavior – any tips?
edit: if i bring Time down far enough, I can trigger externally, but it also seems that each TR.P double triggers.


#164

Having the same issue


#165

You mean the same as @ghost? You’re stuck in RUN mode?


#166

Synthesis mode will create a note whenever you type JF.NOTE or JF.VOX yes. I could add another function like JF.NOTE except without triggering if that makes sense to people. I don’t see how that could work with the polyphonic allocation though.

Regarding double triggers, do you mean from the front panel triggers, or via an JF.x command? Can you tell if it’s being retriggered by the falling edge of the trigger, or some other behaviour? Are you in Transient or Sustain mode? Transient mode should ignore falling triggers, while Sustain mode will hold the note on until it receives a velocity=0 command. How does your observed behaviour differ?

@ghost
I’ll look at the diff for what changed in the RUN jack detection between the earlier working beta and the new one. Very strange to me that it seems to be working for some folks but not you. You have the same hardware!
Also - did you have a chance to test if the calibration procedure worked any better when leaving the cable connected for 0v (with your voltage source set to 0v)?

@ghost and @glia
With the always-in-RUN firmware, could you try plugging/unplugging the RUN jack and see if it changes the behaviour of the jack? eg. If you’re stuck in PLUME mode you should have super long decay on notes with no jack attached, which should become vactrol-y blips when you connect a dummy cable to RUN. Please let me know if this is not the case!


#167

@Galapagoose, Synth Mode questions were a minsunderstanding about the voltage assignments in the VOX and NOTE ops in addition to not leaving cycle mode. so sorry!

a reboot has solved the double triggers.


#168

Just to clarify, the ‘always-in run’ behaviour only seems to be for the Sound modes. The Shape modes have some issues but not in the same way. (exactly the same as in JF2c)

In Plume mode, with no jack in the run input the decays are longer than if a dummy cable is inserted, but I wouldn’t say super long. It’s comparable to an input of -2.7v to the run input. There is also a change in behaviour when entering Floom mode - no run input vs. dummy cable but this is harder to quantify.

I agree, I’ve tried reflashing twice but no change. I wonder if @mlogger could confirm that shape/cycle mode is working properly?

I’ve just tried this. Slightly better. I’m losing 9cents over 4 octaves so still not as good as the original. How accurate does the 2Vs need to be? I’ve been trying with various monome modules to do this and none are exactly getting 2v to 3 decimal places (as measured by O’Tool). The best I’ve tried is Earthsea which gave me -0.002v and 2.003v. I would assume that that would be accurate enough.

Another thing I’ve noticed that I never did on the original firmware is that when Ramp is set to fully CW or CCW there is an unpleasant digital noise added. It is much more noticable at higher frequencies. (I’m testing this on Plume, with the gate held open. Also present on Floom with no FM) And actually at other RAMP values this is present but to a much lesser extent, confirmed on the O’Tool. I never remember noticing that the JF waves were anything but perfect previously although maybe I just wasn’t looking so closely!


#169

I’m seeing the same behavior with shape modes. exactly as @ghost described actualy:
shape/cycle does not work at all. I’m getting no signal whatsoever. volley is ok.
shape/sustain does work but envelopes not working correctly. Maximum level does not stay while the gate is high. looks very similar to transient . strata works as expected.
shape/transient and shift are ok.


#170

shape / cycle mode - this does not cycle and does not cycle with nothing in the run jack. However, if i put a trigger in the run jack and another trigger in one of the trigger in jacks, it cycles. I then get audible blips out of the mix jack and the trigger outputs.

shape / sustain mode - this does nothing with one trigger in the trigger in and nothing in the run jack. It does work if i put a trigger in run and a trigger in the trigger in. Similar to the shape / cycle mode issue.

shape / transient mode - this is ok with one trigger and nothing in the run jack.

sound / transient is cycling ok and works with run jack also.

sustain / sound - works with a trigger in and nothing in the run, audio through mix out works. Works also with run jack trigger in and trigger in. Liking this one alot - don’t touch anything about sustain / sound! Its fantastic :slight_smile:

sound / cycle works fine and cycles - with no run and with run jack and sounds like a Hertz Donut. I like this alot, don’t touch it! :slight_smile:

@Galapagoose, so yes - very similar results as @ghost and @derz but wereas they said shape/cycle, shape/sustain were not working, which was correct, i managed to get something when triggers were added to run and trigger in’s jacks together


#171

In synthesis / sustain TT triggers and hardware gate signals work well, with sound sustained during high. switching to transient during high trigger on any channel, holds that channel on sustain and signal goes on even with trigger going down.


#172

heres some floom mode


#173

@mlogger @ghost @derz @glia
Can one of you check if this firmware fixes the problem (if any one of you finds it doesn’t work, please don’t anyone else bother).

(also nb: calibration mode won’t follow the firmware update - it’s accessed after reset with the same settings except all knobs at maximum)


#174

9cents over 4 octaves is 9/(1200*4) = 0.001875 error
5mV over 2V is 5/2000 = 0.0025 error

Seems to me like it’s pretty accurately following the calibrated input. How are you measuring the tuning, and what are you using as the voltage source when doing so? Is it possible to use the same voltage source for calibration as you do for testing?

Regardless, I’m adding a ‘factory reset’ right now to allow one to revert to the mathematically calculated values (which don’t take component variation into account).


#175

Yes! I’ve quickly tested all run and non-run modes and all seems to work as it should: Really awesome!

The only thing I’ve noticed that isn’t quite right is that in Floom mode, negative CV to FM does normal FM and not intone modulation.

Calibration: I’m using the o tool (first edition) for measuring all voltages and tuning. For setting the voltage I’ve tried a few things: Ansible (Levels and Kria), Earthsea and Intellijel uScale. I’ll have another look at this tomorrow when I have some time.

Just to reiterate what many others have said, this is an incredible update. Thanks for all the hard work you’ve put into this.


#176

Thanks, I appreciate it! Hope I’m not coming across too direct - I’m just trying to get this update finished so we can ship the new ones and move on to the next big project.

Re: FM input in synth & floom modes is designed to work that way. Negative voltages can thus decrease the panel setting. Otherwise CV would always be increasing the amount of modulation. I agree it’s complicated and muddy’s the functionality somewhat.

Re: calibration. If you calibrate using say Earthsea as the voltage source (0v and 2v), does it accurately increase the pitch by 2 octaves when you flip between those voltages after calibration? My thinking is that even if it’s not “correct” it should accurately conform to the calibrated voltage.


#177

Not at all too direct :slight_smile: I think we all find it a really privilege to be able help!

WRT FM on Floom mode input - that makes much more sense than how I expected it to be actually. Here’s a video of me playing with it…love the different characters switching between FM and intone mod.

Edit…also:

!!!


#178

confirmed working in my camp with new beta. using TT outs that supply ~2.030V, but it tracks accurately when flipping between V 0 and V 2.

quick q: getting C4 @ -28.2 cents (257.38 Hz) from O’Tool in JT Synth Mode, measuring A=440 Hz. at A=432 Hz, it’s only +3.3 cents off. I tried JF.GOD 0 to align JF with A=440hz, but neither 0 or 1 had an effect on the module’s pitch. this was consistent before and after calibration, which I assume only affects front panel v/8-based modes.

edit: WEIRD. the JF.GOD command only has an effect after leaving and re-entering Synth Mode. so, no immediate shift. but, JF.GOD 1 now puts my read at ~252.68 Hz, which is also -28.2 cents from an A=432 Hz C4.

so, I guess I’m just off by -28.2 cents, regardless of ‘God’ note.


#179

Oh good point. I totally eye-balled the 440hz tuning to get it running and need to dial that one in. Added to the issue list!

Thought .GOD was working, but will reconfirm. Will investigate the required re-entry.


#180

related: .SHIFT is amazing. very helpful. have to do the same re-entry to get Synth Mode to recognize a change.


#181

Think we’ve arrived at a release candidate. I’ve made it through my list of required features, and a bunch of extras, plus dealt with all of the bugs I could discern from the above posts. Still haven’t had time to write up the documentation properly, so gives one final day of beta testing.

Ok! Full details on the JT page.


#182

can i just double confirm the calibration procedure.
Is this correct regarding when to apply 0v and 2v?

  1. The module is currently reading the CV input values, so make sure you don’t have any cables plugged in, except the RUN jack which should remain (but no signal going to it).

4.5. Attach an accurate voltage source providing 0V to TIME cv input

  1. Switch to shape mode.

6. Turn the voltage to 2v.

  1. Switch to sustain mode (The v8 signal is now being read).