Linux on the desktop


#82

seq64 is planning to address this issue eventually. There’s just a lot of other/ground work needed to get there first.
Also afaik all or at least the majority of the stazed seq24 work has been incorporated in sequencer64.

For anyone using gentoo we’ve made sequencer64 as well as some other sound production related packages that aren’t in the gentoo tree available under the audio-overlay https://github.com/gentoo-audio/audio-overlay


#83

Just a quick update…

I’ve finally found some time to get myself switched over to Linux full time on my desktop (still running OS X on my laptop). Somehow I managed to put together a list of parts to order at the end of the summer holidays and get it built once my eldest daughter was back at school.

I’ve gone with Arch Linux, still not especially fond of it, but Gentoo seems like it’s struggling with a lack of developers (and systemd is a second class option there).

In the end I went with a Core i7 6850K (6 cores / 12 threads, 44 PCI lanes) and an X99 motherboard, it’s last generation but no compatibility issues with Linux, and the price on the 6850K has dropped to not much more than a 7700K in UK.

The X99 chipset should be really good for virtualisation. If I stick a second graphics card in there I should get near native levels of performance with virtualised Windows, and if I’m really luck OS X too. In theory I can pass through USB and Firewire cards directly, so I should be able to use the VMs for audio too.

Speaking of audio, I’ve just got a Jack-DBus setup, so far I’m going with piping ALSA to PulseAudio, and then sending the PulseAudio stream to Jack (and then onto an SPL Crimson1). I’m going to try the other method, which is to get Jack to ask PulseAudio for the sound card when it starts up.

I’m also tempted to get my MOTU 828 mk3 to work with Jack too, then I can run Jack and PulseAudio in parallel. I just need to buy a Firewire PCI card.


1 Annoyingly the SPL Crimson isn’t working properly in Linux, which it should as it’s class compliant, I guess I’ll head on over to the ALSA mailing list at some point and see if I can get to the bottom of it and maybe even provide a patch.


#84

Hi everyone…

I’m in the mood for playing with samples on my OP-1 and in SuperCollider. Anyone care to suggest some sample editors?

I have got Audacity up and running. But it doesn’t cope brilliantly with my 4K monitor.

Bonus points for something that uses a text file to specify edits and fades, etc, etc. But I guess I’d like something graphical to find the edit points in the first place.


#85

@sam have you tried shuriken? https://rock-hopper.github.io/shuriken/


#86

No. But it looks cool. Has an Arch AUR package too.

Will give it a go this evening.


#87

I’ve been using linux on my laptop for nigh on 15 years now. First on an ASUS barebones laptop, now on my MSI.

I started with slackware, then moved to gentoo, and for some reason I recently decided to go CentOS for “stability”, but I’m regretting that every day and my /opt/ folder is filling up with things I’ve had to compile from scratch (and their libraries!).

I used to use fluxbox for a window manager, then I moved to ion, and now I’m using a bone-stock xmonad install and it works just fine for me!

Trollbait :wink:

  • vim > emacs
  • DVORAK > QWERTY
  • gentoo is rice (n.b.: but I love it)
  • ncurses > any other UI
  • OpenBSD > SELinux

#88

Linux was my first real OS in 1998. Redhat 5.2, a Pentium made from dumpster diving and dial up. I really loved Gentoo 2002 - 2008 (still do) … eventually my job started to consume a lot more of my thinking day and I had less time to tinker with my OS. I too was a Slackware user and used it for a development set up for a long time … I still have Patrick’s book of commands and other around here some where … Slackware and Gentoo are both great package management systems / variants of Linux. These days I treat machines and virtuals as more disposable environments that get replaced or hacked to bits in order to pull off some piece of work, so I use Ubuntu for that. Although it is usually via a minimal install and then built a lot from scratch and source.

Lately my favourite tool in Linux is Zsh.


#89

I recently found a 2009 imac in the hard rubbish. I’ve got it running Mint Linux with an unused MAudio 1814 firewire box. For music stuff I’m using Bitwig Studio and Puredata. Not having Abelton Live was a barrier for me running Linux in the studio but Bitwig has pretty much solved that.


#90

I’ve been trying to get my firewire MOTU 828mk3 Hybrid working with Linux. Unfortunately FFADO doesn’t support the ‘hybrid’ version. Looking at the source code, it’s probably an easy fix (they support a different ‘hybrid’ interface), but I really don’t have the time.

Turns out that the ALSA firewire support is better. Haven’t got very far yet, but it looks promising. Anyway, I’ve been completely stumped with how to get ALSA to tell me how many channels a device has.

So far, the best I’ve got is using sounddevice:

IPython 6.2.1 -- An enhanced Interactive Python. Type '?' for help.

In [1]: import sounddevice

In [2]: sounddevice.query_devices()
Out[2]: 
   0 HDA Intel PCH: ALC1150 Analog (hw:0,0), ALSA (2 in, 6 out)
   1 HDA Intel PCH: ALC1150 Digital (hw:0,1), ALSA (0 in, 2 out)
   2 HDA Intel PCH: ALC1150 Alt Analog (hw:0,2), ALSA (2 in, 0 out)
   3 HDA ATI HDMI: 0 (hw:1,3), ALSA (0 in, 8 out)
   4 HDA ATI HDMI: 1 (hw:1,7), ALSA (0 in, 8 out)
   5 HDA ATI HDMI: 2 (hw:1,8), ALSA (0 in, 8 out)
   6 HDA ATI HDMI: 3 (hw:1,9), ALSA (0 in, 8 out)
   7 HDA ATI HDMI: 4 (hw:1,10), ALSA (0 in, 8 out)
   8 828mk2: - (hw:3,0), ALSA (14 in, 14 out)
   9 sysdefault, ALSA (128 in, 128 out)
  10 front, ALSA (0 in, 6 out)
  11 surround21, ALSA (0 in, 128 out)
  12 surround40, ALSA (0 in, 6 out)
  13 surround41, ALSA (0 in, 128 out)
  14 surround50, ALSA (0 in, 128 out)
  15 surround51, ALSA (0 in, 6 out)
  16 surround71, ALSA (0 in, 6 out)
  17 iec958, ALSA (0 in, 2 out)
  18 spdif, ALSA (0 in, 2 out)
  19 pulse, ALSA (32 in, 32 out)
  20 dmix, ALSA (0 in, 2 out)
* 21 default, ALSA (32 in, 32 out)
  22 system, JACK Audio Connection Kit (2 in, 2 out)
  23 PulseAudio JACK Sink, JACK Audio Connection Kit (2 in, 0 out)
  24 PulseAudio JACK Source, JACK Audio Connection Kit (0 in, 2 out)

Anyone know the best way to get ALSA to print out some info about my sound card?


#91

Doesn’t amixer or alsamixer show you that if you’ve selected the correct device?


#92

Yep and another way to do it is aplay -l


#93

yeah sounddevice looks like a wrapper for aplay -l.
sorry, i’m blind. looks like it does indeed do something extra to query the i/o channel counts.

aplay -l doesn’t really tell you the channel count. some devices have a subdevice for each channel and some only have one subdevice that takes a multichannel stream.

amixer and alsamixer likewise show you plugin interfaces with whimiscal relationships to physical device channels.

same goes for attributes like supported sample rates and PCM formats.

closest i’ve got is something like:
aplay foo.wav -D hw:0 --dump-hw-params

but even then it just shows the range of values the alsa thinks it can use, which may more may not correspond to the physical capabilities of the device (depending on the driver i guess.)

i am on the verge of writing something wrapping snd_ctl_open() just for this. it’s crunchy though. like here is the portaudio source where it “gropes” the device for min/max channel count:
[https://app.assembla.com/spaces/portaudio/git/source/master/src/hostapi/alsa/pa_linux_alsa.c#ln834]

actually come to think of it maybe i can just wrap portaudio.
shocking that there isn’t an easy tool to do this in alsa-utils.


#94

Oh and quick note, for anyone else unwilling to allow PulseAudio to taint their system, I’ve been using apulse to provide emulation of PulseAudio in ALSA. It’s included in Gentoo so I’ve never had to build it.


#95

They only tell you stuff if there are ‘controls’ that can be changed. Both my MOTU 828mk3 and another USB device I have present no volume controls or otherwise, so they both show up empty (or rather “This sound device does not have any controls.”).

Almost better of seeing if you can get a patch to an existing tool (such as aplay and arecord). It is shockingly hard trying to get a channel count.

Sadly I haven’t had much success with my MOTU. I got aplay to happily output a wave file, but no sound and my kernel message buffer was filled with lovely messages, such as:

[  193.553114] dmar_fault: 572 callbacks suppressed
[  193.553116] DMAR: DRHD: handling fault status reg 602
[  193.553126] DMAR: [DMA Read] Request device [09:00.0] fault addr fffe4000 [fault reason 06] PTE Read access is not set

Oh well.


Also my SPL Crimson only shows up as a USB1 device under linux (2 in / 2 out 48KHz) instead of USB2 as it does on OSX (6 in / 4 out). I think I’ll try and get that bug fixed first.

I’ve got ALSA into PulseAudio into Jack, and it seems to be working well. Only major issue is that Jack doesn’t like suspend. Once I’ve got my audio interfaces working properly, I’d like to switch to parallel PulseAudio / Jack on different interfaces.

RedHat are trying to replace PulseAudio with a newer standard Pipewire that does video too, but also specifically mentions wanting to support low latency pro audio too.


#96

I’m using an MAudio firewire and it doesn’t show much in Alsamixer other than some spdif related switches. I had to use ffadomixer to get at the mixer settings.


#97

I started my coding adventure very little time ago, and while my Yosemite works well, i have been thinking to install a Linux distro for some time.
I went ahead and swapped my optic drive for a second drive and will go ahead and install a Linux distribution there, so i can have both. Would like to know which one you recommend, it’d be basically for my experiments with Jack, coding study and Linux-Audio related stuff


#98

Lots of thoughts on the subject here. I’m fond of Debian based distros personally, but you’ll see that there adherents of several others as well.


#99

Thanks Jason! saw ir recommended that thread when i was writing the post, but checked right after :neutral_face: so i guess this one can get lost forever like tears in rain


#100

I tried Ubuntu for a bit, before switching permanently to Arch (on my Macbook Pro 8,2). Ubuntu was certainly a good first step in getting familiar with linux, and appreciated that it comes fully set up for use. Arch is the other end of the spectrum, if you haven’t installed something it just isn’t there, but I have had heaps of fun customising. And also it is fast. The same macbook running OS X was really slowing down, and the switch made me realise that the problem was entirely software-side.

As far as audio coding (which was the same reason I made the switch) the only slightly painful aspect is configuring sound, especially with different audio cards. I’ve gotten to a place where everything is routed properly and I just have to not touch anything, but I know that to begin with the interactions between ALSA, JACK and/or Pulse were doing my head in. I think there is another thread here somewhere (titled Linux Audio?) which was very helpful.

Have fun!


#101

Yeah, I think this might be the thread that @pxxlhxslxn is referring to:


The search feature on this forum really works quite well, I recommend it!