Linux on the desktop


#122

I have the R24 which works fine for me under linux (though it mostly lives as a standalone recorder in my bedroom) – maybe a newer kernel would do the trick? I’m running 4.18.9 on the laptop I use the R24 with, but a raspberry pi running raspbian (with an older kernel) doesn’t work with it.

I can’t say enough good stuff about MOTU’s ultralite AVB though, which works great with linux (at least a recent kernel, I haven’t tried with older ones) has great preamps, but isn’t a standalone unit, and it’s a bit pricey.


#123

Though I haven’t used them myself quiet a lot of people seem to recommend/be happy with the current Behringer X air series (XR12, XR16, XR18). They are obviously digital mixers and need software to be useful, but since you’re using a computer anyway it might make sense depending on your preferences regarding how you like to work.
They have pretty good Linux support and have Android an iOS support as well in case you want to use it with those OSes.

Apart from that, any USB device that’s supported on iOS should work because they have to be class compliant for that.


#124

again not sure if this On Topic but i have been having getting amazing results with BitWIg on linux for my quasi ableton fix but someone recently reminded me of and i got a very nice working version of Qtractor which is works fabulous. I also am embarking on a recording project over the web with folks in disparate locations sharing tracks and overdubs and i found that the linux BETA of Reaper is just beautiful and works dreamy.

I also recently got a cheapo Behringer X1222 that works perfectly with my linux setup i mix 12 channels to stereo for my mix [i do the mixing on the device and i do not need individual tracks so it’s perfect] it shows up in jack as HW:CODEC and it a wonderful surprise.

fwiw
Linux shree-linux2 4.4.0-116-lowlatency #140-Ubuntu SMP PREEMPT Mon Feb 12 22:41:05 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux


#125

nice little tool that works great as a standalone recorder, also with cheap usb drives. Very simple and straightforward to use. Only does panning and -10dB pads. No mutes. Good line mixer and recorder for people who don’t know and don’t care about mixing and recording (me). Haven’t used with computers. Requires floating TRS cables as its designed to connect to the mixers inserts.


#126

I’m using the Focusrite Scarlett 18i20 with Ardour on Ubuntu Studio, and very happy with it.


#127

Hey there, y’all. Anyone got jack (specifically jackd with proper realtime configs and security configs :confused:) running on Arch Linux? Figured it’d be nice to have something with specific mention of Norns development, too. I’d love to give it a shot. Might be a nice resource.

I just have xorg and i3 and PulseAudio routed to a cheap USB soundcard. I want to use Jack and a whole bunch of software (I’m okay writing small scripts or something to handle the management) but I can’t seem to get the damn thing booted :disappointed_relieved:.

Even just links to resources that have worked would be great. Work is nuts and I only have so much weekend time to config and so little time to create! :smiley:


#128

I don’t use jack via pulseaudio – it should be possible to rig up via one of these methods though: http://jackaudio.org/faq/pulseaudio_and_jack.html

But starting jack2 (I’m using the jack2 package, not the dbus variant) with alsa as the driver (alsa-lib, alsa-plugins, alsa-utils, alsa-tools and alsaplayer are the relevant packages I have installed right now) has never been a problem for me on arch. I still use qjackctl most often to start it standalone and configure it for a new hardware device, but there are a lot of neat new utilities like cadence that might be worth checking out.


#129

@lazzarello and I set up a workstation with i3, jack, and ardour a while ago. If you’re using the USB sound card as the primary device I’m not sure you want to hook it up to pulseaudio? We did it with Cadence and Claudia directly working on the (in our case, FireWire) audio interface.

What are you trying to run / what’s not working?


#130

to be honest, I need to find a compatible interface but cant justify it right now

I’m just trying to get jackd to start with all the correct realtime permissions.


#131

What did you try? What’s not working?


#132

Arch Linux has given great contributions to documenting the distro. There’s a whole wiki page on Jack.

Pulseaudio is useful but not required to get realtime sound from jack, especially if this is a Norns environment. There’s a bridge between jack and pulseaudio so you can do clever things like route audio from Firefox or Chrome to anything else in your jack connection graph. Latency is…well, bad which is expected for playing audio over wifi over internet.


#133

Pulseaudio is useful but not required to get realtime sound from jack

@lazzarello sorry, but I have to disagree with this. Pulseaudio is neither useful nor required to get realtime sound from jack. It actually might be harmful, since jack requires exclusive access to an audio device to work reliably. See http://jackaudio.org/faq/pulseaudio_and_jack.html for more details on using them together (TL;DR: it’s best to avoid that).


#134

The jack-pulseaudio bridge is the only way I know to get sound from a web browser into the connection graph. If you know a better way that’d be awesome.

@gretchen and I made a karaoke system with real-time pitch shifting and reverb that used YouTube as the music source. Connected via jack.


#135

Using pulseaudio jack sink is the most straightforward way to get sound through jack from the browser, but what does this have to do with setting up jack?

Fun fact: you can build Firefox with jack support for playing Youtube to jack natively, but I’m not sure if anybody is actually doing that in practice.


#136

It has nothing to do with setting up jack. But it’s useful. I’m scared of compiling Firefox. I imagine jackd will kick it out of the graph real fast.


#137

i’ll chime in to agree with @artfwo, the OP question is setting up jack to work reliably. if you’re having trouble there the first thing is to get rid of pulseaudio. (i’ve literally had to do this on at least two systems.) then add it later (with the bridge) if you run into the edge case where you want to process sound from an application that only supports pulseaudio.


#138

+1 for purging pulseaudio. jack setup got infinitely easier once I got rid of it.

Firefox in the Arch package repository comes with jack enabled by default

This post is a bit old, but I found it very helpful for getting ALSA playback -> jack set up. ALSA playback from Chromium is still spotty for me, but so far I’ve opted for using Firefox over the pulseaudio bridge or spending more hours in the linux configuration hole.


#139

I think yall are talking past each other – seems like everyone’s saying PulseAudio can be useful, but you shouldn’t hook it up to your audio devices (directly) if you’re also using jack.


#140

Whelp, I found a slightly smaller one, the Scarlett 18i8 on Ebay for US $279. I also have a 2012 macbook pro, which from what I read has full compatibility with Arch Linux. Here we go!

Anyone have a favorite control surface for Ardour? I’ve written my own XML parameter mapping for an Akai APC40 but it was tedious. It’d be cool if there was some kind of preset control surface that “just works”.


#141

I had PulseAudio into Jack working pretty well, but I never really pushed it. At the moment I’ve got them running in parallel, so PulseAudio out via the builtin sound card, and Jack via my USB interface. That works really well.

My computer is really used for general purpose web browsing, coding, etc and Jack tends to have a few too many hiccups1 for that.

Pipewire seems to be coming along, there is an instruction page on the Arch Linux Wiki as well as provided packages in extra. It’s supposed to have support for Jack clients for low latency… anyone feeling brave?


1 e.g. not coping with suspend very well, or USB device removal.