Linux on the desktop


#162

I think you only have user permissions to virtual consoles that you’ve logged into these days. If you want to use other VTs you need to have X11 setuid (which isn’t great idea anymore…).

You can use the environment variable XDG_VTNR to grab your VT number.

It’s also worth checking the contents of ~/.xserverrc and /etc/X11/xinit/xserverrc


#163

That last item is a fun change that was made in the latest xorg-server ebuilds without adding a news item. Just wasted 2 hours on that yesterday :expressionless:

Easiest fix/workaround is USE +=suid which fortunately still works. I’m not sure there’s a way to make it work with rootless Xorg if you don’t use systemd/elogind. See https://bugs.gentoo.org/show_bug.cgi?id=670212


#164

Great tip! I’ll probably go ahead and write a wrapper to do that automatically. Very useful, thanks


#165

You should be able to cp /etc/X11/xinit/xserverrc ~/.xserverrc and add the option there:

e.g.:

#!/bin/sh

exec /usr/bin/Xorg -nolisten tcp "$@" vt$XDG_VTNR

source: https://wiki.archlinux.org/index.php/Xinit#xserverrc

In theory startx will just work then.


#166

re: Wacom touchscreen support

I also had a problem on dual-monitor configuration.

Used xrandr and xinput to map the touchscreen device to the laptop display.
Although the ‘output’ is actually indexed and prepended with HEAD.
So HDMI-0 mapped to HEAD-0
DP-2 (laptop’s display) mapped to HEAD-1

mfoster@cyperus ~ $ xrandr                                                                                                                                                                                                                                                                                                                                                                                                                                                                   
Screen 0: minimum 8 x 8, current 7680 x 2160, maximum 32767 x 32767                                                                                                                                                                                                                                                                                                                                                                                                                          
DP-0 disconnected primary (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 3840x2160+3840+0 (normal left inverted right x axis y axis) 597mm x 336mm
   3840x2160     30.00*+  29.97    25.00    23.98  
   1920x1200     59.88  
   1920x1080     60.00    59.94    50.00    23.98    60.05    60.00    50.04  
   1680x1050     59.95  
   1600x1200     60.00  
   1280x1024     75.02    60.02  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1152x864      75.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    59.94    59.93  
DP-2 connected 3840x2160+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   3840x2160     60.00*+
mfoster@cyperus ~ $                                                                                                                                                                                                                                                                                                                                                                                                                                                                          
mfoster@cyperus ~ $ xsetwacom --list                                                                                                                                                                                                                                                                                                                                                                                                                                                         
Wacom Pen and multitouch sensor Finger touch    id: 10  type: TOUCH                                                                                                                                                                                                                                                                                                                                                                                                                          
Wacom Pen and multitouch sensor Pen stylus      id: 11  type: STYLUS                                                                                                                                                                                                                                                                                                                                                                                                                         
Wacom Pen and multitouch sensor Pen eraser      id: 23  type: ERASER                                                                                                                                                                                                                                                                                                                                                                                                                         
mfoster@cyperus ~ $                                                                                                                                                                                                                                                                                                                                                                                                                                                                          
mfoster@cyperus ~ $ xsetwacom set "Wacom Pen and multitouch sensor Finger touch" MapToOutput "HEAD-1"                                                                                                                                                                                                                                                                                                                                                                                        
mfoster@cyperus ~ $ xsetwacom set "Wacom Pen and multitouch sensor Pen stylus" MapToOutput "HEAD-1"                                                                                                                                                                                                                                                                                                                                                                                          
mfoster@cyperus ~ $ xsetwacom set "Wacom Pen and multitouch sensor Pen eraser" MapToOutput "HEAD-1"                                                                                                                                                                                                                                                                                                                                                                                          
mfoster@cyperus ~ $

#167

I’m using a machine from System76, you might check them out.


#168

Nice, I’ve been meaning to chevk out System 76. I wish Max had a version for Linux. I’d switch in a heartbeat. Used it for a desktop for years until I got into making music again. Started with Red Hat, then briefly CentOS to Ubuntu. Ubuntu was extremely stable for me. I got extremely good (and productive) at using gnu Screen.


#169

Wine isn’t too bad and Max has a Windows version. There’s even a JACK bridge between Wine and jackd. I’ve used it!

Sometimes I work with a Nord Micromodular. The editing software is obsolete and only exists as a Windows XP binary. I got it to work with MIDI in Wine on Arch. That was cool.


#170

Yeah I think @ioflow wrote up a document somewhere on configuring the Linux + WINE + Max setup. Really really cool if you need the runtime/environment!


#171

I tried Wine once (a very long time ago) and it was a disaster. But if it’s gotten better that’s something to definitely consider. I might have to try that on another older PC this weekend and see what happens. :ok_hand:


#172

I’ve been really happy with linux support for lenovo laptops, but I always buy cheapo old stuff. My dev/music machine is an x201 tablet with 4gigs of RAM – ardour runs great on pretty minimal resources, but I only usually use a DAW for straightforward mixes and mastering type stuff. (I like the calf multiband EQ & compression plugins.)

(FWIW, I downgraded to the x201 in a hurry from an x230 when its fan suddenly died. ~$80 on ebay it was going to be a stopgap, but over a year later I haven’t even bothered to add more RAM yet… I’m sure the recent generation of intel chips are faster, but IMHO computers kind of got fast-enough-for-me about 10 years ago, I don’t feel the need to upgrade so often anymore…)


#173

last-gen thinkpads are great and cheap, so true


#174

So I had to come here to eat my words: I finally upgraded my x201 from 4GB of RAM to 8GB, and it’s great! Feel pretty stupid waiting this long to do that.

I also got a discontinued IBM x3690 x5 server recently, which I’m really enjoying for its 40 hyperthreads (20 cores in total) and 64GB of RAM!

Whole thing actually cost less than a smartphone even after picking up a UPS power backup, the monitor/keyboard rack combo and a 4U portable rack for it. (Not pictured – it’s a big green ex-military pelican case…) This is kind of crazy to me since servers like this go for tens of thousands of dollars new, and this was only discontinued a few years ago. (It was new circa 2012 I think.)

(Both these developments were encouraged by working on the long-form ambient compilation. Dropping 45 minute audio segments into the blender with ease now. :))

For example, this 56 minute render that does 8x granular passes over a 45 minute field recording took less than a minute to run :rofl::joy:


#175

Love this. Now I want to buy one, dammit. Very cool, and I also love that HP TFT5600 along with it! Looks like a custom Fairlight almost.


#176

Be forewarned it’s really loud. I might try to replace the fans with something quieter, or more likely: put it in its case, find an out-of-the-way closet and a long ethernet cord. :slight_smile:


#177

Aye, had a couple servers in a living room once for VPN/product-testing for a contracting gig. My partner at the time was less than stoked. Very handsome IBM rack unit


#178

What’s your electricity bill look like? When I worked in data centers, the hardest part was enduring the temperatures due to both industrial air conditioning and dozens of servers blowing hot air out. Messing with the thermal controls and fans could end with the magic smoke being let out of some components. IIRC those things run very hot even when idle.


#179

Seems to be running at normal temps, I’ll have to await the power bill. I’m not expecting anything crazy, the load on the UPC is barely showing up as a blip on the display when idle, and 2/5 when running. (I also only fire it up when I’m working.)


#180

Just in case anyone is considering a used IBM server – I didn’t see much of a difference on my last energy bill thankfully, so that’s a relief. Compared to the summer months running a window unit AC there wasn’t much of a change in my electric since I started using it. (It’s only on when I’m rendering stuff, but I’ve been keeping long renders going pretty steady for the last few weeks at least, so it’s been more on than off so far…)

Usage June - today.

power_usage

Staying a little more on topic for the thread – FWIW I’m using a very untweaked arch linux install on my laptops and this server, all just using ALSA & JACK without any special tuning.

Hop on in, the linux is fine!

(YMMV but I think it generally helps to go with a rolling release distro that is based on a recent kernel – so, debian, ubuntu and friends might not be the best choice depending on the hardware you want to use…)


#181

As someone who used to compile a realtime kernel and do all sorts of fiddly tuning, I actually haven’t bothered with any specific tuning or config for audio on new linux systems in years. That said I work primarily on offline/non-realtime systems now so my needs are probably pretty different from a lot of folks here who do much more realtime & interactive work.

I just found this wonderful page on the arch linux wiki about pro audio config under linux:

https://wiki.archlinux.org/index.php/Professional_audio

If you’re running arch linux (or a derivative) there is a cool (new?) meta-package called pro-audio which installs a giant stack of audio software and tools. But this page also goes into detail about configuring linux for realtime audio and should be useful to some degree regardless of the distro you’re using.

</linux-audio-advocate>