MacOS 10.13 (High Sierra) and serialosc


#1

has anyone had success with 10.13 yet?

i’m yet to install it. just out last week. had one report of non-showing serialosc so wondering if they messed up the FTDI driver again.


#2

Serialosc 1.4 seems to be working fine so far; I haven’t tested it extensively but my Arc based app works.

Standalone Max apps; like monome_sum (and some of my own stuff) break after the upgrade but I was able to rebuild my own apps and they seem to work once rebuilt.

This is what the “broken” monome_sum looks like (for me):


#3

I’m on 10.13 and haven’t had any issues yet. I was able to run Sum just fine for what it’s worth…


#4

everything works fine on my iMac 27-inch late 2015


#5

Out of curiosity for the folks that have monome_sum working, are you on a full SSD system with the new file system (APFS)?

One of the changes between HFS+ and APFS is that in HFS+ directory contents come back to applications in lexicographical order where as APFS returns directory contents to applications in its internal hash ordering. The most visible breakage from that change that I’ve seen is the behavior of the next and previous preset buttons in various plugins (native instruments in particular)


#6

Yessir – full SSD and APFS. 5 year old MacBook though :grin:


#8

Ive been having the monome not showing up right away in re/mix (even with restarting), and i have to replug it and sees it. It works perfectly other than that

Everything was fresh installed a couple days ago

10.13.1
128 (2011)
live 9.7.5


#9

I can’t get monome to work with anything on High Sierra, have tried install both serialOSC and FTDI drivers in muliple combinations, and both alone but no luck, High sierra, MBP early 2015, full ssd, monome, greyscale 64, nothing shows in mark eats or any max patches


#10

just confirmed a fix for pre-2013 devices on 10.13, via @hypnosapien

install the FTDI driver from 2015: http://www.ftdichip.com/Drivers/VCP/MacOSX/FTDIUSBSerialDriver_v2_3.dmg

apple will make you jump through hoops with preferences > security to enable it, but once you’ve done this everything should work as expected.


USB-C + High Sierra + 2016 MBP success
#11

installed the FTDI driver but mine still only shows after re plugging after boot up. All apps work fine, and the monome stays connected, but it used to always show up after boot up


#12

can you be more clear? if i understand, the problem is that it doesn’t show up when you boot up with it plugged in?


#13

correct that is the problem. After i plug it in it shows up everytime every app both in max for live and max 7, until i restart or shutdown the computer then i have to plug it back in


#14

Is this just a fix for per-2013 devices only ? I tried out of curiosity on a early 2015 with no look fyi,
thanks for looking into this


#15

early 2015 should’ve never had a problem to begin with. you’ll need to let me know exactly what you’ve tried already.


#16

My monome greyscale 64 Just doesn’t appear in any max patch or Mark eats, it appears in the terminal I think it may be related to the dev string fix in another thread, I’ve tried a lot of things installing FTDI drivers and serial osc in multiple combinations and uninstalling everything and trying again but no show


#17

install this: https://github.com/monome/serialosc/releases/download/v1.4/serialosc-1.4.pkg.zip
and this: http://www.ftdichip.com/Drivers/VCP/MacOSX/FTDIUSBSerialDriver_v2_3.dmg

reboot

terminal, type:

ls /dev/tty.usb*

paste output here

open activity monitor, check for serialosc processes, list them here.


#18

/dev/tty.usbserial-m64_0716

59

There you go no show for monome in max or mark eats after following your steps


#19

Any more info on this yet? Thanks


#20

apologies-- it seems that installing the older FTDI driver didn’t fix the problem for you the same way it did for me and for a few others users. we’re still working on the serialosc fix.

which device and year are you using?


#21

Hey sorry for the late reply on this the device im using is a Greyscale 64, not to sure on the year as I purchased second hand, do you know how I can find its serial number then maybe you can figure from that?
Thank you