MacOS 10.13 (High Sierra) and serialosc


#22

gs64 is sufficient in this case, thanks.


#23

Wanted to say i had a change with my monome. I didnt update anything and ive been using it alot. I can only plug it in once after reboot and it shows in max, if i unplug it and replug it wont see the monome in max for live or max or the terminal, but it shows in system profiler. I have to restart and wait to plug it in after the computer is on.

in terminal it says no such file or directory


#24

can i assume you’re using 10.13 as you posted in this thread?

it looks like your serialosc.maxpat is very old. install max 7, try the monome package, see if it works.

if it doesn’t perhaps try installing the old FTDI driver as instructed above.


#25

i installed the serialosc1.4 pkg and the old ftdi driver you listed above, but it hasnt changed anything. I can only plug it in once, or i have to restart the computer. It shows in all the max 7 package patches, but after i replug it wont show in any of the patches until i restart and plug it back after the computer is on. after i plug it in again it comes up in the system profile twice.

mbp 10.13.1
monome 128 (2011)
max 7.3.4

51 PM


#26

No way


Help!!


#27

@tomme is this a first time install or did you upgrade? what device? need more information to help.


#28

I can probably help do some QA as well since I have access to a 128 grid as of yesterday. Been putting off upgrading until I had a good reason.


#29

with QA hat on i would wonder how many of the failure cases are:

  • using USB-C port
  • using a hub

i have a 2016 mbp and two different usb adapters from apple, one with a display port/power and one just a straight usb port. the bigger adapter has dropped packets and connection issues - it loses usb devices when it sleeps, and audio interfaces exhibit audible dropouts. the small adapter is fine.


#30

I used serialosc and monome in past MacOS versions since 2011. I have a 128 - year 2011. I wrote also in the other post in this forum…


#31

Hey any updates on this it has been a while now, my monome is a very nice paperweight atm,
Should I just downgrade? Could we for expect a fix in say 1 - 2 weeks?
The old driver thing docent work for me, would be great to know whats going on, it seems monomes on the latest osx are just not working properly.


#32

@tomme apologies, the question was ambiguous. so did you just upgrade your OS and it broke? or is this a new computer?

@Alistair i’ll get a fix by the end of the week. update tomorrow.


also as suggested, please report your USB C hub use and exact hardware models


#33

Thank you very much, look forward to it :slight_smile:


#34

im using an apple usb c to usb converter > kingwin superspeed usb 3.0 hub with 7 ports and 2 charging ports (powered). I tried plugging the monome straight into the apple converter but its the same issue

128 (2011)
mbp 10.13.1
max 7.3.4


#35

The problem occurred after upgrading to High Sierra…


#36

ok, here’s a first try. not a fancy installer. unzip, click “install.command” and reboot.

EDIT removed installer, it’s busted.


#37

Tehn, I’ve been having exact same problems as Allstair. Just upgraded from os 10.9 to 10.13
on early 2011 MBPro.

Am using early 256 grid and gs128.

Similarly, will only detect upon reboot - both devices simultaneously though - but disappear until reboot after I unplug monome.

Tried latest serialosc you posted and older ftdi driver (is this required for early 2011 Mac?)
with no change.

couldn’t find ‘install.sh’ in the zip file above.

Thanks!


#38

Sorry, I meant to say I am having the exact same problem as amerryprankster.

Will only detect monomer on reboot and will not re-detect if unplugged.


#39

Running the install.command in the zip file seems to have fixed the issues I was having with my greyscale 128, which is now recognised on my late 2017 iMac 27". Though, I am seeing some strange, but ultimately only slightly inconveniencing, behaviour. Neither the greyscale 128 nor DIY-kit-built 128 are recognised after hot-swapping.

Here is a systematic test of the issue:

  • Rebooting the iMac with both diy and greyscale plugged in; for which the terminal output is

*********-iMac-2:~***********$ ls /dev/tty.usb
/dev/tty.usbserial-m0001747 /dev/tty.usbserial-m128-481

and for which the activity monitor readout is

  • Removing the diy-kit-built 128 and plugging back in gives the following state from which the diy is not recognised:

***********-iMac-2:~ ************$ ls /dev/tty.usb
/dev/tty.usbserial-m128-481

  • Lastly, unplugging and reconnecting the greyscale128:

*********-iMac-2:~**********$ ls /dev/tty.usb
ls: /dev/tty.usb
: No such file or directory

  • Rebooting returns the system to the original state.

#40

try deleting the FTDI driver so the system reverts to the AppleFTDI driver. copy-paste this into a terminal:

sudo rm -r /Library/Extensions/FTDIUSBSerialDriver.kext

then reboot


#41

I removed the FTDI Driver. Now the ‘serials-devic’ shows up under Processes for each monome I plug in, and it re-detects when I unplug and replug!

But…now the devices don’t show up at all in monome_sum or M4L, etc.

Can you help me with the Install in the serialosc171221.zip file you sent?
I can’t find ‘install.sh’ and I’m not sure how to proceed.

I’m getting this when I run ‘install.command’:

cp: directory /usr/local/lib does not exist
logout
Saving session…
…copying shared history…
…saving history…truncating history files…
…completed.

[Process completed]

Thanks!