MacOS 10.13 (High Sierra) and serialosc


#42

apologies, install.command is correct

i’m going to try to build a proper package installer now.

have you tried the max 7 monome package for detection?


#43

I’m not sure how to check the Max 7 monome package.

I just upgraded to max 7.3.4 but not sure how to check or re-install the maxpat.

Also, why is the installer giving me directory errors?

Sorry for being such a noob about this.


#44

i need to fix the installer, don’t bother continuing with install.command

also i’m seeing the not detect on reconnect issue now

install the max monome package via the max 7 package manager, there’s a test-grid.maxpat included


#45

new approach.

try 2.4.2: http://www.ftdichip.com/Drivers/VCP/MacOSX/FTDIUSBSerialDriver_v2_4_2.dmg

and reinstall the known-good serialosc: https://github.com/monome/serialosc/releases/download/v1.4/serialosc-1.4.pkg.zip

i just upgraded to 10.13.12 and it was massively broken, now it works, with all editions.


#46

does this mean that everyone can no longer use the built-in apple driver? seems to be a pretty bad regression somewhere upstream. i had been enjoying not needing an external driver, especially given the changes in recent years in macOS’s handling of third-party kexts.

external ftdi <10.9, >=10.13
built-in ftdi 10.9 - 10.12


#47

if it’s not broken, don’t fix it.

i’m sorry i don’t have a better suggestion. apple is really fucking up lately (in much bigger ways than breaking the ftdi driver)


#48

just to be clear, the fault is not with monome at all. apple has clearly broken things somewhere in their stack. but at least we have a verified working setup path, in using the external ftdi kext.

i’m curious though–do we have any idea why the apple driver is suddenly failing in some cases? from what i can gather, 10.13 brought about a different device enumeration/naming scheme.

if that is the sole cause of these woes, is there a way to build some detection logic into serialosc, to know how to talk to the apple kext in all circumstances? a complicated if…else…elif recipe, i’d guess.


#49

the new approach fixed my hot swap issue you can plug the monome in as many times as you want with both max and m4l. It still does not show up on start up, and you have to plug it in.

10.13.1
max7.3.4
128 (2011)

ive been waiting to update the operating system because my monome has been functional, and ive needed it. Do you think updating the OS will solve the problem with seeing the monome on bootup or is this still an ftdi issue


#50

i still need to test detection on bootup. luckily i’d consider this a more minor bug compared to the others, however.

yes, i would suggest upgrading. and you may need to reinstall the FTDI driver afterwards as the update will likely revert the driver.

@ioflow i saw other issues where the grid was not redetected after a few reconnects. like the ftdi driver just gave up trying entirely, for any ftdi device.


#51

i found a statement from ftdi last year, when sierra kicked off the first of these issues:

if those two features mentioned at the end are important to serialosc, and if they’re still being left out of apple’s driver, that might be an issue. other guesses: apple’s usb stack has a timer to limit discovery attempts, or its ftdi driver isn’t waiting for stuff to be sent to it; attempting to work with the device before it’s ready, so it gives up.

dug around a bit more. maybe there’s something useful in apple’s developer docs on how usb/ftdi devices are detected and handled?


#52

I updated to 10.13.2 and like you suggested all i needed was to reinstall the FTDI, and its back to showing up after plugging in and hot swapping

it seems its getting duplicated in max, and in m4l it only shows one instance


#53

baud-rate aliasing

i think this would (only?) apply if an application requested non-standard baudrates

that’s not a comprehensive list of things apple dropped… but they wouldn’t have dropped 115200, right?


#54

Tehn: All seems to be working. Thanks and Happy Holidays all!!


#55

I tried this new approach also but not working.
MacOS 10.3.2
Max 7.3.4
monome 128 2011
thanks for help


#56

open a terminal, copy-paste this below:

ls /dev/tty.usb*

and post the output here

check system profiler, usb section, do you see a monome device?


#57


#58

Curiously I have two different machines (laptop and desktop) with identical software configurations and while my older grid work works fine on the laptop the desktop is wonky (something is definitely borked on Apple’s side, see below).

UPDATE: I can get my older grid working on my desktop if I manually load the AppleUSBFTDI driver before plugging in my grid to the hub. To manually load the driver run the following in a terminal:

sudo kextload /System/Library/Extensions/AppleUSBFTDI.kext

For what is worth here are the details:


machine A:
  • 2016 mac book pro (15")
  • macOS 10.13.2
  • AppleFTDI driver
  • Apple USB-A to USB-C adaptor
  • serialosc 1.4
  • max 7.3.4

2012 grid 128

  • works, including hot-plug
  • enumerates as /dev/tty.usbserial-m0000852

2016 arc 4

  • works, including hot-plug
  • enumerates as /dev/tty.usbserial-m1100074

machine B:

  • 2013 mac pro (trashcan)
  • macOS 10.13.2
  • AppleFTDI driver
  • serialosc 1.4
  • max 7.3.4

2012 grid 128

  • doesn’t work if plugged into a USB2 hub
    • AppleFTDI driver doesn’t get loaded if grid is connected on boot or via hot-plug
    • nothing appears in the system profiler
  • does work if plugged directly into the machine
    • hot-plug functions
  • plugging into the USB2 hub, after plugging into the CPU works
    • hot-plug functions
    • my running theory is that the AppleFTDI driver stays loaded after plugging in directly to the CPU thus allowing the hub to function (off to test)

2016 arc 4

  • works, including hot-plug
  • enumerates as /dev/tty.usbserial-m1100074

#59

Is the general advice to upgrade? (I’m on 10.12.16 and serialosc has been finicky for me, though I haven’t dug too deeply; sounds like it won’t get worse?)

(Aside and possible derail: anyone holding out on the upgrade? If so, why?)


#60

i’ve reverted to the AppleFTDI driver and things seem to be working fine, though i need to recheck old grid editions which i expect are still broken


#61

Super. Thanks! FWIW: I updated and did not revert drivers but things seem to actually be happier now. (I’m pinching myself, because when has that ever happened after an upgrade? :wink: )