MacOS 10.13 (High Sierra) and serialosc


#62

Hey has this been looked at any further asof yet, my GS64 is still not detectable, have tried all of the above,
Have already posted my issues further up the thread.
Thanks,
Ali


#63

checking with @wrl now


#64

On latest high Sierra 10.13.2 MacBook Pro (Retina, 15-inch, Mid 2015)… no luck trying all the above. Was very happy with my 10.10, but forced to upgrade. Now I’m mo longer playing monome…

Tried several combos of FTDI driver and serialosc, also tried compiling serialosc myself…

with all versions I have
kaos$ ps aux |grep serial kaos 1388 0.0 0.0 4267964 916 ?? S 7:03PM 0:00.03 /Library/Application Support/Monome/serialosc.bundle/Contents/MacOS/serialosc-devic /dev/tty.usbserial-m128_121 kaos 1387 0.0 0.0 4295160 1352 ?? S 7:03PM 0:00.00 /Library/Application Support/Monome/serialosc.bundle/Contents/MacOS/serialosc-detector kaos 1386 0.0 0.0 4286508 1100 ?? S 7:03PM 0:00.01 /Library/Application Support/Monome/serialosc.bundle/Contents/MacOS/serialoscd kaos 1460 0.0 0.0 4267768 884 s000 S+ 7:05PM 0:00.00 grep serial

So it is detected somehow…
but it does not show up in a fresh install of Max 7 (with monome addon from package manager) or fresh Ableton live 9 (modules load fine)

moreover legacy MonomeSerial detects it just fine, and blinks all the LEDs in testmode…

What’s next?

Thanks!


#65

I think this issue has been fixed with the merge of this PR https://github.com/monome/libmonome/pull/58
Don’t know how you installed libmonome/serialosc before, but if you built it yourself you could try again with the current master branch.


#66

Is there a step by step on building the master branch, I am no programmer but would like to try
Thanks


#67

new installers coming soon thanks for your patience


#68

Still out of monome… :confused:

uninstalled both libmonome and serialosc using ./waf uninstall

libmonome git was up to date

libmonome kaos$ git pull
Already up-to-date.

I pulled the latest serialosc master

serialosc kaos$ git pull
remote: Counting objects: 31, done.
remote: Compressing objects: 100% (14/14), done.
remote: Total 31 (delta 17), reused 23 (delta 16), pack-reused 0
Unpacking objects: 100% (31/31), done.
From https://github.com/monome/serialosc
   b5cd618..7d7cb82  master     -> origin/master
Updating b5cd618..7d7cb82
Fast-forward
 include/serialosc/ipc.h          | 14 ++++++--------
 src/common/ipc.c                 |  2 +-
 src/serialosc-detector/windows.c |  4 ++--
 src/serialosc-device/server.c    |  2 +-
 src/serialoscd/uv.c              |  6 ++++--
 5 files changed, 14 insertions(+), 14 deletions(-)

I recompiled libmonome, pointing it to the brew version of liblo that I have installed (correct?)

libmonome kaos$ LIBRARY_PATH=/usr/local/Cellar/liblo/0.29/lib/ CPATH=/usr/local/include ./waf configure

installed it,
recompiled serialosc, installed it, rebooted…

no luck…

I still found the device listed when grepping for serialosc in ps aux

kaos              2013   0.0  0.0  4279228    956   ??  S     8:02PM   0:00.01 /Library/Application Support/Monome/serialosc.bundle/Contents/MacOS/serialosc-devic  /dev/tty.usbserial-m128_121
kaos              2012   0.0  0.0  4316688   1424   ??  S     8:02PM   0:00.01 /Library/Application Support/Monome/serialosc.bundle/Contents/MacOS/serialosc-detector
kaos              2010   0.0  0.0  4290604   1152   ??  S     8:02PM   0:00.01 /Library/Application Support/Monome/serialosc.bundle/Contents/MacOS/serialoscd

It still shows up in MonomeSerial, but not in Max 7 or Ableton or in any standalone app I used to play with

I also tried uninstalling the FTDI driver again


kaos$ pkgutil --pkgs | grep -i ftdi
com.FTDI.driver.FTDIUSBSerialDriver
LAPTOP-1501155:serialosc kaos$ pkgutil --files com.FTDI.driver.FTDIUSBSerialDriver
Library
Library/Extensions
Library/Extensions/FTDIUSBSerialDriver.kext
Library/Extensions/FTDIUSBSerialDriver.kext/Contents
Library/Extensions/FTDIUSBSerialDriver.kext/Contents/Info.plist
Library/Extensions/FTDIUSBSerialDriver.kext/Contents/MacOS
Library/Extensions/FTDIUSBSerialDriver.kext/Contents/MacOS/FTDIUSBSerialDriver
Library/Extensions/FTDIUSBSerialDriver.kext/Contents/Resources
Library/Extensions/FTDIUSBSerialDriver.kext/Contents/Resources/English.lproj
Library/Extensions/FTDIUSBSerialDriver.kext/Contents/Resources/English.lproj/InfoPlist.strings
Library/Extensions/FTDIUSBSerialDriver.kext/Contents/_CodeSignature
Library/Extensions/FTDIUSBSerialDriver.kext/Contents/_CodeSignature/CodeResources
LAPTOP-1501155:serialosc kaos$ sudo rm -rf /Library/Extensions/FTDIUSBSerialDriver.kext
Password:
LAPTOP-1501155:serialosc kaos$ sudo pkgutil --forget com.FTDI.driver.FTDIUSBSerialDriver
Forgot package 'com.FTDI.driver.FTDIUSBSerialDriver' on '/'.


still shows up both in ps aux and in MonomeSerial, (and buttons work) but still no luck.

Thanks


#69

I tried several combinations of kextunload and kextload and hubs and usbports, but no luck…really stuck now.

could it be that I really have an old monome? /dev/tty.usbserial-m128_121

something different there? can it be upgraded?

K


#70

@kaosbeat does the serialoscd log show a message when you connect your grid?


#71

cannot really check now, as i’m not near my monome, but looking through yesterdays system log files I found dozens of serialsoscd crash logs…

see one attached

serialoscd_2018-01-15-203132-1_LAPTOP-1501155.crash (10.5 KB)

also at the same time in the system log

Jan 15 20:31:29 LAPTOP-1501155 com.apple.xpc.launchd[1] (org.monome.serialosc[2685]): Service exited due to signal: Segmentation fault: 11 sent by exc handler[0]
Jan 15 20:31:29 LAPTOP-1501155 com.apple.xpc.launchd[1] (org.monome.serialosc[2702]): Service exited due to signal: Segmentation fault: 11 sent by exc handler[0]
Jan 15 20:31:29 LAPTOP-1501155 com.apple.xpc.launchd[1] (org.monome.serialosc): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.

Where would serialsoscd store it’s log?

K


#72

Hi everyone,

Since today I’m the happy owner of a Monome ’ 64 ’ , Although I seem to struggle quiet a bit with the Serial OSC - installation. I have a macbook pro (2011), 10.11.13
After installing successfully, Terminal mentions ‘command not found’.
I read something about manual installation, but I don’t know how to do this.
Can anyone help me out with this ?

Thanks a lot !

grts


#73

Thanks @tehn
I found the answer.

MacOS 10.13 (High Sierra) and serialosc


#74

@kaosbeat To check the serialosc log, stop any instances of serialosc running in the background, the run serialoscd from terminal and try plugging the grid in and out. If you see connect and disconnect messages, it works.


#75

Ok I did this.

very mixed results

plugging it in gives an event, always
unplugging also always works

but only the first time after reboot, manually killing serialoscd (multiple times, until respawning pauses long enough to manually start the deamon) and starting serialoscd from a terminal I can get the grid to show up in Live or Max.

I then works, starting other patches, stopping and restarting Live or Max, until I unplug replug.

the moment unplug the monome… it’s game over. Detects in the terminal, but does not show up in max/live

monomeSerial is still unaffected
restarting the serialoscd daemon no longer helps.

very flakey I would say


#76

You can kill it temporarily (for the current session) with the following command:
launchctl unload /Library/LaunchAgents/org.monome.serialosc.plist

Do you have multiple instances of serialosc installed? pkg, homebrew?


#77

hmmm possibly multiple install, but only one is running at a time. Could of course be the wrong one for 10.13…

how can I check this?

kaos$ brew uninstall serialoscd
Error: No such keg: /usr/local/Cellar/serialoscd
kaos$ brew uninstall serialosc
Error: No such keg: /usr/local/Cellar/serialosc

kaos$ which serialoscd
/usr/local/bin/serialoscd

/usr/local/bin/serialoscd is the only one I’m aware of but I used a package (.pkg) from the as well as the sudo ./waf install to install the updated source version. I’ll get the new packaged version tonight. I just ran sudo ./waf uninstall from the source dir, so it’s gone now…

K


#78

Hey guys, after running the latest installer, my GS64 works woohoo! Thanks for getting this working :smiley:


#79

May have been a little hasty in my response here, It’s working but only when plugged in from boot, if I unplug and plug back in it’s not showing, just a heads up, it’s a lot better than note working at all.
All way to give it a kick without rebooting as a workaround.
Is there a fix planned for this also?


#80

@Alistair are you still using the OEM FTDI driver?


#81

Hey, I’m not to sure at the minute as not at my laptop, I was testing all the options in these threads so more than likely one of the ones recommened.
How to I uninstall and get back to the apple default,
whihch one should I use, I’ll try and start clean and see what happens
Thanks