MacOS 10.13 (High Sierra) and serialosc


#82

I am not really sure how to do that, but perhaps this post helps?


#83

Ill take a look, what driver should I be using with the latest serialosc build?


#84

The one that comes with High Sierra.


#85

ok I ran this as super user, “cd /Library/Extensions” then “sudo rm -rf FTDISerialDriver.kext”

Same result as before, monome works when lugged from boot, hot-plugging does not.

Any ideas?


#86

I’m out of ideas, but perhaps this thread could be of help? Make sure you have 1) serialosc 1.4.1 (reinstall it if you’ve got compiled stuff in /usr/local) 2) Apple’s built-in FTDI driver 3) No third-party drivers


#87

Ok Ive fully reverted back to the apple drivers, and reinstalled serial osc 1.4.1
hot plugging still not working


#88

Ok, what happens if you try the following in Terminal:

launchctl unload "/Library/LaunchAgents/org.monome.serialosc.plist"
cd "/Library/Application Support/Monome/serialosc.bundle/Contents/MacOS"
PATH=.:$PATH ./serialoscd

…then plug the grid in and out a few times.


#89

alistairs-mbp:~ alistairmessom$ launchctl unload "/Library/LaunchAgents/org.monome.serialosc.plist"
alistairs-mbp:~ alistairmessom$ cd “Library/Application Support/Monome/serialosc.bundle/Contents/MacOS”
-bash: cd: Library/Application Support/Monome/serialosc.bundle/Contents/MacOS: No such file or directory
alistairs-mbp:~ alistairmessom$ PATH=.:$PATH ./serialoscd
-bash: ./serialoscd: No such file or directory
alistairs-mbp:~ alistairmessom$


#90

Sorry, I forgot the leading / in the 2nd line, post above edited.


#91

ok tried this, cursor is flashing in terminal for quite a while


#92

Ok, what happens if you run the following from the serialosc bundle directory?
PATH=.:$PATH ./serialosc-device /dev/tty.usbserial-m64_0716


#93

libmonome: could not open monome device: No such file or directory
./serialosc-device: failed to open device /dev/tty.usbserial-m64_0716


#94

Are you sure you have the Apple driver loaded? What is the output of the following?
ls /dev/tty.usbserial*


#95

i get no such file / directory on that one


#96

Can you try your grid with another computer? Because this sounds like problems with your OS and/or hardware. Cable perhaps?


#97

I haven’t got access to another computer right now, but the device works fine on boot, its just when i unplug and replug it isn’t detected again


#98

running this, system_profiler SPUSBDataType

gives me
monome 64:

              Product ID: 0x6001
              Vendor ID: 0x0403  (Future Technology Devices International Limited)
              Version: 6.00
              Serial Number: m64-0716
              Speed: Up to 12 Mb/sec
              Manufacturer: monome
              Location ID: 0x14114000 / 22
              Current Available (mA): 500
              Current Required (mA): 500
              Extra Operating Current (mA): 0

#99

This is normal. But if the grid doesn’t reappear in system profiler and /dev after a replug, check your OS and drivers, seriously. It’s also good to try that on another Mac. Also, does the problem above happen with other USB devices? Other FTDI-based devices?


#100

News about new installers?
I’m blocked
Thanks


#101

Are you already on 1.4.1?