MacOS 10.13 (High Sierra) and serialosc


Hey, this is still happening, the device does appear in the system profiler after replug, it does not however show in max or mark eats seq, i have tried other cables and another mac with the same issues, now pretty sure im using the default apple driver and the latest serial osc which is all i need i believe.
also i have tried plugging directly into my matchbook rather than via a hub, still the same issues. Works fine, replug dissent work,


my grid in still not discovered in max. tried all the suggested routes.


mac os version? grid version? any debug information? is the device in /dev/ ? is it in system profiler?

have you tried another computer? was this working before upgrade?


hey i’d like to bring this up again as not sure if anyone is looking at it,
The new serialosc brought my monome back to life,
However it has to be plugged in from boot.
If I unplug and replug while the computer is on the monome is then not showing in max,
It does however show in the system profiler.
I’m afraid there is still something not working in the software
GS64, apple ftdi, high sierra, MBP early 2015.
,Ive given my specs a lot of times now, and I am convinced this is not a problem my end. Tried different laptops etc


we’re aware of your problem but it takes time to find a specific fix for every combination, so i appreciate your patience.

what other laptops did you test? it’d be useful for data points.


hey no worries thanks for looking, I checked it on my girlfriends MacBook one of the new usb-c ones probs a year old also fully updated


Yeah, but it doesn’t show up in /dev I believe. can you PM me the output of ls -R /dev after you unplug and replug the grid?


I ran the the code in terminal for uninstallation
tried the steps from boot up
discoverable in terminal, and never in max


reinstalled the newest serialosc? do you get serialosc processes listed in activity monitor?


yes new serialosc. no, indication of processing in monitor


I was blocked, so I went for the full reinstall…

fresh High Sierra
downloaded serialOSC 1.4.1 (latest)

upon insert of monome128 I get a crash

Process:               serialoscd [699]
Path:                  /Library/Application Support/Monome/serialosc.bundle/Contents/MacOS/serialoscd
Identifier:            serialoscd
Version:               1.4.1 (1.4.1)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           serialoscd [699]
User ID:               503

Date/Time:             2018-02-11 10:40:43.628 +0100
OS Version:            Mac OS X 10.13.3 (17D47)
Report Version:        12
Anonymous UUID:        C4ABF54E-3A4E-A4FF-0992-696DC04E023B

Sleep/Wake UUID:       66F092A2-19A3-430F-B920-B732EE46DBEC

Time Awake Since Boot: 40000 seconds
Time Since Wake:       320 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue:

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]

VM Regions Near 0:
    __TEXT                 0000000100000000-000000010002e000 [  184K] r-x/rwx SM=COW   [/Library/Application Support/Monome/serialosc.bundle/Contents/MacOS/serialoscd]

Thread 0 Crashed:: Dispatch queue:
0   org.monome.serialosc          	0x00000001000024a4 handle_device_msg + 20
1   org.monome.serialosc          	0x000000010000223e dispatch_ipc_msgs + 142
2   org.monome.serialosc          	0x000000010000248a device_read_cb + 74
3   org.monome.serialosc          	0x000000010001b20b uv__read + 1659
4   org.monome.serialosc          	0x00000001000169dc uv__stream_io + 380
5   org.monome.serialosc          	0x0000000100025280 uv__io_poll + 3504
6   org.monome.serialosc          	0x000000010000a9a1 uv_run + 225
7   org.monome.serialosc          	0x000000010000157f main + 447
8   org.monome.serialosc          	0x0000000100001394 start + 52

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000000100002490  rbx: 0x0000000000000000  rcx: 0x0000000000000001  rdx: 0x0000000000000000
  rdi: 0x00007ffeefbff748  rsi: 0x00000001004007d0  rbp: 0x00007ffeefbf72c0  rsp: 0x00007ffeefbf7280
   r8: 0x00007ffeefbff748   r9: 0x00000001004007d0  r10: 0x0000000000000011  r11: 0x0000000000000202
  r12: 0x0000000000000000  r13: 0x0000000000000000  r14: 0x0000000000000000  r15: 0x0000000000000000
  rip: 0x00000001000024a4  rfl: 0x0000000000010202  cr2: 0x0000000000000000
Logical CPU:     4
Error Code:      0x00000004
Trap Number:     14

Binary Images:
       0x100000000 -        0x10002dfff +org.monome.serialosc (1.4.1 - 1.4.1) <7CD629D5-032B-38C4-9C3B-7BF9C5D61A28> /Library/Application Support/Monome/serialosc.bundle/Contents/MacOS/serialoscd
       0x100040000 -        0x100050fff +liblo.7.dylib (10) <3C0E103E-EEBC-3A6E-9874-9240CFDA16DC> /Library/Application Support/Monome/serialosc.bundle/Contents/Frameworks/liblo.7.dylib
       0x104610000 -        0x10465a98f  dyld (519.2.2) <6695F30B-4E88-3C0B-9867-7D738C44A3E6> /usr/lib/dyld
    0x7fff7689d000 -     0x7fff768d0fff  libclosured.dylib (519.2.2) <48051216-5647-3643-B979-B77D0FD20011> /usr/lib/closure/libclosured.dylib
    0x7fff76daf000 -     0x7fff76db0ff3  libSystem.B.dylib (1252) <47329E26-DC23-3EBA-9461-37755368327D> /usr/lib/libSystem.B.dylib
    0x7fff76fe3000 -     0x7fff77039fff  libc++.1.dylib (400.9) <FCF5E1F6-2B04-3545-8004-F3AB32FED172> /usr/lib/libc++.1.dylib
    0x7fff7703a000 -     0x7fff7705eff7  libc++abi.dylib (400.7) <217656D5-BC40-37FF-B322-91CB2AAD4F34> /usr/lib/libc++abi.dylib
    0x7fff783b0000 -     0x7fff7879e7e7  libobjc.A.dylib (723) <93A92316-DE1E-378C-8891-99720B50D075> /usr/lib/libobjc.A.dylib
    0x7fff78e4b000 -     0x7fff78e4fff7  libcache.dylib (80) <354F3B7D-404E-3398-9EBF-65CA2CE65211> /usr/lib/system/libcache.dylib
    0x7fff78e50000 -     0x7fff78e5aff3  libcommonCrypto.dylib (60118.30.2) <674286D3-7744-36A3-9AAA-49DFCD97A986> /usr/lib/system/libcommonCrypto.dylib
    0x7fff78e5b000 -     0x7fff78e62fff  libcompiler_rt.dylib (62) <4487CFBA-A5D7-3282-9E6B-94CAD7BE507E> /usr/lib/system/libcompiler_rt.dylib
    0x7fff78e63000 -     0x7fff78e6bffb  libcopyfile.dylib (146.30.2) <2C7C67D7-562B-3FFA-973D-BACF4C10E1EC> /usr/lib/system/libcopyfile.dylib
    0x7fff78e6c000 -     0x7fff78ef1fff  libcorecrypto.dylib (562.30.10) <8A53EFE1-AFCA-3676-BEE1-FA5ED9F0E222> /usr/lib/system/libcorecrypto.dylib
    0x7fff78f79000 -     0x7fff78fb2ff7  libdispatch.dylib (913.30.4) <7D0E3183-282B-3FEE-A734-2C0ADC092084> /usr/lib/system/libdispatch.dylib
    0x7fff78fb3000 -     0x7fff78fd0ff7  libdyld.dylib (519.2.2) <C50D02BC-A333-3313-B787-02F255A6783F> /usr/lib/system/libdyld.dylib
    0x7fff78fd1000 -     0x7fff78fd1ffb  libkeymgr.dylib (28) <6D84A96F-C65B-38EC-BDB5-21FD2C97E7B2> /usr/lib/system/libkeymgr.dylib
    0x7fff78fdf000 -     0x7fff78fdfff7  liblaunch.dylib (1205.30.29) <E66F58ED-C15E-3DFB-BC22-A861E13918C6> /usr/lib/system/liblaunch.dylib
    0x7fff78fe0000 -     0x7fff78fe4ffb  libmacho.dylib (900.0.1) <756F2553-07B6-3B42-ACEA-2F0F1A5E8D0F> /usr/lib/system/libmacho.dylib
    0x7fff78fe5000 -     0x7fff78fe7ff3  libquarantine.dylib (86) <6AC8773F-3817-3D82-99C2-01BABB9C3CBB> /usr/lib/system/libquarantine.dylib
    0x7fff78fe8000 -     0x7fff78fe9ff3  libremovefile.dylib (45) <912FA211-DD8C-3C92-8424-21B89F8B10FD> /usr/lib/system/libremovefile.dylib
    0x7fff78fea000 -     0x7fff79001fff  libsystem_asl.dylib (356.1.1) <94972913-9DF0-3C78-847C-43E58919E3DA> /usr/lib/system/libsystem_asl.dylib
    0x7fff79002000 -     0x7fff79002fff  libsystem_blocks.dylib (67) <F2493BB5-B1C6-3C4D-9F1F-1B402E0F1DB7> /usr/lib/system/libsystem_blocks.dylib
    0x7fff79003000 -     0x7fff7908cff7  libsystem_c.dylib (1244.30.3) <E0136C71-0648-36F0-9F84-82EA2748A8D7> /usr/lib/system/libsystem_c.dylib
    0x7fff7908d000 -     0x7fff79090ffb  libsystem_configuration.dylib (963.30.1) <0F8D0B76-4F7D-34EC-AB6C-50F9465809DA> /usr/lib/system/libsystem_configuration.dylib
    0x7fff79091000 -     0x7fff79094ffb  libsystem_coreservices.dylib (51) <21A488D0-2D07-344E-8631-CC8B2A246F35> /usr/lib/system/libsystem_coreservices.dylib
    0x7fff79095000 -     0x7fff79096fff  libsystem_darwin.dylib (1244.30.3) <2F750CB1-BC26-3FA3-AE59-553EE30D451B> /usr/lib/system/libsystem_darwin.dylib
    0x7fff79097000 -     0x7fff7909dff7  libsystem_dnssd.dylib (878.30.4) <EB9BB165-45A4-367C-B33A-688D4F383A95> /usr/lib/system/libsystem_dnssd.dylib
    0x7fff7909e000 -     0x7fff790e7ff7  libsystem_info.dylib (517.30.1) <7D79E167-4B5C-3833-81EE-3AF3FB53616D> /usr/lib/system/libsystem_info.dylib
    0x7fff790e8000 -     0x7fff7910dff7  libsystem_kernel.dylib (4570.41.2) <5155A4C3-825B-3178-AC51-0D2D2F2A6618> /usr/lib/system/libsystem_kernel.dylib
    0x7fff7910e000 -     0x7fff79159fcb  libsystem_m.dylib (3146) <ABB1B85F-9FFE-31B8-AD4F-E39A30794A93> /usr/lib/system/libsystem_m.dylib
    0x7fff7915a000 -     0x7fff79179fff  libsystem_malloc.dylib (140.40.1) <36B22C99-D772-3039-9A4C-AA31389965E1> /usr/lib/system/libsystem_malloc.dylib
    0x7fff7917a000 -     0x7fff7921eff3  libsystem_network.dylib (1229.30.11) <40BAD301-8744-3AD8-A688-E7925C587B00> /usr/lib/system/libsystem_network.dylib
    0x7fff7921f000 -     0x7fff79229ffb  libsystem_networkextension.dylib (767.40.1) <CEDC330D-28F0-3902-BEB0-10B92ACEC69F> /usr/lib/system/libsystem_networkextension.dylib
    0x7fff7922a000 -     0x7fff79233ff3  libsystem_notify.dylib (172) <98EA3D62-7C86-30DE-8261-D020D2F1EFF3> /usr/lib/system/libsystem_notify.dylib
    0x7fff79234000 -     0x7fff7923bff7  libsystem_platform.dylib (161.20.1) <C049250F-8C35-314D-810F-4E28AEAED983> /usr/lib/system/libsystem_platform.dylib
    0x7fff7923c000 -     0x7fff79247fff  libsystem_pthread.dylib (301.30.1) <ABA848E1-6978-3B42-A3A7-608B2C36FA93> /usr/lib/system/libsystem_pthread.dylib
    0x7fff79248000 -     0x7fff7924bff3  libsystem_sandbox.dylib (765.40.2) <922D3D15-AB4C-3F1A-A94F-39214AF1ADB3> /usr/lib/system/libsystem_sandbox.dylib
    0x7fff7924c000 -     0x7fff7924dff3  libsystem_secinit.dylib (30) <F06ADB8F-9E94-34A7-B3C9-2C22FDD14BAD> /usr/lib/system/libsystem_secinit.dylib
    0x7fff7924e000 -     0x7fff79255ff7  libsystem_symptoms.dylib (820.30.7) <DC3586C2-AA56-3419-88D3-FC0DBF08E3C0> /usr/lib/system/libsystem_symptoms.dylib
    0x7fff79256000 -     0x7fff79269ff7  libsystem_trace.dylib (829.30.14) <69EBF017-D40F-30D7-9B0B-BFC862D761A5> /usr/lib/system/libsystem_trace.dylib
    0x7fff7926b000 -     0x7fff79270ff7  libunwind.dylib (35.3) <6D4FCD49-D2A9-3233-95C7-A7635CE265F2> /usr/lib/system/libunwind.dylib
    0x7fff79271000 -     0x7fff7929dff7  libxpc.dylib (1205.30.29) <F7E5F1BC-614B-39CB-B6CE-92A9C7B7EC0B> /usr/lib/system/libxpc.dylib

External Modification Summary:
  Calls made by other processes targeting this process:
    task_for_pid: 74
    thread_create: 0
    thread_set_state: 0
  Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by all processes on this machine:
    task_for_pid: 25750
    thread_create: 0
    thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=197.5M resident=0K(0%) swapped_out_or_unallocated=197.5M(100%)
Writable regions: Total=80.3M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=80.3M(100%)
                                VIRTUAL   REGION 
REGION TYPE                        SIZE    COUNT (non-coalesced) 
===========                     =======  ======= 
Kernel Alloc Once                    8K        2 
MALLOC                            72.1M       14 
MALLOC guard page                   16K        5 
STACK GUARD                       56.0M        2 
Stack                             8192K        2 
__DATA                            2324K       43 
__LINKEDIT                       188.6M        5 
__TEXT                            9124K       43 
shared memory                       12K        4 
===========                     =======  ======= 
TOTAL                            335.8M      111 

Model: MacBookPro11,2, BootROM MBP112.0142.B00, 4 processors, Intel Core i7, 2,2 GHz, 16 GB, SMC 2.18f15
Graphics: Intel Iris Pro, Intel Iris Pro, Built-In
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343147533641465238412D50422020
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343147533641465238412D50422020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x134), Broadcom BCM43xx 1.0 (
Bluetooth: Version 6.0.2f2, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SM0256F, 251 GB
USB Device: USB 3.0 Bus
USB Device: Apple Internal Keyboard / Trackpad
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: Hub
USB Device: HP LaserJet Professional P1102
USB Device: Keyboard Hub
USB Device: Apple Keyboard
USB Device: monome128
Thunderbolt Bus: MacBook Pro, Apple Inc., 17.1

really stuck

right before the reinstall laptop went to AppleCare for full checkup because I had failing keyboard.



on the other hand, now suddenly it works in ableton live and max
a bit flakey :slight_smile: but getting somewhere



are the new grids connecting perfectly fine with the new OS?


seemingly so, i’m going to go recheck my gs128, i believe it was fine. i apologize for the trouble, this has been a deeply confounding problem…


just confirmed that the gs does indeed work fully.

confirming you installed the newest serialosc, yes?

can you run this in a terminal (copy paste) and paste the results here?:

pkgutil --pkgs | grep -i ftdi
pkgutil --files com.FTDI.driver.FTDIUSBSerialDriver


One of my older monomes is not showing up in SerialOsc since I updated to 10.13. Any advice on what I could check?


Yes. This thread MacOS 10.13 (High Sierra) and serialosc In my case (walnut 256) it doesn’t solve everything (I have to reboot if I disconnect the Monome) but that’s better than no connection at all… you need to uninstall the FTDI driver and install the latest Serialosc (i think it’s 1.4.1 )


other than install Serialosc 1.4.1, do i need to anything else if i’m running 10.13 on a macbook air 2015?



Ive just purchased a monomer 128 and downloaded the serialosc and MAX MSP and MaxforLife packages but it seems that the monomer is not recognized by my computer. Totally new here so any help will be very appreciated


Hey there! I just traded one of my old toys for a Monome and I am super excited to get started! I just have absolutely no clue on where to start!

A little info about my computer: Running masOS High Sierra version 10.13.3 on a macbook pro 15 inch, 2017 model. 2.9GHz intel core i7, 16gb ddr3 memory, with a radeon pro 560 graphics card.

Naturally, I started on the documentation page and downloaded a couple things; Terms, and the Max 7 Package, and I went to the setup and introduction. I went into terminal and removed the FTDI driver, installed serialosc, and can see it running in activity monitor. I have rebooted a couple times and reinstalled serialosc a couple times, but when I run the monome max 7 package, it displays a message saying “hello! if you haven’t yet, be sure to install serialosc”

I have never used a launch pad and I’m not sure if there is anything else I am missing, but let me know! I can’t wait to get started. Once the troubleshooting is done, any information you can provide on where else to go and what to do to learn, throw it at me! Is there anything I need to do in the midi devices in ableton/pro tools/logic themselves?