MacOS 10.14 (Mojave) and serialosc

#11

FWIW things are working for me:

  • 2013 Mac Pro
  • macOS Mojave 10.14.1
  • Max 8.0.1
  • 128 gird (2012)
  • arc 4 (2017)
  • AppleUSBFTDI driver provided by the OS

The gird and arc are connected to a USB2 hub which is in turn connected to one of the Mac Pro’s USB3 ports (not that that should really matter). I can unplug/replug the grid/arc and have them detected correctly.

Note: I did have to fully power cycle the machine after it was upgraded before things started working, attempts to use the grid right after the warm reboots from the upgrade process didn’t work

3 Likes
#12

So people are generally ok with Mojave?

I’m still on Sierra as High Sierra seemed like a mess, and not compatible with monome stuff(?). Wouldn’t mind upgrading as it’s been a long time.

#13

I have continued to not have problems with Mojave! Also, dark mode is surprisingly pleasant.

#14

Just set up my first monome (64) w/ mojave and no issues at all. Serialosc didn’t seem to want to get installed but I tried a couple times and it finally worked.

#15

Skipped from Sierra to Mojave myself and have had no issues I recall. Using current model grid, Motu interface, iConnect midi.

1 Like
#16

That’s good enough for me! Downloading it now.

(though I dread having Safari 12, since as last I read it breaks a lot of extensions, and a couple I use don’t work anymore… (Right Exit and OpenAtEnd))

#17

I’m having nothing buy sucsess so far with Mojave. Made the jump from El Capitan to Mojave I think. Mainly using the terms m4l package, the notes app and re:mix. No troubles so far.

#18

I have a hard time getting serialosc to run again after my mac woke up form sleeping. Un plugging and repugging seem not to help. I am on Mojave.

#19

is there any hint on what to do every time my system is crashing or the computer hibernates i have to do a restart. @tehn any leads?

#20

are you running serialosc manually or is it autostarting?

you don’t have the FTDI OEM driver installed, correct?

#21

it is autostarting. I did not install the FTDI driver, but just to double check is there an uninstaller for the FTDI driver? I might have migrated from an old system.

#22

Hey y’all — I’ve got a setup that consists of monomeSerial, a (I think) 2nd or 3rd gen (walnut / aluminum) 128, and Reason. MonomeSerial just connects to Reason and I get a 128 button MIDI input. That’s literally all I use it for. I don’t even bother with getting the lights to work.

I recently installed Mojave, and I’m wondering if there’s a compatible version of monomeSerial floating around out there somewhere. Any help would be much appreciated. I think I tried installing SerialOSC a few years back, and I could never get it to work, but if that’s the direction to go, then any help there would be appreciated too.

Hope I can get my setup working again!

#23

Some discussion going on here may help:

#24

monomeserial won’t work. you’ll need to use serialosc, and https://github.com/monome-community/collected/tree/master/monomebridge

#25

Thanks! I’ve got monomebridge working, but it’s not able to see my 128. I’ve tried disconnecting / connecting, and I’ve checked that serialoscd, serialosc-device, and serialosc-detector are all running.

Any idea what else I could try out or should do?

#26

make sure to uninstall the ftdi driver (as noted on https://monome.org/docs/setup)

#27

Ok, nuked the FTDI, and restarted, SerialOSC is running, and I still can’t see the 128.

I noticed in another thread that some people were having issues with SerialOSC and Mojave… @tehn , think they’re related?

#28

Hey @tehn, I’ve got serialOSC working, but Reason still isn’t picking up the MIDI. I’ll check on the Reason forums from here, but thanks for the help!!!

1 Like
#29

No, but you can run the following commands:

sudo rm -r /Library/Extensions/FTDIUSBSerialDriver.kext
sudo pkgutil --forget com.FTDI.driver.FTDIUSBSerialDriver

Then reboot (and this is important!)

#30

monomebridge doesn’t have midi built-in, and now that you’re asking for that i realize you don’t even need monomebridge.

instead

download max
get the monome package
run grid-midi.maxpat which is included

and you’re good

4 Likes