MacOS 10.14 (Mojave) and serialosc

it is autostarting. I did not install the FTDI driver, but just to double check is there an uninstaller for the FTDI driver? I might have migrated from an old system.

Hey y’all — I’ve got a setup that consists of monomeSerial, a (I think) 2nd or 3rd gen (walnut / aluminum) 128, and Reason. MonomeSerial just connects to Reason and I get a 128 button MIDI input. That’s literally all I use it for. I don’t even bother with getting the lights to work.

I recently installed Mojave, and I’m wondering if there’s a compatible version of monomeSerial floating around out there somewhere. Any help would be much appreciated. I think I tried installing SerialOSC a few years back, and I could never get it to work, but if that’s the direction to go, then any help there would be appreciated too.

Hope I can get my setup working again!

Some discussion going on here may help:

monomeserial won’t work. you’ll need to use serialosc, and https://github.com/monome-community/collected/tree/master/monomebridge

Thanks! I’ve got monomebridge working, but it’s not able to see my 128. I’ve tried disconnecting / connecting, and I’ve checked that serialoscd, serialosc-device, and serialosc-detector are all running.

Any idea what else I could try out or should do?

make sure to uninstall the ftdi driver (as noted on https://monome.org/docs/setup)

Ok, nuked the FTDI, and restarted, SerialOSC is running, and I still can’t see the 128.

I noticed in another thread that some people were having issues with SerialOSC and Mojave… @tehn , think they’re related?

Hey @tehn, I’ve got serialOSC working, but Reason still isn’t picking up the MIDI. I’ll check on the Reason forums from here, but thanks for the help!!!

1 Like

No, but you can run the following commands:

sudo rm -r /Library/Extensions/FTDIUSBSerialDriver.kext
sudo pkgutil --forget com.FTDI.driver.FTDIUSBSerialDriver

Then reboot (and this is important!)

monomebridge doesn’t have midi built-in, and now that you’re asking for that i realize you don’t even need monomebridge.

instead

download max
get the monome package
run grid-midi.maxpat which is included

and you’re good

4 Likes

Righteous, got it working! Thank you so much!!!

I originally posted in the High Sierra thread that my grayscale 128 is not working. It is still not working in Mojave.

When I execute ls -lha /Library/Extensions/ | grep 'FTDI' I only see this FTDI file:

drwxr-xr-x@ 3 root wheel 96B Dec 16 2015 FTDIKext.kext

When I execute: ls /System/Library/Extensions | grep FTDI:

AppleUSBFTDI.kext

Executing serialoscd results in -bash: serialoscd: command not found. However ps -ef | grep 'osc' shows that serialoscd and serialosc-detector is running.

501   585     1   0  9:27AM ??         0:00.01 /Library/Application Support/Monome/serialosc.bundle/Contents/MacOS/serialoscd
501   654   585   0  9:27AM ??         0:00.01 /Library/Application Support/Monome/serialosc.bundle/Contents/MacOS/serialosc-detector

The grayscale 128 is connected to my computer:

When I had High Sierra I tried many combinations of the FTDI driver and am not sure if I have properly cleared all the results of those attempts. My computer is a 2015 Macbook Pro Retina, and I have Mojave 10.14.1. Does anyone have any advice?

Thank you.

Ok I’m having a problem I had a couple years ago again.

When I fire up Max and connect to a device the first time, works awesome. If I close that patch, I can’t get anything to connect to any monome device again until I quit out of Max and restart.

delete that file and see if things improve. that’s the OEM driver.

augh. what OS point version are you on?

10.14.1 (though I see a 10.14.2 is out). I’m on Max 8.0.2, but I can also test the problem out on 7.3.5 as well.

edit: did some further testing and it all appeared to work right (in both Max8/Max7) BUT it still did fail to reconnect on one of the tries (maybe like 1 in 10 attempts).

At first it was all perfect, then I realized I was plugged into a different port last time (left side vs right side (which I guess are different on the 2017 MBPs)) and when I switched back to the left side, it failed to reconnect…

But after that it was fine. So not sure what’s going on.

Let me know if you want me test anything or have terminal spit something out.

@tehn - removing /Library/Extensions/FTDIKext.kext did the trick. My grayscale 128 works again. Hooray!

FWIW:

grid/serialosc and Max all seem to be working fine here. All software installed today (012919). Grid reconnects fine when changing Max apps.

MacOS 10.14.2
serials 1.4.1
Max 8.0.3
grid 128 (2018)
MBP 2017 w/SSD

2 Likes

Not a beginner, but have had these similar issues many years ago with my first Monome 40h, rarely with my old walnut non-varibright, and now with my 2018 grid. All my usual fixes aren’t working and I suspect I’m another victim of the fickle Apple audio driver policies.

My grid appears under devices:

But does not appear in Max 8 under monome grid-test, @neauoire’s fantastic Linn or Rack devices, OR in my old reliable Mark Eats Sequencer app that usually has the best track record of connectivity.

Running the following command:

Yields:

no matches found: /dev/tty.usb*

I’ve deleted FTDIUSBSerialDriver.kext (which is the old fix that usually works), I’ve reinstalled SerialOSC through the monome setup docs and nothing.

SO… help? :grimacing:

For what it’s worth, I was initially attempting to use the grid on the Trilogy VCV rack modules and no dice, but the grid DOES work on my Norns.

MacOS Mojave 10.14.6

you restarted your computer as well, right?

did you install the FTDI VCP driver? you need to, if the other one was deleted

in the newest MacOS this is generally not needed (the included driver now pretty much works)