macOS 10.15 (Catalina) and grid/arc

starting to get more Catalina q’s in the inbox, wanted to see how things are going with folks + their grids/arcs on macOS 10.15. looks like Apple nuked the AppleUSBFTDI.kext, but unsure how that’s affecting things.

any confirmation, positive or negative, will be good data :slight_smile:. if you share, please also let us know if you upgraded to 10.15.x or if your machine came with 10.15.x

Upgrade everything works fine.


I’m happy to take a list of issues and raise Radars so feel free to ping me if you feel you don’t want to do it yourself. Any logs etc associated with issues will be helpful.

Not upgrading my current machine to Catalina, but will chime back in next week when I pick up my 16” MB Pro and get everything going :slightly_smiling_face:

1 Like

following up as promised to say that installing serialosc was a breeze. after a quick download/install/reboot it just worked

for the record i’m running Catalina 10.15.2 on a brand new 16" mb pro

also props to team monome for the great new docs. it’s obv been awhile since i’ve been on that part of the site and although i’m quite familiar with this stuff now, it’s refreshing to see the care and effort put in to make things as clear as possible for newcomers


Weird that everyone else is having an easy time of it. I’ve tried every single cable / configuration and can’t get anything to show up. Catalina 10.15.3 on the new 16" mbp. I know the monome works fine, was able to talk to it via raspberry pi… to make things even more confusing, I guess kexts got moved somewhere else and there’s no longer /dev to check for the devices since catalina does a secret users volume mount now… any advice? I’ve tried the installer, manually compiling libmonome/serialosc from git, etc etc

did you try manually installing the FTDI VCP driver?

No, I thought we were on the AppleFTDI bandwagon. It says in the setup docs that FTDI is a problem to be removed. Will do so now and report back~

well I’ll be damned. Works now, should that “alternative” install path be put back into the docs?

My grid still doesn’t survive an unplug/replug with a reboot, but I don’t think I ever got that one working…

many thanks~

1 Like

Catalina is a unique beast w/r/t the FTDI driver, which was the impetus for the thread – we needed more data points. I’m super glad we have your confirmation! I’ll add it as a Catalina caveat :slight_smile:

Hi! My first post after a long time on the forums :slight_smile:

I had the opportunity to buy second hand a grid 256 varilight. When trying to check if it is working in OSX Catalina, I have no luck getting the command ls -lrt /dev/tty.usb* returning --> zsh: no matches found: /dev/tty.usb*
Serial osc is running
What is strange is when I’m trying to check it on another older mac with mojave it is recognize…

Anything I’m missing on the Catalina install?


Sure I have done it
Step one / OSC serial woking

Step 2 / execute ls -lrt /dev/tty.usb* got error message
Capture d’écran 2020-09-28 à 17.33.48
Step 3 / nothing is returning from the command

As I said it is working first trial on my other mac with an older system… so guess I have something install and causing an issue…maybe

So nothing from the instructions was working for me (thanks to Dan at Monome for the grezt help). I have to do a clean install of mac osx Catalina. Apparently it was something conflicting due to past development tools installation like android environment for Unity. So now I will keep these tools in a separate account :slight_smile:
Going to enjoy the 256 right now!

1 Like

Necrobumping this because the thread title seems to be appropriate.

I’m on a 2015 MacBook Pro running Mojave.

I’d like to update it to at least Catalina but am concerned about what is likely to break.

Any advice on updating from Mojave? I’m definitely not ready for Big Sur.