Max4Live clip playing?

Trying to observe if a clip is playing. message “property playing_status” only returns a zero whether clip is playing or not. I thought “is_playing” would work. What am I doing wrong here?


----------begin_max5_patcher----------
548.3ocwVtsaiCBDF9Z7SAhq8FYricR2WkpJKrCJktNfEfcSTUe2WXvNa6t4
jSR2dQbDCjYlu+wyPdKBQpTa4FB9m3GwHzaQHDXxa.MrFQ1v1V2vLvwHa3FC
aMmDG1S1sQ0Ya3VXW5f0Vls9YgbcolWaCdOawCyxiwYEIyRhw4vyzzYI3mF9
MF6tFNDhQeKVAKUUu7irjQignY20xC9kP16AWtHjioRp216QQ9GwWGaV9VH4
cIBtfNexHmmLGnb4Ugb5x+GHK4u5B1+PrEWgaNLvomnFuL.bVp+qroBbwQAt
hIWShOJ3z6XstUqZ4Z6NrvT11v1I7QdpuqmUDJ7fbPozIJD4emur634Ybinm
WZ3VrUyp+kAOOGW2HZKMMJqAmbsc+zEfTPeHaZJBs3arWvqEy7pxgoN6rTml
.TmmOQnyNNzwCete8CmBdUkgq645oOPXXnOcoGc2hoI.omV.NRkez0rd9pRm
ebYSIyZ0hpNa3tNzdM.QJcc6Fgwxk078ZWP7FkPHNNkP922TBD6s+Yc0n5z0
iY5HH3+.8JtwJjLqPI+vg7Wwgo3mNXs6RijeFp2ImLR9aV9vgT5UtRqa6jaO
zmCR+nM+g95gDz7C.I8lBsum775aw8.x7KPNGew51X5RJb.3eNRg1BVaauuC
JbZHHtAKun.wdQLrTHCKgQkDMuWLd94fEl1M3v55S6zggAaKB+aKxFkqrI6D
CUNWjeO52XikygA
-----------end_max5_patcher-----------

I will have a look in an hour, when I’m back home.

OK, I’ve had a look at your patch.

Here’s the answer : in MaxForLive it is not possible to observe if a clip slot is playing.
You can only access the property “is_playing” with a “get” message (and it only works with clip slots of Group Tracks).

If you really need to know if a clip slot is playing using “observe”, then you can use the property “playing_status”.
But this, too, can only be used with clip slots of a Group Track.

If the clip slot you need to observe is not inside a Group Track, then you can observe the clip playing status (instead of the clip slot), or you can know if the clip is playing using a “get” message.

Please don’t hesitate to tell me if this is not clear enough, and, if you’re not familiar with it, I suggest that you explore this page :
https://docs.cycling74.com/max7/vignettes/live_object_model