Max4Live Grid Recognition Troubleshooting

Hoping to crowdsource some troubleshooting steps I can take for the following problem: my grid isn’t being recognized by any of the Max4Live devices I try—the serialosc dropdown just says “none”.

grid-test.maxpat and indeed all of the Max patches in the Monome package work just fine, so this is really only a Max4Live problem as far as I can tell. Curiously, all the devices (e.g. markeatsclips, gridlab) seem to recognize the grid if I open them in Max, but not if I use the edit button in Live.

Any ideas greatly appreciated! I’m in Live 10.1.30, Max 8.1.5, MacOS Big Sur

I had that last week, where the arc was shown but not the grid. Two or three times unplugging fixed it (on windows though).
Then only other reason I can think of is big sur, as it is yet to be announced compatible by ableton afair

I guess it must have been some kind of transient problem—restarting all the relevant things enough seems to have resolved the problem!


I’m currently running into this issue on a new Windows 10 machine. Running Live 10.1.30 suite, Windows 10 20H2 build 19042.867. monome is showing under “Other Devices” in Device Manager, but with no driver installed, and serialosc is running in Services, but no luck getting it to show up in M4L. I don’t have standalone Max to test if it works in that, however.

It could be the driver issue? But I don’t recall having that problem with my last PC.

hey hey! sorry to hear about the issues :confused:
we should really get a windows machine in the workshop…

standalone Max is free to download + use – only if you want to save patches or export devices does it require payment. there’s a grid test patch inside of the monome package, which should confirm whether things are generally groovin’.

you can also download the monome package from the Max for Live editor, which is just standalone Max running inside of (and authorized by) Live :slight_smile:

Thanks Dan! Happy to be the guinea pig on this one. Installed Max and pulled up the test patch. Get this from the debugger; no errors:


Still no grid detected though; it says serialosc running so that confirms what I’m seeing in the Services pane in Windows.

rad, thank you!

hmm. there’s a pretty nice overview of steps from a success last summer with windows 10 here: 2x mk 2010 grids -- unable to connect to serialosc (Windows 10) - #7 by silent_strangers. please lmk if any of that clears trouble!

1 Like

It was indeed the Bonjour Print Services of all things. Grid test works just fine after I got it installed and the service running. Do we know the reason for that?

fantastic news! i’ll add to the docs!

ah! it actually makes sense after working a year of front-line support for c’74 – MIRA requires Bonjour to be installed on Windows to shuttle network messages. i wonder if Max’s OSC protocols also generally rely on Bonjour.

i think it was less common to have to install Bonjour Print Services when folks were using iTunes, as Bonjour is bundled with it.