The Braids adaptation is really great. On my DIY Norns I only have mono output (left side). The Braids Eurorack module is of course also mono, but is it possible to duplicate the left channel to the right channel in the norns engine?

I ran mi-ugens-install.lua above.

If I run sclang, it looks normal except for: *** ERROR: dlopen ‘/home/we/.local/share/SuperCollider/Extensions/MiRings/MiRings.so’ err ‘/home/we/.local/share/SuperCollider/Extensions/MiRings/MiRings.so: file too short’

Try re-installing the ugens?

Not sure if you need to delete the existing ones at ‘/home/we/.local/share/SuperCollider/Extensions/ The shell script is doing a cp -r so I’m not sure if that replaces or not.

I’ll have to look at this.

I had trouble installing this morning—
Renaming ‘mi-eng-master’ to ‘mi-eng’ and then restarting Norns made it all work.
Thanks for the handy ugen installer! I forgot how to access above dust folder.

1 Like

Hmmm. I tried reinstalling after deleting the existing ones and it just hung on “loading…” I think I’m going to re-image.

should not be necessary to re-image. I can help debug further in a couple hours

great work okyeron, these work great. Some Braids ones at least I think sound a bit different than what the name implies. And I suspect the scripts are mostly intended to test the engines, but as these are the most ‘public facing’ bits if you will, it would be nice to credit Emilie as well as Volker.

good call.

This is all very very BETA at best. :slight_smile:

1 Like

No biggie. I need the practice. :slight_smile:

Got 'em working. So. Very. Cool!

1 Like

Updated everything and I get this error from macro-b resonate and texture


/home/we/dust/code/mi-eng/texture-c.lua:72: attempt to index a nil value (field ‘?’)

stack traceback:

/home/we/norns/lua/core/norns.lua:128: in metamethod ‘__newindex’

/home/we/dust/code/mi-eng/texture-c.lua:72: in global ‘init’

/home/we/norns/lua/core/script.lua:103: in function ‘core/script.init’

[C]: in function ‘xpcall’

/home/we/norns/lua/core/norns.lua:129: in field ‘try’

/home/we/norns/lua/core/engine.lua:91: in function </home/we/norns/lua/core/engine.lua:89>

so… I guess I broke something. Will do some testing after lunch and try to figure it out.

EDIT: yeah - screwed up something with the pmaps I was working on yesterday. Will push a fix in an hour or two.

1 Like

No hurry - I thought I broke it.

Update v0.3.3

pull new mi-eng from github.

  • fixes init error from v0.3.2
  • clouds re-work
  • testing creation of default midi map for 16n
  • Braids - use CC 47 to enable meta mode (random)

Thanks - totally works now. Great graphics update on all of these!

Update v0.3.4

pull new mi-eng from github.

Probably a good idea to delete existing psets/pmaps from inside ~/dust/data/mi-eng/

  • fix for pmaps with missing values not matching param controls.

For the moment if you re-map midi, you need to save a pset for that to be remembered. Then you will probably need to re-launch the script once to get the on-screen controls updated to those changed CC values.


install worked great and i can’t believe suddenly, after all these years, Clouds. thank you @okyeron, totally amazing.

currently i am unable to switch “dials” on the graphic screen, although the three dial parameters (pos size den) work and all parameters work from the Parameters menu. i know you’re at the somewhat experimental stage, what’d i miss??

Midi controller needed to change other dials - everything available on params page tho.

1 Like


@justmatt added LFOs to the Texture-C engine and test script (lfo yer clouds, ya’ll).

It’s all in the parameters. I’ve not done much testing yet, but give it a go and report back. :slight_smile:

(no need to re-install UGens, just re-pull the mi-engines repo)


Would it be possible to make polyphonic [or maybe even multitimbral] version of Plaits or Braids?

1 Like