Mi-UGens for Norns

Installed. All good. Reaaally enjoy clouds. I installed via winscp :)) it was a breeze. Sleep and rebooted. I`m on last norns fw on fates :slight_smile:

1 Like

Installed on norns shield. Rings works great, but clouds, elements, and plaits all give an error: load fail. Used the lua script to install the ugens. Using latest norns release. Any ideas?

@ pcnclghtnng You need to Restart norns after installing the ugens, also check that the script directory in dust/code is named “mi-eng” and not something else (by default github names it "mi-eng-master, that won’t do it).

1 Like

@sns I did restart, but the github zip download naming convention was the key. After removing “-master” from the folder name they all work, thanks!

4 Likes

Really want to try this, but lost with the install:
I ran the (updated) lua script and I had an ‘install complete’ on the norns script, but nothing else, no error message but no mi-ugens folder too.
I surely miss something…

the ugens install at /home/we/.local/share/SuperCollider/Extensions

Be sure you’re using the install script from the Top Post

Remember to reboot

also note - the actual scripts are a separate install

Thank you very much for the MI Engines. Great work! Rings, Clouds and Plaits run smoothly on the Norns Shield, only Elements doesn’t react to Midi notes (or Norns Buttons). Any ideas what could be the reason for this?

I’ll take a look at it later tonight. Might be something in-progress or just forgotten. :slight_smile:

2 Likes

Fantastic work! Playing with clouds, out of my rack and without a way to trigger it except internally with the density control, I am realizing that a clouds/torii combo would be amazing! On top of that, it is making me see that clouds + a trigger sequencer could make a super cool trance gate in my modular system! Fun times!

I must be an idiot. Do you run the installer script from within maiden/matron?

you can run it from inside Norns itself after putting it into your code folder

Do you run the installer script from within the norns front end or ?

I followed the instructions in the post at the top, and everything seemed to be working until I got this error: -- Configuring incomplete, errors occurred! See also "/home/we/mi-UGens/MiClouds/build/CMakeFiles/CMakeOutput.log".

I’d suggest not building the ugens yourself. The source code is being actively developed and might cause compile errors like this on Raspi/norns.

Grab the updated binaries from the top post.

  • Copy the installer script to ~/dust/code on your device.
  • Go to maiden (reload first) and run the script, or run it by selecting it from the scripts menu on device.
  • Restart your device after installation.

Seriously man - you’re the best.

2 Likes

I went on these today and played on the scripts - really enjoyed Plaits especially. Mainly because i can use it without a keyboard and just a controller. Big thanks for doing this.

A couple of issues I came across, I couldn’t get any sound at all out of Elements. I was using the same midi keyboard that triggered Rings and Plaits Ok. I also remapped with a Faderfox. None of the dials on the screen were updating/moving when I used a controller on any of the scripts. I used the Lua script to install and everything seems to be in the correct folders.

it would be good if you could get some very basic grid support, something like earthsea would be welcome. So I can use that instead of a midi keyboard.

1 Like

Thanks for the feedback!

It’s still very early days for my demo scripts and def not “release ready”. I should probably make a Library post for the mi-eng scripts to separate the discussion from the ugens themselves.

Elements may be broken (or I’ve not pushed recent changes). I’ve not had a chance to check on that yet. I had been trying to generate a mapping for 16n defaults - cc’s 32-47 on channel one.

Grid support - I’ll see what I can do, but my goal here is first to be synth engine libraries/demos that could eventually be used in other scripts.

5 Likes

Yes, I guess this thread is primarily about getting the engines working and developed. I think you’ll get a lot more people beta testing them and other coders maybe helping out, if the scripts were in a library post, even at this early beta stage.

The Elements script must be an older version.

Yes understood about the grid support - I’m jumping the gun a bit :slight_smile:

1 Like

Same experience with elements… nothing triggers it? Plaits engine names are off by one. Probably an array starting at zero instead of one issue? Otherwise, great fun! And nice graphics. I installed the super collider files via your lua script BTW. Worked fine. Will be useful if they get updated.

Updated github (I forgot to push elements changes the other day).

Also - a new Library topic: Mi-engines

3 Likes