Midigrid: use launchpads & midi grid controllers with Norns

I linked to it in the trade forum. I loved the 16 button one I had (my brother ended up “borrowing” it). The buttons are awesome. Figured I wouldn’t lose anything by trying it with various bits of my setup.

Oh, this one is really awesome. I have spare Ableton Push 1 around and just wondering is there any way to get it working as grid as well? Is there particular reason why only push2 is supported?

Many thanks working on the alternative grid support!

Push 2 is supported because a few people put in the effort to support it and submitted the changes back into midigrid. The Push 2 is also more well documented.

From what I can find the Push 1 should work with the Push 2 code, but I think some people have tried that without success.

What I’d suggest you do is connect your Push device to Norns, put the Push into “User Mode” and see what shows up in the midi devices menu, hopefully you will see something like “ableton push” and “ableton push 2”. The second device is the name you will want most likely, then you can add this to supported_devices.lua ie. { midi_base_name= 'ableton push 2', device_type='push2' }, and with the Push still in User mode test things out and see if it works. Cheat Codes 2 would be a good script to try as it has built in support.

Let me know what you see and if you have any luck.

3 Likes

Many thanks for definitive answer.

I did some googling about push 1 user mode and tried to access it without live with no result. When the push 1 is connected to live, you get to the user mode by pressing “user” button. The mode exist until you turn off the device and seems that there’s no way to get to “user mode” without first initialising live. So no way to get to the user mode by using norns as usb midi host.

Probably this is the reason there’s no implementation for the Push 1.

I’ve got a Neotrellis M4 here if it’s not too puny a device, haha. It’s only 32 buttons, but I’ve seen others mention the possibility of rigging up four of them for the full 128? Those units sell $50 a pop, that’s several hundred dollars less than Monome Grid…

There’s an incomplete fork / PR to support the M4 in midi mode, but I think the author gave up on it in favour of the neotrellis monome emulation as found here DIY monome compatible grid w/ Adafruit NeoTrellis

1 Like

Unfortunately, that Ada fruit build is discontinued. Damn.

Edit: looks like a few kits are still floating around though, hrmm…

I have a monome- firmware for the neotrellis M4 I can send you

not sure what scripts are gonna be cool with the 8x4 layout. I know Loom works tho.

1 Like

Hey, that would be swell, thanks! 8x4 is better than 0x0, haha. You can send to fuzzpope @ Gmail, much appreciated!

actually duh - the hex is up on github. There’s a UF2 in this directory

Thank you, sir, much obliged!

I’ve removed my launchpad x from the norns MIDI settings, but a button (row 1, col3) still seems to blip random colours in cheat codes 2, when other pads are hit. Interestingly, the novation logo will sometimes changes colours as well.

It’s more cosmetic than anything else (works great otherwise :smiley: ), but I’m curious if if this is a midi grid or cc2 thing?

Most likely this is at midigrid or lower level, possibly right down at the Linux driver/kernel level.

One day I will sit down and see if I can reproduce it in C or another low level language …

Early days playing with norns and I spent a while the last few days going through the scripts I have installed and modifying them to work with Midigrid.

I’ve added them to the list on the community page.

Following a mixture of the method outlined in this thread and the one in the pdf by helen on the community page.

I don’t really know what I’m doing, so I’m overjoyed that it’s mostly working.

4 Likes

FWIW I experience the same on a Launchpad mini mk3 (logo and third button randomly changing color), even when it’s not in the midi slots, I got used to it though :slight_smile:

Hey guys, thanks for all the hard work getting these to work together. I’m brand new to the Norns (and in over my head with the scripts). I’ve been having success connecting the Launchpad mini mk3, but for some reason Cheat Codes started freezing after I installed midigrid. It works fine as long as the launchpad is not connected.

hi hi! hope all’s well and welcome :slight_smile:

i noticed this starting to happen as well recently, which is likely because cheat codes starts in 128 config – i’m assuming that when LEDs which are outside of the drawing area are called, a nil value is causing trouble with midigrid. i’ve hardcoded the midigrid installation check specifically for 64 grids because the 128 layout, when split across two launchpads, is super wonky – plus, the 64 grid has its own dedicated interface.

i’m still trying to work out how to retain the previous seamlessness (where folks don’t need to add anything to the script themselves), but until then:

  • launch cheat codes without the launchpad attached
  • under PARAMS > grid, turn midigrid? to yes, which will make the size 64 and the varibright 4-stage
    • you can also just specify that the grid is 64 and the varibright should be 4-stage, but that lil’ midigrid toggle flips 'em at the same time
  • these settings will be saved, so if you plug in your launchpad and relaunch the script, you ought to be good!

lmk if you run into any further trouble :slight_smile:

2 Likes

Midigrid will respond to grid.is_midigrid with true and null from a normal grid if this helps?

is_midigrid = true

Midigrid now also implements .device now which might be why it “works” when it did not before.

1 Like

That did the trick! Thank you so much for that super speedy response Dan! Now I can start cruising through your hackspace tutorials. You’re the best!

1 Like

ahhh this is all helpful for wrapping some guardrails in cc2, thank you!!