Mlr (norns)

I haven’t tried anything else as far as I remember…

bugs will be fixed Thursday! apologies for the delay. no idea what changed.

this will also give me a chance to add some small things and get to the other issues on the list.

11 Likes

sounds like phase offset / quant issue, no?

i’m noticing that phase quant and offset is only being set when a clip is loaded

phase quant and offset are affected by softcut reset:

so MLR should be careful to set them appropriately. before reset you could probably get away with this if MLR was the only thing touching those params.

2 Likes

yeah but set_clip gets called in init

i’ll dig in properly

So i’m trying to sync up with ableton - do you know how i would go about getting it to show up in this slot?

I have no problems syncing up to ableton when using Orca which is what is confusing me.

How exactly?

You would need a usbmidi Host-to-Host adapter of some sort - like the SevillaSoft device, my 2host, or an iConnect midi interface. (Or a pair of usb to midi adapters)

@okyeron I’ve got a usbmidi cable and it’s hooked up to my interface that ableton is using. When I use orca, it syncs no problem (I don’t need to select it in the norns midi settings). But when I set midisync in the Mlr settings, ableton doesn’t receive any clock data. Do I somehow need to find a way to get ableton to show up in the norns midi slot 1?

Here’s the code in mlr for midi clock:

   midiclocktimer.event = function()
        if midi_device and params:get("midi_sync") == 2 then midi_device:send({248}) end
      end

Reading that MIDI beat clock start/stop values are int 250 and 252 and tick is 248.

Maybe Ableton wants 250 first?

Orca code looks pretty different and glancing over it quickly, I couldn’t see something similar.

To clarify - “Ableton” will not “show up” in slot number one. Your midi interface will be listed there.

What is your midi interface named and what do you see listed for SYSTEM>DEVICES>MIDI? Is your midi interface device name listed in the first slot?

If not, you need to click button3 and then select the correct midi interface. (the interface needs to be connected via USB when you select it - norns will remember it in this position even if you disconnect it later.) If that interface is listed in another slot, then click button3 to set that slot to none

If at this point it’s still not working, then there may some problem with MLR itself.

FWIW - Just trying this now and I can’t make it send clock either.
EDIT - just tried again with a fresh install of MLR and I get clock to my computer OK.

EDIT #2 - if you’re still having trouble - try re-downloading the current version of MLR and start over from scratch. Also, you might want to do SYSTEM>RESET just in case.

@okyeron That worked! Just needed to re download mlr. Thanks a bunch!!!

2 Likes

ok unfortunately debugging this revealed some other issues I am tracking down, will continue tomorrow

9 Likes

Was able to give it a go yesterday and seem to be starting to get the hang of it. Thanks for the breakdown, seeing it explained a different way helped me understand a bit better.

1 Like

can anyone explain what the level slew param does? can’t quite identify it by ear

ed. should have searched first :disappointed:

fixed! please download 2.1.1 to fix the pesky off-by-one bug, which also affects loop lengths.

12 Likes

Fixed it for me! Many thanks as always.

1 Like

Can anyone help me with the tempo. when i cage it im not seeing the light on the cut page move any faster or slower or anything seaming like its changing.

Curious about that as well, so far for me the tempo parameter is virtually useless even for loops preset to the right tempo.

@robotboot @LLK hold alt and press focus to enable tempo mapping of selected track

1 Like

It was indeed in “quantize” section of the manual sorry for asking (somehow “tempo mapped” didn’t ring a bell in my mind for this kind of behavior ? weird). Thanks anyway ! Not that I’m using tempo much with MLR but that’s great to know for future use !

Edit : it’s pretty intimidating to answer that to someone who’s nickname is rdfm by the way.

1 Like

I think this did the trick for me.
any reason "audio.level_cut (0.5) isn’t a sort of defat?