mlr (norns)

clock tempo is set globally via the PARAM menu, is it not saving between boots? are you using other scripts in between which set the tempo?

i checked quickly and i don’t think mlr itself sets the tempo, but the default clip length (if you’re recording live) is 2sec, so if you octave shift it i guess you could get what feels like 240bpm?

Thanks for quick reply. No it’s not saving between boots. Sometimes I use other scripts but at the moment am only really exploring MLR. Even when I do use other scripts I almost always have a tempo around 50bpm…

Finally got mlr working with push2.


where is it? i can’t find it
thank you

edit: it was in the params page, obviously. (thanks @eigen !)

if anybody want the pan setting on hand, i added it in the cut page, near the volume, controlled by encoder 3.
just add at line 701

if n==3 then

and at line 720



@tehn something always blooms when revisiting mlr. it’s pretty timeless. wondering what line the crow out’s in the code are? i’d like to add ii out if possible…thnx

also where is best to look to add a few more recording options for gestures to the top row?
specifically the 4th from the left and the 3rd and 4th from the right on the top row.


@tehn @dan_derks
Was this ever implemented? I have a show coming up and I’d like to use MLR/grid if possible. Ideally I’d like to just be able to load up 6 audio files, with the volumes and other parameters saved and ready to jam with, and then load up another 6 files for the next jam. Apologies if this has been answered earlier in the thread.

hi hi! yep – if you save a PSET of a specific jam setup, that’ll capture everything you see in mlr’s parameters (including vol + file) which can be restored through the LOAD function of that menu. hope this helps, have a great show!! dang, it’s been so long since shows!


Amazing! Thanks dude

Hey! I used to use MLR ages ago and I just went back to it to find out that it does not record anything into to buffer :scratch:

I select the channel, turn the overdub up to 1, press play and then record and it doesn’t seem to be a way to make it record!

Audio is passing through correctly… am I doing something wrong? Pretty sure I am not.

Has anyone encountered any problem like this? I tried to look in the forum but I could not find anything related.

Oh and yes, I tried to uninstall it and install it again :slight_smile:

are you on the latest norns version? i haven’t checked for a while, so i’ll take a look

Just updated and now when I try to launch MLR it gets sticked on ‘loading…’

Edit: It gets stuck with every script :open_mouth:]

EDIT EDIT: forgive me, after an hard reset it is launching the scripts. Still the same problem with MLR

It’s possible that the softcut input level is turned down. That happened to me after one of the last couple updates.

1 Like

it was actually turned up. Not sure what happened but it is now working. Thanks for the hint tho!

1 Like

Newbie deciding to take the plunge on a Shield here, and just want to be sure :slight_smile:

So is this the same with the Shield then? I have an ERM clock for my hardware, can I take the master from that through a USB and sync to my hardware/ableton?

is there a version of mlr with non variable brightness? :slight_smile:

1 Like

It’s definitely somewhere, because mlr existed way before varibright grids! Not sure where to find it though. hopefully someone can post the link.

I would assume so, but cannot say definitively as that’s not something I’ve tried.

64 or 128 grid? It’s a fairly simple modification to the script.

@kin.sventa has his own method

1 Like

a 128 :), I saw the g.led part of the script but I am new to norns so I was wondering if there was allready one that was modified.

1 Like