Module firmware update troubleshooting

Continuing the discussion from Orca - alternative firmware for white whale and arc [and now grid]:

could you post the individual steps that you’re doing? and the output of the terminal that is giving the error?

also, are you running it on Windows? if you do, you might need to make sure you are running it as Admin.

i seem to also remember somebody having this problem when downloading the flash command directly from git (i think the OS is trying to prevent running something that was downloaded), which can be solved by downloading the zip file that is linked to the release, extracting it somewhere and then copying the flash command from there. alternatively, you can just create the flash command file yourself using a text editor, and just copy/paste this:

#!/bin/sh
cd "$(dirname "$0")"
dfu-programmer at32uc3b0256 erase
dfu-programmer at32uc3b0256 flash orca.hex --suppress-bootloader-mem
dfu-programmer at32uc3b0256 start

Yes, I’ll post when i’m back home, basically i downloaded orca’s 2.3 firmware and tried to open it with dfu but it just kept saying i don’t have enough permissions, then i read Scanner’s tip on that, so i copied the command and created one on text edit, same same. I then pasted it directly on the Terminal but it gave an error.
I then installed WW 1.5 firmware back without a problem

since you mentioned Terminal i assume you’re on mac - unfortunately i have zero mac experience, so not sure what else could be done… one other thing you could try though, since you mentioned you were able to install the WW firmware - i assume you downloaded the WW zip file? so maybe that will help, i’ve created a zip file with the Orca hex and flash, and added it to the release, try using that and see if that helps! https://github.com/scanner-darkly/monome-mods/releases/tag/v2.3

Thank u :slight_smile: I’ll try that right now

Hey man
i got this message in terminal:
Last login: Mon Oct 26 20:33:05 on ttys000
MacBook-Pro-de-Damian:~ damianschwartz$ /Users/damianschwartz/Downloads/orca/flash.command ; exit;
-bash: /Users/damianschwartz/Downloads/orca/flash.command: /bin/sh^M: bad interpreter: No such file or directory
logout

[Process completed]

Since you don’t experience with OSX maybe someone that uses it can chime in? i don’t have a clue what might be hapening here.

i think i might’ve found a solution… can you try downloading a new zip attached to the release, here is the direct link: https://github.com/scanner-darkly/monome-mods/releases/download/v2.3/orca2.3.zip

and try again?

Yes indeed, will try right now

That worked :slight_smile: thank you !

great!

the reason for this was - when i edited the flash.command it replaced Unix line endings with Win style ones.

Trying to update to 2.5 and ran into the same error. Currently trying to run 2.3 but my WW does not appear as a device currently and won’t lend itself to any update.

I got it to work. Just typing this out sort of form myself really as I seem to be forgetting this between each time.

Using the orca zip, I had initially forgot to place orca.hex in the folder with flash.command. What follows might be described as some type of locked up behaviour with a few leds lit and nothing else. Don’t worry.

  • As long as the orca.hex file isn’t in the folder with flash.command the update won’t run. Place orca.hex in the same folder as flash.command.

  • For updating to Orca 2.5, use flash.command file placed in the monome-mods-2.5.zip (this helped me avoid permission errors I think). As pointed out above, the orca.hex file needs to be next to the flash.command file. Look inside your monome-mods-2.5 folder for another folder called orca. This is were the files go.

  • Sometimes Terminal says there’s no unit mounted. If found that the led above clock out was a nice precursor to finding this out, which save me a few rounds of trying to run the update without WW receiving it. After a few rounds of powering on/off my modular, restarting my Macbook, trying both usb ports to connect to the WW I did manage the connection and the update.

  • Is your usb cable really working?

I didn’t contribute to the firmware in any way so there’s no official info to be had from this post.

1 Like

it appears that in the process of updating the manual i somehow accidentally removed the section on how to update the firmware. i’ve restored it and updated it based on your comments - thank you! it should be more similar to the official firmware routine now, and as a result, simpler.

flash.command is now called update_firmware.command, and instead of listing it and the hex file separately in the release i combined them into one zip, which should also help in avoiding permission related issues when downloading the command file directly.

direct link to the firmware update section in the manual: https://github.com/scanner-darkly/monome-mods/wiki/Orca---manual#updating-firmware

1 Like

Cool!

Now if only I could figure out why that Github link won’t jump to the Updating Firmware headline. (https://github.com/scanner-darkly/monome-mods/wiki/Orca---manual#updating-firmware). Tried accessing from Chrome 49.0.2623.87 (64-bit), landed a little higher up on the page and broke my scroll wheel j/k

yeah, i noticed sometimes the anchor links within the manual don’t seem to work. what happens if you click on any links in the Contents section at the top? does that work?

That works, like a 20 character post!