Monolase app

#21

Yeah I can see that.

So it just doesn’t show up at all? (as in not in the dropdown menu of serialosc)
Or does it connect but not do anything in the app itself?

1 Like

#22

my grid doesn’t show up in the serialosc box, as if it isn’t sensed despite having good connection with everything else. so i guess it for some reason isn’t connecting within app. i thought about trying to manually enter it through that port entry. but i’m not sure that would work, and i don’t know my port.

0 Likes

#23

in the monolase app
the words above the serialosc box say-
/sys/prefix /coco
actually a button
~push it
…it resets the serialosc device to /coco

maybe…

0 Likes

#24

tried that to no apparent effect.
did grab screenshot of max window.

something about zeroconf. wasn’t that the connector thing before serialosc?

i also tried opening the serialosc app within ml and it appears to be the genesis of the connection issue as nothing happens with either the old so app or the one i copied and aptly named from the functioning tpv vers. something within the serialosc app doesn’t want to connect to my gs64.

0 Likes

#25

i also tried to use the monome home app and those port numbers from the screenshot to see about manually entering port # data. to no avail.

0 Likes

#26

'sup dude
it’s cool that you gonna rock the monolase!
nice when you post all the details about your setup

it’s possible that my system has an older serialosc version, that needs zeroconfig files
in the externals folder of max
maybe something there…

the old forums have really helped-
different from what you’re seeing, but…
http://archive.monome.org/community/discussion/11282/serialosc-and-first-time-problems/p1.html
http://archive.monome.org/community/discussion/12026/max-runtime-error-solved-/p1
http://archive.monome.org/community/discussion/12861/serialosc-issues/p1.html
…it’s also cool to see that back-in-the-day there were issues, that got resolved on the forum
tech support is way better when we have people that know, like @Rodrigo on the line :slight_smile:

1 Like

#27

yes! i hope i have listed the pertinent system details. i can share more if t’would be helpful.

thanks for sharing those old resources. interesting to read. my problem may well be contained in there but wasn’t readily apparent.

0 Likes

#28

Right right. Yeah that’d be a suuuuper old serialosc version.
I would imagine it still works if you add the zeroconf externals in there. I’m surprised it didnt work when you replaced that version of serialosc with a newer one.

2 Likes

#29

is there an easy way to install the zeroconf externals?

0 Likes

#30

Try sticking these in the same place with any other externals (Max6/Cycling '74/msp-externals/).

zeroconf.zip (89.8 KB)

2 Likes

Needing zeroconf externals
#31

thank you ! ! !
should i delete anything prior?
will try shortly.

0 Likes

#32

Nope, just copy that in there and restart Max.

0 Likes

#33

oh my, well me in my ignorance.
thinking simple, then proceeding, i installed that and restarted. nothing new in monolase, but then also now my monome isn’t sensed by anything. so now monolase is in the same state, but no terms use no funky custom max apps and no tpv connection to monome. :poop:

0 Likes

#34

0 Likes

#35

Weird…

I guess remove them and restart Max again?

I don’t know if I changed the patch since I last shared it, but in the folder on my computer, I have the 2014 version of serialosc with monolase (both local versions attached).

I don’t have a good way of testing anything like that at the moment, but give this a spin.

monolase.zip (56.8 KB)

0 Likes

#36

i will give it a spin.

thank god i was able to reinstall some stuff because it somehow knocked out my audio interface thereby killing my whole studio interaction.

was like my worst nightmare.

somehow 10x as bad as i had thought.

i did something wrong in what appeared to be a super mundane task.

1 Like

#37

but i have stuff working again. monome interaction back with everything except monolase, so i guess exactly as it was before the interruption. i think i somehow had a mix of two things or three. 1 info overload on usb buss on desktop. 2 . messing with msp internals and somehow deleting some necessary shit inadvertently, that part i still don’t understand but it happened.

0 Likes

#38

Holy shit that’s rough! And what an oddball thing to happen with. Glad you were able to refix things!

0 Likes

#39

sorry to be so dramatic, it was just really crazy. no idea what i did. but 100% connected to my lack of understanding about the world.

i am sorry and remain so grateful for your work, presence and guidance.

i did check that monolase version and it works, seems to sense my grid. but still no actual interaction with the grid. i did delete those zeroconf externals you first sent as i was afraid of bogeyman. so that may be the prob there.

but my absolute necessity audio side is working, so i am no longer feeling ill. would still love to get ml working, but i amy have just learned my lesson…

1 Like

#40

Can you stick a print object here and see what it spits out when you press buttons on the grid?

Also, it could be that this era of serialosc doesn’t take messages formatted that way. Can you go to the inspector of serialosc (as in press Command+i with the grey serialosc object selected) and then add “coco” to the arguments area:

Then save and restart Max/Monolase.

2 Likes