Monome 256 detected as 128

for some strange reason, my monome 256 (4-fold varibright) has recently started being detected as a 128. occasionally i can solve this issue by restarting my mac.

i’m running OSX 10.11.3 and max 7.2.0 64bit. any clue?

how consistent is this? does it detect differently on a replug? or is a restart completely necessary?

hey brian, thanks for jumping in.
i’ve tried around and i’m pretty sure a restart is necessary. have un- and reloaded serialosc (via utilities/monome folder), have unplugged several times and loadbanged the serialosc bpatcher repeatedly. nothing seemed to help :confused:

a gentle bump on this one… any help from anywhere?
edit: the problem seems to be getting worse. by now not even a restart guarantees the correct detection of the 256.

just checking-- are you still using serialosc 1.4 ?

new installer is being worked on now…

thanks tehn. yes, running 1.4 – please let me know if i can test an upcoming version…

just to confirm-- do the keypads work even when it’s reported as a 128? (they should)

no, they dont /: well – the last 8 columns seem to receive osc, but don’t output anything.

ah, maybe i got that backwards. do you mean the LEDs still work?

yes tehn, that’s it (:

i’m sorry to ask this-- but is there a chance you have another machine that has a version of os x lower than 10.11.3 ? or do you have a sense that this cropped up after you upgraded?

no worries – obviously i’d like to help! (: i have a macbook running i think 10.11.1 … i can’t say for sure that this bug came up after the upgrade, although i never had it earlier so it may very well be linked to most recent OS. i’ll do a test on the 10.11.1 and let you know.

anything else i could try?

try deleting your serialosc prefs:


no /: … and it’s getting worse and worse. now the monome additionally locks up completely after pushing several buttons. i’m totally lost. after it crashes, nothing goes in or out (of the serialosc bpatcher) anymore.

did you get a chance to try a different computer?

ok, ran a test now. weird:

  1. hooked up the 256 to my 10.11.4. iMac (formerly 10.11.3.) » monome recognised as 128
  2. hooked it up to my 10.11.1. macbook » monome recognised as 256
  3. hooked it back up to my 10.11.4. iMac, but connected it to a different USB port » monome recognised as 256

how ever, i had tried ( 3.) multiple times in the past, unplugging and replugging to different ports, restarting, deleting preferences – solving the problem remained to appear random. i therefore assume that this is no long-term solution.

can you make any sense of this, brian?

Completely random suggestion: have you tried removing /System/Library/Extensions/FTDIUSBSerialDriver.kext and rebooting?

hello @abozzelli – for some reason i don’t have this file :? any clue?

yeee, this problem is really annoying. connecting my monome currently works like 1 in 15 times – the other times it involves various restarts, reconnections and whatnot :frowning: furthermore, it seems to be getting more and more labile.

and another observation – it’s getting weirder:

most of the time, when my 256 is detected as a 128 and i unplug it and plug it back in (while max is running) – the serialosc bpatcher’s umenu doesn’t show any device (only choice in the dropdown is “none”). ocasionally how ever, this does work (how ever the selection remains 128, not 256). if i repeat the step, i’ll at some point have a whole list of 128’s in my dropdown

the grid has no “memory” so plugging it into other machines won’t affect behavior.

however, you mention that 10.11.1 works? so we can narrow this down to a 10.11.4 issue?