Monome 256, yosemite, serialosc problems

hei folks,

i’m dissapointed ): have just got my (used) monome 256 (pre 2011) from ebay and can’t seem to get it to work. strange scenario:

  • serialoscd is showing up 3 times in the activity monitor – one of the processes is peaking at ~100% cpu
  • monome doesn’t show up in monome_sum
  • serial connection via max works strangely: after sending a command to the monome (/monome/grid…), it appears to lock up and stop sending messages back to max (when buttons are pushed)
  • grid studies 2.1 (using the /max/grid… prefix instead of /monome/grid…) appears to work more or less.

any clue? i’m on MAX 7.0.5 + yosemite 10.10.5
gracious for any help!

try this one:

which 256 is it? attach a photo?

hello tehn,

thanks for the quick help! after working my way through various threads, i found your build for the 1.4 version of serialosc. this solved the problem immediately!

i’m using a walnut 256 monome with the rubber “worm” on the bottom and the beautiful “monome” engraving. i wasn’t able to find the current serialosc-version anywhere on the monome site itself (except for in a github, which was of no help to a novice as me). working beautifully and i’m sure there’s more folks who will profit from making it a little more public (:

HI there ,

i have the same problem with my 256 ( 2009) -since the upgrade of Mac OSX , my monme doesn’t show up in monome_sum and Mlrv.
i 'm using Max7 +yosemite 10.10.5
i used the package below but still the same .
i tried FTDI device ,nothing works…
Looking for a french user in Paris …

did you try the serialosc 1.4 link above?

yes i 've tried
nothing works

what version of OS X were you using prior when it worked?

plug in your grid, open a terminal, and type:

ls -lrt /dev | grep usbserial

what gets printed?

that’s :

-bash: s: command not found

i don’t really remember what versions of OS X i used.

Copy paste the command

i copy and paste the command : ls -lrt /dev | grep usbserial on the terminal

and i had this : -bash: s: command not found

thanks !

although it is working for me now (thanks to the serialosc 1.4 update), i’m getting the following output from terminal (in case this is of any help)

@benniii try re-uploading that screenshot

@fred023 copy/paste this: ls /dev | grep usbserial

Last login: Mon Sep 21 19:12:25 on console
MacBook-Pro-de-freddy:~ freddybarbentane$ ls /dev | grep usbserial
MacBook-Pro-de-freddy:~ freddybarbentane$

done! (and <-this here-> i am writing because i need 20 characters to post!)

Stop the presses! I disconnected the FTDI cable (used for development) and then the very most recent reboot has made things work as they should. It’s possible yet another permissions repair to the boot drive and my account’s home folder drive made things better, but I can’t say for sure.

Hi, I am having the problem of a grid monome not showing up in monome_sum. I have tried an older 256, a recent kit 128, and an arc4 (one at a time). None is showing up.
I have installed serialosc 1.4, OSX is 10.10.4 Yosemite, the process table in activity monitor shows 2 serialoscd processes running, one of which sits at 100% when there is no monome attached. When I plug in a grid, a third instance of serialoscd appears. This instance goes away when I unplug the grid.

The output of the suggested ls command is this:
$ ls -lrt /dev | grep usbserial
crw-rw-rw- 1 root wheel 17, 0 Oct 13 22:28 tty.usbserial-FTE54KGT
crw-rw-rw- 1 root wheel 17, 1 Oct 13 22:28 cu.usbserial-FTE54KGT
crw-rw-rw- 1 root wheel 17, 19 Oct 14 20:06 cu.usbserial-m0001017
crw-rw-rw- 1 root wheel 17, 18 Oct 14 20:06 tty.usbserial-m0001017

a footnote: the FTE device is an FTDI serial cable I use for arduino projects.

I also have Max 7.06. When I open Monome Home it shows port 17777 and no monome.

What can I try or do next to make the monomes work?

it seems like everything is mostly working, so this in confusing. try rebooting, and do not plug in the ftdi serial cable. check if serialosc is still at 100%. try running monome_sum afterwards.

After removing the FTDI cable and a restart none of the oscd processes registers more than 0.2% or so.
I start monome sum, it finds the monome, all seems to go normally. While it’s running I can unplug the monome and replug it. It is found in a few seconds when I plug it back in again.

I plugged the FTDI Serial cable, the oscd process with the lowest PID goes up to 100%. If I unplug and replug the monome continues to work. Then I quit monome sum and launch it again. Now the monome can not be found and serialoscd is back up to 97 - 100%.

Next: Quit monome_sum again… unplug the FTDI cable. I used Activity Monitor to kill the 100% serialoscd
process, unplug/replug the monome, launch monome_sum, and everything is working normally…

It seems that serialosc 1.4 is getting confused and hung by the FTDI serial cable.

ok-- so the problem is the FTDI cable. i thought 1.4 was supposed to fix this. are you certain you didn’t install 1.2? did you install monome_sum after 1.4? as the monome installer includes 1.2. Perhaps try reinstalling 1.4?

It’s working now, and it seems to behave properly with the FTDI serial cable inserted, out, and even with the monome plugging and unplugging. The monome grid’s connectedness is instantly reflected in the monome_sum UI. On top of that there is now only one instance of the serialoscd process in the activity monitor, and its CPU utilization is never above 1%.
I think your suspicion was correct-- I installed the serialosc 1.4"driver" before installing the monome_sum “application”. While that typically is the necessary order for drivers and apps, in this situation it created a problem by installing serialosc v1.2 which you said is included in the monome_sum package over serialosc 1.4 which had been previously installed.
There are some learnings to acknowledge from this experience:
The server behind the link for downloading serialosc 1.4 is incommunicado for the past day and a half. (, so it’s a good thing that I downloaded it a few days ago when the server was up. Could it be hosted somewhere on this or another site with other monome downloads? Also, if there are going to be two packages to install, why not keep them separate and therefore separately installable/updateable? Or at least in the monome_sum installer, update it to have the current serialosc, or announce the serialosc version included and make it an optional component of the monome_sum installer.