Monome Basic Installation Help?

I just got a monome which I purchased to experiment with MLR and some M4L patches and some of the other cool stuff I’ve seen online.
I am having trouble getting things installed and finding the setup documentation.

Luckily I found someone who explained the basic setup in the forums so I began following those directions.
[ ]
It felt pretty straight forward, but I got stuck at step 4 (installing the serial osc). From what I’ve read the serialosc is important but I’m not sure exactly where to get it or how to install it. The installer files and instruction links are broken unfortunately. I’ve found various discussions online talking about how to set it up but their links always seem to go to the same pages on the monome site that no longer exist.
i found a couple of downloads online, but i am unclear on which one to use and i want to make sure i am doing this whole install process correctly. [ i am not able to link these in my post because i am a new user but i will try in a reply below ]

I’m also not sure why it says this step is optional. From what I have read in other areas online, the serial osc is the main link between the computer to communicate with monome (or maybe i’ve got that wrong)?

And then I found this link [ Pages Installation for Mac (Manual needed) ] on the new monome forums about installing “Pages”, which made it sound like this is the main important link the computer needs to interpret monome. (Maybe serialosc is to “see” monome and Pages is to “interpret” monome?….)
I went to learn more about “Pages” and luckily there was a pdf manual that was available . But when I clicked on the Installation section, it sent me to another dead link.

I am trying very hard not be “that guy”, the noob that doesn’t read the manual and pesters everyone on the forum for simple answers… But I’m having a hard time finding this information on my own. Any help would be much appreciated! Or if there is some documentation I missed in my searching feel free to send me there!

What is SerialOSC and how do I install it? Where is the official download, is that the GitHub one I found?
What is Pages and how do I install it?

1 Like
  • serial osc download possibilities mentioned above

[] ]
[] ]

have you seen this page?

Yes. Sorry, I should have mentioned that. thats the first thing i did was install that. I was confused by it because it says it includes monome_sum as well as the serial osc, but when its done installing, all i saw was the monome_sum. When the installer finished it pointed me to a page [ ] which was actually another link that didn’t end up working.
So maybe that installer installed serial osc and I don’t have to do step 4 in that monome setup guide?

I think a major step for me at this point would be getting to where i can see my computer communicate with the monome device in any form. I plug in the monome and a few of the squares glow blue for a moment, but I think that is more to do with the monome receiving power than a real communication to software.

In monome sum, i cant find any evidence that the software even recognizes the monome hardware at all. I’m not sure where to look either to test this.
In ableton i cant get the device to communicate either.
also I realized that i’ll probably have to stick with just m4live devices for awhile because i dont have enough $ at the moment for the full Max software (but hope to upgrade it in the future).

To sum up


  • What am I missing?
  • Did that original monome_sum installer install serial osc so I don’t need to worry about that any more?
  • How do I test the monome?
  • How do I set it up for use with Ableton?

to the mods: sorry for the accidental double post, after i submitted it said something about how it didnt like one of the links i used, and i thought the post didnt go up so i posted it again without the http links, but I think I double posted so I deleted one.

I also notice my thread was “flagged by the community”, which I’m not sure what that means…

quick update from a little more research:

I noticed in another thread that @tehn tehn wrote

So it sounds like the best way to test the communication is in Monome Sum… although I’m not sure how to go about it.

I also found an older monome thread [ ] which had a link to “Pages 2” [ ] which had a pretty lengthy setup documentation. Perhaps I should abandon the first set of instructions I found on that forum and all I really need to focus on is that monome sum installer (which included serialOsc when I installed it) and then just follow these “Pages 2” instructions instead?

Sorry for all the posts and I apologize for my complete noob-ness. I am doing the best I can in researching and learning these things.
Thanks for your patience and help!

sorry for the post flagging-- the system is set up to prevent forum spam and multiple same-domain links set it off (even though those links were to, ha!)

serialosc is installed with monome sum, via the installer. while stepping through the installer you would’ve seen serialosc install dialogs. by installing another serialosc on top of the old one, perhaps something happened?

can you check your activity monitor? (let me know if you’re not on a mac) it should look something like this image attached.

Thank you for your reply.
Yes, I had to restart but I do see two instances of “serialoscd” in my Activity Monitor. I installed it on my office machine to test there as well and had the same result. Both computers have “serialoscd” come up twice in Activity monitor and neither have “serialosc-detector.”

As for testing it with Monome Sum, I’m not sure how to do it. I press buttons on the Monome and i dont see a reaction. I also dont see a preferences window that shows the monome on a list of devices or anything like that. I tried holding the top right button (tried all the corners) as the help menu suggested but nothing happened.

Also, I was still unable to get any signal to show up in Ableton either.

Let me know the next steps to be taken :slight_smile:

try this installer, it’s a newer version.

Thanks for your quick reply!
I installed it. After restarting my computer I do see the two activities just like on your screen (serialoscd and serialosc-detector). Now how do I go about using the monome? I tried monome sum again but still couldnt get it to communicate. I pressed “connect” but didnt have results.

Also, I don’t own Max, only Max For Live. Is this a problem?

Let me know what to try next

when you plug in your grid do you see other serialosc processes? there should be more. serialosc-client etc.

what grid hardware are you using?

Good news and bad news…

So, nothing new pops up when I plug it in on my laptop.
Buuut… I just tried it on my Mac Pro, which is a computer I haven’t installed anything monome related on. I actually installed the serialosc 1.4 first, before the monome sum [ ]. I restarted and saw the same two activities in the monitor as expected. Then I plugged it in and, yes, there was a “serialoscd-device” that wasn’t there before on the activity monitor. I loaded monome sum and it detected my “m40h1119 monome”! The monome finally interacted with the computer!

The only problem is that, unfortunately, I would be using the monome on the laptop, not the Mac Pro I got it working on. I restarted the laptop and still didn’t have any luck with the serialosc-device or monome sum. :pensive:

The only differences I can think of is that, first, I started with a blank slate on the Mac Pro and setup the new serial osc 1.4 first. I could see the serialosc-device working before I went any further with any installations. The second difference would be that my Mac Pro is on OSX 10.9.5 and the laptop is on 10.8.5. But monome has been around awhile so I figure 10.8.5 would be perfectly fine.

Is there a way to uninstall the serialosc and start fresh and see if that works? I’m not sure what to try next…

here’s an uninstall script. run it, then run the normal installer from and don’t use the 1.4 serialosc. (360 Bytes)

just to be clear-- you have an old 40h kit, correct?

on my laptop, I uninstalled and then did the normal installer again from your link. still had the same problem of two instances of “serialoscd” in activity monitor and no “detector” like I was able to get on my Mac Pro.
however, I ran the uninstall again and this time tried the 1.4 serialosc instead. PROGRESS! I now have the “serialosc-detector” alongside one instance of “serialoscd” in my activity monitor.
I crossed my fingers and plugged it in, but nothing new showed up in the activity monitor. I tried monome sum and no devices were showing up to connect with. :cry:

Is there a monome sum uninstaller? maybe i could play around with the order that i install the two. I know that on my Mac Pro I installed the serialosc 1.4 first, and then I installed the monome sum and everything works fine on that computer.

as far as the monome model I have, the monome sum read it as monome40h1119. I bought it used but I believe he said it was from a kit. It is black and has blue LEDs. he said its either a “40h kit – 2007-2010 8×8, DIY soldered kit” or “monome kit aka mk – 2010 modular grid kit”.
however, to help troubleshoot this issue, I bought another monome which is white and half as thick. The buttons are less thick and more sturdy. The whole thing is encased in a white plastic and the rubber is kind of grippy. This one shows up as monome40h001. I may be able to find out more about them if you need.
My idea was that I could use both for troubleshooting until I can figure out the issue, then re-sell one of them. As you can see, I really want to get monome working on my laptop with the rest of my setup! :blush:

not sure if this matters but I figured Id mention,
when testing them again on the Mac Pro (my desktop computer which works fine with the monomes), I noticed that in the activity monitor all that displayed were two instances of “serialoscd” and no “detector”. When I plugged in a monome it added a third instance of “serialoscd” instead of reading as “device.” This is without changing anything since the last time I tested it (aside from restarted the computer at some point). I loaded monome sum and everything worked fine though.

i am tempted to try your older version of serialosc [ ] or one of the other versions on github [ ], but the installer may not work for these and I dont want to complicate things further.
let me know what the next steps I should take are.
and thank you so much for helping me along this process! i really appreciate it.

I had a lot of problems getting mine to be detected. All I did was install the most updated version of serial osc and it worked. I also don’t have a mac.

ack. on mac 10.8 you need to manually install the FTDI driver.

thank you tehn that is promising news! I saw that mentioned on the site but assumed 10.8 was new enough. I will try that when I get home!

just quickly installed it on my lunchbreak. YES it connects now!
thanks so much!
while I have you here, can you point me in the right direction for using monome with ableton Live 9?

theres a million different threads online saying different things over the years and a lot of the links to official monome resources are broken. I’m wondering where you would suggest I look for the most current documentation on using the monome with live.

some people say you need LiveOSC or “Pages” or “zeroconf” and its not really clear where to start.

specifically I’m interested in MLR style devices in ableton so I have downloaded “re:mix” and “clip chopper” devices that I want to experiment with once Ive got everything set up.
Thanks again!