Monome diy service

Hi, I own a walnut 64h monome 2009 model, and I decided to clean its contacts. I did it with isopropyl alcohol and care, but in the end I somewere messed up and as a result I got jerky LEDs flashing. I concluded at the time that some alcohol probably caused a short somewhere and I burned the led driver max7221. I Ordered an a new chip and I easily exchanged it with my soldering skills but I still have the same jerky LEDs flashing. Now I believe its either the ribbon got cracked or the atmel micro-controller is miss-behaving. Could I order somewhere the programmed chip? Anyone got the same problem?

you’ll have to post a video of “jerky” LEDs for debugging assistance. pre-programmed atmel chips are certainly not available but i can send firmware files if needed.

if you’re getting key data in, i highly doubt the avr is the issue.

Yep the input shows fine on max patch, I’m getting 5v on the Vcc input of the MAX also. Is there anything else I should check? I m shorting all the ribbon’s pins and they are beeping fine with a simple multimeter.
I have a link with the video of the LEDs misbehaving

i am pretty sure your hardware is fine. since you got the correct startup pattern (power-on) that means the MAX chip is fine. it also means your firmware is fine. the fact that key presses are sent means your FTDI is fine.

this feels like a software problem. try reinstalling serialosc, and test with the max grid test patch.

What % alcohol did you use? A lot of people pick up whats in the drug store which is usually 60% which can cause rust and degradation from the non-alcolohol content. I use 90% in my restoration work.

Hey, thanks tehn, you were right, it was no hardware damage ( AIsynthesis my isopropyl alcohol is 99% pure). I had the opportunity to test it on 2 different macs with freshly installed serialosc and worked like a charm. My other system that it has those led hick-ups is a 10.13 High sierra 3.1 Mac Pro (dosdude1 install). Is there any chance that the system or any other driver is corrupting the serial communication? I tried to reinstall serialosc previously but I had no luck.