Monome 'dying' on patch switch? - Help/suggestions needed

Has anyone run into this problem:

  1. Use monome with a patch in max/msp, it works fine.
  2. Close the patch.
  3. Start a new patch.

The monome responds to commands in the patch (for example, clicking /led/0), but becomes immune to button presses. Only restarting the computer seems to fix. Stopping Max itself does not work. Unplugging and plugging the monome does not work. This all worked fine last time I did this, so it’s a bit a frustration as I have a gig.

Running OS X 10.10.5

ETA: I have discovered the ‘workaround’ of quitting MAX entirely and restarting it each time, which although a pain, does not require me to restart the entire machine.

try replacing your serialosc.js with the attached file

it goes in

/Max 7/Contents/Resources/C74/packages/BEAP/patchers/

serialosc.js (1.8 KB)

clicking “none” will now refresh the dropdown

Thanks. Is there another location for the attached file? I don’t seem to be able to download it.

ETA: Tried on Chrome and Safari.

just pinged c74 to include the newest version in the next max update

Thanks! Ended up using the ‘quit/load’ workaround during the gig, and it worked fine. I’ll install this today, though.