Monome not detected in MAX

Monome is not detected in MAX apps but it runs fine in M4L any reason why this would be. I tried reinstalling the monome device with the installer from github, but nothing has changed

Are you using Max 7? If so you’ll need to re-download the updated versions of the apps. The “serialosc.maxpat” is not included in Max 7 but in order for patches to run correctly, they needed to be updated slightly.

Check here: http://github.com/monome-community

im on max 6 havent updated

I cant even connect to the monome test

Hey Galapagoose i got it working in Max 6.0.8 but it wasnt working in max 6.1.9.

How can i fix this as id perfer to use the later version

When you say you “can’t connect”, can you see the box where your device should appear? If the device isn’t populated in the dropdown it’s something quite mysterious, but if the space is blank then it sounds like serialosc.maxpat isn’t loaded correctly, or the wrong version is being used.

Can you post a screenshot of the max window (command + M) ?

the first image is with max 6.0.8

this image is with max 6.1.9

I also mysteriously had not a row die but was faded and would not illuminate at its brightest. if my 128 was laying horizontal it was the second half only 8 buttons horizontal were dim…i fixed it just by mashing on the buttons kinda wierd

Add screenshots of your max window (cmd+M)

looks like you don’t have the zeroconf externals installed.

Even more importantly, looks like you’re using a (very) old version of serialosc.maxpat.

Grab the latest versions from here: https://github.com/monome/serialosc.maxpat
Install by putting the files in your Max 6.1 folder (anywhere, but /patches is the ‘normal’ place)
Download the updated versions of the apps from https://github.com/monome-community

However, if you don’t want to use new any new apps, and instead just get things back to ‘normal’, you’ll need to install those ‘zeroconf’ files in Max 6.1 – The good news here is that you obviously already have the files in your Max 6.0 folder, so just open /Cycling '74/max-externals in two finder finders and go to the very bottom of 6.0 to find the 2 files that you can copy to the 6.1 folder.

Thank you guys for help that solved it

THE MYSTERY
I have been having troubles with monome not connecting to MAX for a long time.
I have 2 laptops: the issues are always with the MacBook Pro: running 10.9.5

  • I am able to use my monome with a MacBook Air: also running 10.9.5

please see attached screen captures of monome-sum and MAX 7 windows.

PLEASE HELP