n.Kria 0.23: native norns Kria


native norns Kria

monome ansible kria tutorial, sequencer for eurorack modular synth - YouTube (thanks, @Puscha !)

This is a full rewrite of Kria, native to norns.

It has screen implementation: I wrote hints and context on the screen whenever possible to aid in learning this somewhat oblique sequencer. For instance, any time you interact with controls, information about that input - and what you’ve changed - will appear in the post window.

All important information is embededded in the params system. This means: everything is a mod destination. Everything can be midi mapped. Everything is stored with your psets.

Thanks to @sixolet 's fantastic nb submodule, n.Kria supports outputs over midi, crow voltage, and ii.

please let me know if you find any bugs, or undocumented differences between n.Kria and ansible kria. I want to know!

why? what?

longish personal reasons for writing this script

I used Kria extensively when I owned Ansible hardware - when patched through Teletype it was my favorite tonal sequencer.

When I sold my modular, I planned on switching to kria_midi. This is an extremely faithful port of ansible Kria - in fact, it’s almost the exact same code, just directly ported to Lua’s syntax. in @junklight’s own words,

“This is a very straight port of Kria from Ansible to Norns. It’s basically a direct translation of the original source into Lua.”

There are more Kria offshoots out there (@yams Colorwheel and @alanza faeng come to mind) but no more direct ports that I’m aware of.

So, I was left with a 3 options.

  • Ansible hardware (out of production indefinitely and very expensive)
  • Colorwheel or Faeng (fantastic, but both felt like learning new instruments, where I wanted to keep playing the one I know)
  • kria_midi (faithful and fit the muscle memory, but I could never figure out how to expand it and i found saving extremely limited.)

So naturally I took the 4th, much less convenient option and completely rewrote Kria in Lua from the interface backwards, adhering as faithfully as possible to the Ansible Kria experience, but structuring it in a way that made sense to my amateur programming brain, and that left plenty of room for lots of modulation, as well as future extensibility!


  • grid


for more information on n.b. and its inputs/outputs, check here

docs now on github



;install https://github.com/zjb-s/n.kria
or use maiden, though some people seem to be having problems getting the submodule to load. so if you run into trouble with the maiden install, try the above command instead.


  • @tehn for the original design of Kria, and for his kindness to me every time we’ve spoken
  • @sixolet for co-writing n.kria, tons of help, and for our friendship


  • clear or fill retrigs, as seen in ansible kria manual (let me know if anyone wants this, I never use it.)
  • send midi start/stop

Known bugs

  • script can fail when installed from maiden instead of ;install command
  • when changing patterns, rarely the first step is skipped (I haven’t been able to repro this recently, let me know if you can?)

Happy release day! I want to add two things:

  • crow outs are coming as I code up the relevant nb mods, and will be available a la carte as separate mods
  • for now I recommend emplaitress to get sound directly out your Norns.

Yes! Emplaitress is the way we’ve been testing this script the whole time, definitely check it out.


Well done! Installing as soon as I get a moment.


Such a gift! Thanks so much! EDIT: Been playing this for a couple hours and WOW! So fun, and sounds great with emplaitress mod. An awesome way of learning Kria as well. Amazing @zbs @sixolet

1 Like

upded to 1.12 to fix something i’m 100% literally no one has noticed yet

e: The classic thing happened where I found a couple bugs right after release. Expect another patch imminently :slight_smile:

e2: Okay, pushed it, should be OK. Let me know if anything comes up though.


an absolute triumph. well done.


the demo is so serene & lovely!
also was touched by your description of what motivated you to return to kria and rewrite it…



I can’t say thank you enough! I, like you have been on a similar journey and parted with my modular, leaving me without Ansible. To be able to use the same muscle memory with your rewrite and features with visual feedback from Norns is invaluable. Thank You!

@sixolet thanks for continuing to push the envelope with your mods. I have followed the instructions for emplaitress and have it installed as a mods, restarted twice and am getting sound from n.kria when assigning it to the track outputs, but have no idea how to change Plaits models or parameters?

I though I’d do this in the Mods page, but when I click on emplaitress in mods it doesn’t do anything? Unlike say matrix mod? Am I missing something? Should I be looking elsewhere for the voice parameters for emplaitress?

Edit: Found them! If anyone else is wondering there are script’s params under “Voice Controls”.


Yeah. Choosing an output for a voice will un hide a parameter group that controls it. The reason these are params instead of in the mod menu is twofold:

  • The param library is easy to use and familiar
  • I want them to be available to modulate with matrix.

Thanks, Edgar, I’m so glady you’re enjoying it and that you’re learning well :blush:

And @mattallison, thank you for your kind words as well!

1 Like

Quick one for either @zbs or @sixolet do I need a seperate nb library/add on to access Midi Out? Can’t seem to allocate midi as an output for tracks 1-4 from within Params? Output shows “none” even though I have a midi device (Digitone) attached and can see it in the Devices menu.

I think you need to have the digitone attached before you launch n.kria at the moment, but that’s not ideal and we’re working on it. Let us know if that doesn’t work.

e: just pushed 0.14 which should allow you to change the root note, i had to blow some compressed air in the code fans

Hmm, still no luck this end @zbs, I have restarted the script, also rebooted and no luck. I know the MIDI device is working as I loaded up Awake and selected the Digitone (Device 1/Channel 1) and it’s working ace. Any thoughts?

This is so cool! Only issue I’m having is that now I want another grid to leave plugged into ansible :joy:

And Multipass!?!? This mod is so cool, finding new ways to use familiar engines with the simple addition of the aux blend control.

1 Like

Would you mind checking out this branch? GitHub - zjb-s/n.kria at multivoice

See if it solves your problem, as long as the synth is connected before you start the script?

You will have to do a git submodule update in ssh after checking it out.

I think I fixed some midi problems in the combo of n.kria and nb. It also supports more than one voice of midi out per device.

If it works I’ll merge the branch to nb and then merge the branch to n.kria.


I’m a little stuck on how to install the branch, if I try using maiden/matron I get an error sharing it already exists. I’ve uninstalled the original and tried reinstalling from your branch and it shared.

;install GitHub - zjb-s/n.kria at multivoice


install failed: repository not found

I’m assuming once I manage to get it installed I’ll be then using SSH to login into the Norns and from the terminal line run the git submodule update?

Try the following:

  • re-install the script normally
  • log in to Norns over ssh, and cd to the n.kria directory
  • git fetch should give you all the remote branch options. Verify with git branch -v -a
  • git switch multivoice should switch to the new branch
  • git submodule update should update nb

That said this kind of stuff often leaves me swearing at git for a moment. I hope this procedure sorts you.

i’m having the same issues as @mattallison.

i went through the git rigamarole. git switch wasn’t recognized, but i was able to replace it with git checkout -b multibranch’ which gave me a message of “Switched to a new branch 'multibranch.”

however, after restarting, the OUTPUT param, still shows as “none”.

I’m curious if the script requires the latest norns update. i (and matt) are both on fates which doesn’t yet have the latest image available.


Thanks for checking @jaseknighter and yes, I didn’t think that it might be related to the latest image and any changes in the updates, which may be our problem.