*nested* + less concepts: album + cellular automata sequencer (norns, Mac)


#122

this is fantastic Dan, i’ve been on it today. Love that you tied it to the Passersby synth also, which is perfect for this. Really like the snapshots, perfect for improv and also preplanned chord progressions. I’ve been playing on the computer version before this and the added monome layout makes it a lot more playable.

I had a small issue with Midi out - I couldn’t get the midi working very well with my setup, but i don’t have a CVpal, i am using Ansible and Sevillasoft dongle. I could get 2 sets of CV but no gates - they just all lit up gates high.

Some ideas.
+1 re rdfm above about individual snapshot clearing + the ability to save all the snapshots as a preset also. The only thing i miss from this Norns version is the “all” button as i use that to create full baselines whilst playing with 1 layer of bit selection.

  • Now i see it working, and laid out on a monome grid, i think pattern recorders like MLR / Glut would work great on this - on the 2 bit selections, but i think it would work best, on the low scale / high scale reference area. Just with 2 notes playing from the bit area and manually messing in the low/high scale area it becomes a really creative space to improvise. Or even pattern recorders on the snapshots (locking different low/high ranges) to create chord sequences.

Even as it is now, its a ridiculously inspiring musical tool, that makes you want to make improvised and melodic music. I love it.


#123

Tried it last night - this is wonderful, thanks for porting it to norns! And @markeats’s Passersby sounds so good! Will try MIDI with the OP-1 today.


#124

ahhhhh, right right right, cuz there’s no m.note_off messages! I completely missed that, I’m so sorry!

@sbaio + @mlogger, lmk if this works?:
edit: fixed in RC


#125

Haven’t tried the old version with MIDI, but the new version works great with the OP-1!


#126

with the new version, midi works great with Ansible and the Sevillasoft converter

**edit correction update - i had Ansible in poly mode which rotates the outputs like a shift register through 4 channels, and that works fine.

However when i switch to Mode 3 “Mult” on Ansible - Pitch/gate outputs to midi 1, 2 3 and 4 pairs i get gate high and lit on Channel 2 and Channel 1 gate out is fine.The CV outputs behave normal from Ch 1 and 2. I have the vox setting to Midi Ch 1 and Ch 2 on Norns. When i change Vox 2 to Ch 3, i get gate high (steady light) on Ch3 Ansible and CV OK. It could be the dongle i use and not Less Concepts.


#127

Ah that’s why I was only getting new notes at the beginning of each pattern and then infinitely sustaining tones


#128

I think it’s the note-off messages defaulting to channel 1 only.

this should fix, confirm plz? (also, thank you for testing!!): FIXED IN RC

this might also happen based on rule/seed activity – can you confirm working setup with the version posted above and rule: 30, seed: 36, bit 1: 2, bit 2: 5 ?


#129

the triggers are triggering from Ch 1 and Ch2 fine now with the last fix, but what is weird is they trigger at a slower rate / out of sync with whats happening on the grid. Almost like its combining / overlapping gates / something is sustaining. So you will expect say 4 trigger outs from the grid but you only get 1 of them triggering from midi out side. The best way to hear the difference is to watch/hear the triggers from the internal synth playing then switch over to the midi side and it seems to be missing a lot of trigger/gates outs.


#130

super helpful, thank you! i think i have it nailed down now, will post new beta tomorrow morning!

edit: also, @mlogger, thank u for sharing your explorations of the script. i’ve really enjoyed watching how you use it and have been digging the external synth pairings!


#131

edit: fixed in RC

I believe this fixes the timing issue – it reverts when the note_off messages are being sent back to when timing was accurate and also includes the channel-specific note_off messages. I also got rid of the CVpal hack clock, which was causing WEIRD issues. @mlogger, you’re our only hope :slight_smile:


#132

:slight_smile: you’ve only just gone and made it work! All good here - thank you!


#133

oh excellent! and to confirm: there’s no cvpal params item in the working version you have loaded? just wanna make double sure before submitting :pray:


#134

There’s no cvpal param item


#135

oooowoowwowowoo! we are good to go, dang! thank you so much for your help, jason!


#136

Thankyou for an awesome sequencer!


#137

what an incredibly fun sequencer @Dan_Derks!! here’s what I came up with after playing around for a little bit.

I noticed one potential bug. What I think the bottom row is for is basically adding saved states for particular bits/octaves/low/high values, so you can recall them, but it seems like you can only ever access whatever the first set of parameters are for the presets you have saved.


#138

fantastic to see it in the wild! thank you so much for sharing this lovely clip.

i think i follow. do you mean that if you change something about a snapshot x, switch to snapshot y and then go back to snapshot x, snapshot x will always be the first configuration it was saved as? in short, no overwrite?

if so, this is by design, to keep things teetering on the edge of structure and improvisation. if i’m misunderstanding, then i’d love to hear more about what you mean! :slight_smile:


#139

It’s more like snapshot x y z buttons all take you to snapshot x


#140

Ah so I just reset Norns and everything was working as expected, up until I pressed the reset button next to the bottom right new snapshot button. It seems after that point the behavior is a bit strange (in addition to what I describe above it doesn’t seem like the leds of current snap shots clear out always, I haven’t been able to really isolate and pinpoint a good reproduction scenario, but basically clicking reset and buttons in the bottom row that aren’t currently snap shots seem to get me there.


#141

EDIT: fixed in RC

confirmed this behavior:

  • load less concepts with grid
  • choose rule and seed and all that, then start the sequence
  • add it as a snapshot with lower right button
  • bottom left button lights up
  • press any of the 7 empty snapshots to the right and the sequence will stop
  • pressing the ‘clear snapshot’ button doesn’t clear LEDs (no grid or norns hardware interaction works at this point because basically everything is hung by calling a nil snapshot, i suspect)
  • in the hung state, pressing established snapshots will not switch snapshots

to get out of this glitched state: hit the grid’s ‘randomize all’ button (third row, far right) and eveything will return to normal (redrawing grid and screen, restarting the sequence).

there’s also an exit opportunity earlier! if you hit a nil snapshot and stop the sequencer, simply hit one of the established snapshots and you’ll get back to functioning (think of it as a “feature”: a pause button!). the point of no return seems to be hitting the ‘clear snapshot’ button after a nil snapshot is loaded.

note: if no snapshots have been made, hitting the nil snapshots will not affect anything. it’s only once a snapshot has been made that nil snapshot loading will junk things up.

@jlmitch5, thank you for surfacing this behavior and please confirm the above replication steps and workarounds?