new grid can't connect (solved)

hello, today I got my new grid(finally, waiting for long time from China), and I connect new grid in anisble, but it can‘t work, just the white light flash from right to left, same situation with norns, I have old gird 128, It’s all fine,what shoud I do, update the ansible to 3.11 ?

thanks !

and the video link

If you haven’t updated, you should definitely do that. IIRC, big part of the Ansible update was to support new grid. Same thing with one of the Norns updates around the same time.

1 Like

I don’t have Ansible, so this is for Norns: First, update your Norns to the latest version. Second, see if your Norns recognises your Grid. In SYSTEM > Grid it should show up. Lastly, you need to run a script which uses it.

Afaik, yes, new grid requires an update to your ansible firmware to be properly recognized.

I am having a very similar issue. norns is on the latest firmware.

When I plug it in I see some lights turn on for a moment, but no scripts I’ve tried with it work.

When I went to manually select the grid from the devices drop-down in settings, it would display some data based on the script in use, but attempting to interact with the grid didn’t have any results.

Was planning to debug a little more later this afternoon, but thought I’d provide this data point as well.

Edit to clarify that this is a new grid received yesterday.

Same situation here with new grid that arrived yesterday, hopefully I recollect the steps correctly :

  • norns with older firmware and old grid running “awake” script just fine
  • connected new grid, LEDs briefly flash, but no display of “awake” script
  • norns > system > devices > grid showed both new and old grid
  • disconnected new grid
  • updated norns
  • in norns > system > devices > grid I set both grid entries to “none”
  • reconnected new grid = success, awake script works!
2 Likes

beyond updating, yes! this is perf advice for norns folks.

most (/ nearly all) norns scripts connect to the grid listed in slot 1 of SYSTEM > DEVICES > GRID. the only time you’d run into a conflict is when replacing your primary grid with a new one (not as frequent an occurrence as MIDI devices), which would populate in slot 2 since slot 1 is occupied by the previously connected grid. clearing the grid device slots and reconnecting your new grid will allow it to auto-populate to slot 1 (you can also enter the device selector by press k3 on a slot, same as MIDI devices) and you should be groovy from there!

as to the OP, updating ansible should clear things up :slight_smile: modular firmware updates | monome/docs

3 Likes

This worked for me; thanks!

thanks! problem solved after norns and ansible update!

1 Like

thanks a lot for reply!

1 Like