No WIFI or Hotspot

So here’s the pickle.
I have a standard Norns running 210927 firmware. Finally got some time to try and and flash/update, but I wanted to save all my scripts before hand. Plan was to just use the Norns file manager to download all the files, but I can’t connect to wifi, and I can’t make a new connection. I can serial into it, or connect a usb to ether adapter for internet connection, but I have no clue what the terminal commands would be to copy all the files to my raspi 3b+.
Could anyone help me out here? Im kind of at a loss and digging through all the mountains of info is stressing me out and giving me anxiety. It’s like an info overload, if that makes sense.
Any help is appreciated!

if you can ssh into it then you can use scp to copy files/directories from the norns to your computer.
If i’m not mistaken, everything created by the end user on norns resides in the /home/we/dust directory.
So to back up this directory, you just have to:

  • open a terminal on your laptop/desktop
  • create a directory to store the backup, eg mkdir backup_norns
  • go into that directory: cd backup_norns
  • use this command scp -r we@norns.local:/home/we/dust .
    This will recursively copy the dust dir from remote norns to the current folder (represented by the trailing point at the end of the command).
3 Likes

I’ll give that a shot first thing tomorrow. Thank you so much for the help!

So! Gave this a shot. Started okay, but the connection keeps timing out. Think I’ll just have to cut my losses, wipe the whole thing, update it, and manually reinstall all my mods, scripts and engines. :man_shrugging:

Well, tried flashing the latest firmware, 4 different kinds of WiFi dongles, 3 separate wifi connection points, and still no luck. Trying the nmtui method, thought I had all the necessary info filled out. But it still won’t let me select okay after. So I’m officially at a loss. Would anyone be able to provide some detailed instructions on the nmtui method?

sorry to hear about the trouble!

  • just to confirm, you’re connecting your unit to your computer via serial?
  • if so, have you removed your stored networks via Edit a connection?
  • and if you try to Activate a connection, do you see a list of networks around you? eg.
  • if so, can you select the network you want to connect to and if you hit ENTER does it ask for and accept the password?
  • after acceptance, it should show connected via the asterisk next to the network name:
  • if this is all unsuccessful with a known working dongle (the one which allows hotspot is a good indicator of compatibility / working status), you might need to change your country code – in Terminal, execute sudo raspi-config and enter Localisation Options to set your country

hope this helps! happy to assist further with more info, just let us know :slight_smile:

1 Like

Tried connecting via serial last night, but had no real luck. Giving it another shot right now. Made it to this part
then, type: screen /dev/ttyUSB0
and then typed 115200 right after. But I got a notice that there was no command for that or something. I’m taking a smoke break right now, so I’ll have to double check. Should I type screen /dev/ttyUSB0 then hit enter and type 115200? Or should it all be one line then enter?
When I go under wifi on the Norns it picks up the wifi signals around me. It’s just not saving my pass for them for some reason.

for sure, happy to help! if your wifi isn’t activating, the nmtui steps are best done via serial, so let’s get it sorted!

after this step, you have to press TAB to autocomplete your serial number, then enter 115200. you’ll end up with something like screen /dev/tty.usbserial-A9053JEX 115200 all on one line, then press ENTER.

then, from the docs:

If you see a blank screen, press ENTER.
You’ll be asked for login credentials. Login is the same as SSH above.

if you haven’t changed those credentials, it’s the default username (we) and password (sleep).

let us know how it goes!

1 Like

I think I’ll have to switch this all over to my mac later when my boys are napping. I’ve been trying on my pi, just because it’s setup in my living room. So it’s accessible while I’m watching my two sons (1yo & 4m). Anyways, for one reason or another the tab key isn’t working. But here’s hoping I can get it resolved later tonight! Thanks for the help! I’m still new to command line stuff, so every little step is a big step for me.

1 Like

omg, so so sweet – those are wonderful ages. my sister’s kids are roughly the same distance. a super special zone :sparkles:

so glad to be a part of the journey! let us know how it goes :slight_smile:

Alrighty. So I tried on my Mac, but the TAB key still didn’t do anything for me. Idk what’s goin on. I used 2 different keyboards. :disappointed:
On my Mac it says Cannot exec /dev/tty.usb : no such file or directory.
I’m using the same cable I used to flash it, so I know the cable will tx/rx data.

FINALLY got it! I didn’t realize ‘screen’ was something that needed apt-get install.

When I looked in maiden though, I got this error mentioning an Unterminated string. Think it’s something to be concerned with?

1 Like

oh wildscreen should be installed by default on most distros, didn’t even occur to me to suggest apt-get install screen, thank you for the diligence and excellent thinking!

is The Bomboy's your wifi network name? if so, this is very silly, but i’m wondering if that name is actually to blame for the previous trouble – it looks like it’s entered with a prime, rather than an apostrophe, which i think would demarcate to linux that it’s the start of a quoted string which has no end.

for reference, here’s an example of how an apostrophe-based network would print to the console:
image
which has just a little more tilt than the prime/hash:
image

either way, the presence of that network name will print the syntax error, because the system assumes it’s the start of a quoted string and it alerts when there’s no termination – if you don’t need that network to be remembered, you can remove it via the WIFI menu on norns :slight_smile:

2 Likes

Bomboy our family’s last name. :sweat_smile:
But I took that little ' out of our routers wifi name and it’s working like a charm now!

1 Like

Apologies for the trouble - we actually have a bug filed for this very issue that hasn’t been resolved yet.

1 Like

Yeah, not long after I thought I had fixed the issue, my wifi points were saved but no longer showing up when trying to select one.
No new connections are coming up again either. :man_shrugging:
Anything I can do to help further test?

How far are you from the wifi base station? If you are using the little wifi nub which ships with the standard norns the range on those has turned out to be limited when compared against a laptop or phone.

Other forum members have reported compatibility problems with certain newer wifi mesh networks.

At first, about 15-20 ft. Then tried right next to it. I’ve also tried three different brands of wifi dongles. Plugged ethernet cable to router, then network to usb adaptor, then adaptor into Norns gets internet connection.
I’ll try serial connection again with my raspi tonight and see if nmtui provides a list of available wifi options.

Alright, so I managed to get Norns connected to my wifi through serial but couldn’t access maiden. The site would load but not connect. After putting Norns to sleep then booting back up, my WiFi connection was deleted, and it won’t even let me start a hotspot.
@dan_derks do you have any ideas also?

I’m wondering if the filesystem is 100% full on your device - that might explain the rather erratic behavior in addition to WiFi connection configurations being deleted after getting setup.

If you can connect to your device over serial and run the command df -hl and paste the output here. You should get something like this:

Filesystem      Size  Used Avail Use% Mounted on
/dev/root        29G  7.6G   20G  28% /
devtmpfs        486M     0  486M   0% /dev
tmpfs           490M   83M  407M  17% /dev/shm
tmpfs           490M   19M  471M   4% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           490M     0  490M   0% /sys/fs/cgroup
/dev/mmcblk0p1   43M   22M   22M  51% /boot
tmpfs            98M     0   98M   0% /run/user/1000

The entry we care most about is that first one /dev/root if the Use% column reads 100% (or something close to that) then we should clear out some space first by running the following commands:

  • rm -rf /home/we/update/*
  • sudo rm -rf /var/log/daemon.log* /var/log/messages* /var/log/syslog*
  • sudo apt-get clean

Then after that run df -hl to see if that generated some free space.

If you were out of space and this did free up some space I would recommend rebooting (sleeping) the device then going back and trying to setup WiFi.