No WIFI or Hotspot

I’ll still give it a shot, but I’m not sure that’s it. I’m running a standard Norns with the CM3+ module. It was deleting my wifi connections after flashing to the newest update and expanding the memory.

Just wanted to give an update, I’ve had to flash, and setup my norns with the newest update probably 5-6 times, and kept losing wifi or having my connection deleted. Full transparency, I’m worn out over it all. I just wanted to make music with my Norns again. So I rolled it back to the last OS before a flash was necessary (200106). Haven’t had any WiFi or connectivity issues since. Whatever’s goin on, I’m guessing it has something to do with that update. :man_shrugging:

My only other thought at the moment is power, though the standard norns devices have shown to be more resilient than the shields when under voltage occurs due to the battery. Out of curiosity do you typically have additional USB devices plugged in when you power up your device? If so what do you have plugged in?

I definitely understand the desire to just get back to a working state - the hassle associated with flashing a new image is fully recognized. I am perplexed by the behavior you are seeing with the new image.

One last question, do you know which security protocol you WiFi network is using? Typically WEP, WPA, or WPA2.

The only thing I usually ever have connected while powering on is a wifi dongle, plugged into the USB port closest to the power socket. I use my grid quite a bit as well, generally I wait until Norns has booted though.
I don’t think it’d be power either. But that’s only because I’m using the supply that came with it.
WiFi is WPA2-PSK.
I’ll try one last time flashing with the image just after 200106 and update through the menu from there.
:crossed_fingers::crossed_fingers:

Flashed to 210607 same issue. Stopped showing any wifi connections. Ran df -hl and this is what I got.

Still no wifi connections showing. Tried plugging grid in, and it lights up/operates without any issue. Connecting Norns to router with usb to Ethernet dongle provides internet connection.

(now to find some coffee)

I pulled out my “golden” norns which I use to validate bugs on released software - this device is a standard norns from the first factory run upgraded w/ a CM3+. I deleted all the WIFI networks, verified over a serial connection that everything was torn down then rebooted. I then proceeded to test with the oldest most temperamental WIFI nub I had (it is nearly identical to the stock nub which shipped with production versions).

  1. boot the device with nub inserted
  2. navigate to SYSTEM > WIFI
  3. wait for “scanning…” to complete (~2-3 seconds)
  4. choose CONNECT, verify that none is the only option since we haven’t configured any connections
  5. choose ADD, see the list of available networks, selected my main one
  6. entered my password
  7. selected OK
  8. waited ~2 seconds and the network details came up

I repeated this process with the WIFI nub in different ports, inserted before powering on, and inserted after boot. …then repeated the process with the only other USB wifi nub I have.

One thing I was reminded of is that the current WIFI menu has no way to manually enter the name of the WIFI network to connect to (i.e. its SSID). On option that most/all WIFI base stations have is the ability to turn off SSID broadcasting which prevents one from browsing for networks by name. If SSID broadcasting is turned off it wont be possible to configure the network in the norns SYSTEM menu and I suspect the same could be true for the add connection wizard in nmtui.

So I should log into my router and check if SSID is off?
I’ll try, it’s just odd to me that it will power and connect without issue on 200106 but not on updates after that. Do you know of any further steps I could take to stripping all software and basically start from complete scratch? From my understanding, that’s what flashing it does. But thought I’d ask.

I can sort of add to that but not exactly the same issue. I have a card with the older image and the Norns hotspot works great but I’m using the new up to date image and the Norns hotspot doesn’t work at all. Wi-Fi works on both but hotspot only on older image. Don’t know if that helps any but I thought I’d throw that info out there too.

I don’t know what it would be called on any given router but any setting which turns off SSID broadcast or “hides” the network could make it difficult to connect.

I can’t immediately come up with any reason why the old image would work but the new image will not. When trying to recreate the problem I was looking at the wifi handling code and I noted that it has barely changed in four years. If there was a significant behavioral change in NetworkManger (the linux component the wifi menu and nmtui manipulate) in the latest image I would have expected that to come up in testing. I not saying there that a bug is impossible, simply that I can’t recreate the problem despite several attempts to do so.

I feel your pain, not having an explanation for the behavior gives me little satisfaction.

Another random shot in the dark. Some WiFi routers allow you to block connections unless the MAC address (hardware address of the network card) has been added to an allow list - is there any chance there is something like that enabled?

I just tried to recreate this and I can’t. I tested two wifi nubs on the latest image, enabled hotspot, and then successfully connected both a fully patched Windows 10 laptop and a M1 MacBook Pro with the latest macOS Monterey installed. If it is only working on the old image I would try deleting the old wifi connection profile on your computer/laptop and try again with the new image.

1 Like

So after 6 different wifi dongles, serial connecting over Mac/linux, several ssh, ether to USB adapter, countless flashing then downgrading/updating.
I FINALLY got it! Tested multiple times with 5 different wifi connections. Picked them up and connected each time.
Idk why this seemed to work. For now, I’m not going to question it and just take the :trophy: W :trophy:
Put Norns in disk
Erased formatted to Fat32 with pi’s imager
Then formatted with 220306
Updating from the menu ran into a bit of a snag, and had to connect with Ethernet adapter to get the update.
It still cuts out if I try to load too many scripts. But as long as I can keep my excitement in check, it should be good!