Norns 2.0.0

norns
#103

Mmm can someone explain full image to me?

I meant in context of the above question. Pi newbie here - is not the 2.0 download an ‘image’ ?

#104

I’m having trouble adding my network from the Wifi menu. I can see it in the list and enter a password but hitting “OK” just takes me back to the Wifi menu with no change. Hotspot works fine but is a drag.

I took a look at wifi.lua and saw that the script puts the network name in single quotes. My network name does have a single quote in it so I tried changing the name to no avail. Also, trying to add any other network detected results in the same non-result.

Apologies if this has been addressed upthread, I searched but didn’t find anything.

#105

playing with any arc-based app will eventually light up some LEDs on all rings (with some faint flickering)

matron spits a very long list of
libmonome: error in write: Input/output error

#106

I too have seen this once or twice. an unplug/re-plug of the arc restored normal use.

#107

Do you know how the serial connection works?
If so you can login via serial and use nmtui to connect, if it’s a problem with the quote that’ll probably work.

1 Like
#108

You get this with Step ? Reason I’m asking is that this script does not refresh on every incoming arc event but given a predefined rate (60fps)

#109

I’ve gotten this with mangl, which also uses a predefined refresh rate for arc drawing. (haven’t tried step yet.)

#110

I’ve seen with in mangl and angl

I’ve also gotten dancing LEDs on my arc upon bootup, instead of the little wake-up animation.

for the record, I saw this kind of behavior on occasion when using this arc connected to a macbook, so it might not be (solely) a norns issue

#111

This did the trick, thanks very much!

#112

i don’t believe it is a norns issue - we are thinly wrapping libmonome and then of course there is the arc firmware itself. but if we need to implement workarounds in norns (like throttling update / event rates) we can do that.

2 Likes
#113

Right. Step uses an even lower refresh rate than Mangl so that perhaps rules out refresh rate as an issue.

1 Like
#114

what is best practice for copying/removing tapes from norns?

i recorded two brief tests yesterday (< 1m each) but cyberduck shows 45min download time for them

seems crazy and i’m probably missing something here

#115

…had similar issues on 1, much better now but still quite slow (filezilla)

#116

FWIW - I get these errors when the data buffer fills up because the grid/arc refresh rate is too fast.

In the case of my DIY grid and DIY arc - this is about 30 frame per second (fps). Anything faster will throw libmonome errors (with certain scripts). Real Grids/Arcs seem to do ok up to 40/60 fps from what I understand.

However, step is checking to see if the grid is dirty before refreshing, so I think that means its not actually calling grid:refresh() every 1/60th of a second, right?

EDIT - for example - Glut (line 287) will throw these errors for me at 1/40, but not at 1/30. Crank that number up (down?) and you can probably reproduce the error.

1 Like
#117

Use the hotspot. It’s much faster in my experience.

1 Like
#118

I just stared at the update filename for 15 mins before realizing that you have to selected it with button 3 to start updating. :sweat_smile:

I would love a UI for dummies or people that don’t use norns daily. Like, the docs show the ‘pages’ levels/tape/home/params, but the ui on norns is just blank. Its a trap I fall into consistently throughout the norns interface. blabla I’m bad at this! :smiley:

Ok back to it!

edit:
I see 2.0 does have some tabs for the pages in the UI :smiling_face_with_three_hearts:

edit2:
all working, so cool!

1 Like
#119

If hotspot is much faster than using a normal WIFI connection then that most likely indicates signal strength issues since I’d assume that when using hotspot mode norns and one’s computer are in close proximity.

If one is pushing large amounts of data back and forth other options include:

  • if comfortable using ssh and the command line, using ssh to jump onto norns then copy the file to a usb stick
  • use a wired USB-to-gigabit ethernet adapter (this is what I normally use because I have an ethernet switch under my desk)
3 Likes
split this topic #120

3 posts were merged into an existing topic: Norns: scripting

#123

@karst e-mail info@monome.org to make sure your arc is ok. there were issues with the first short batch of aluminum arcs a few years ago.

1 Like
#124

I’m happy about the addition of a library category, but is there a standard for where documents should live on norns itself? Having a utility to add docs (images, and text files) to the documents directory when a script repository is cloned might be useful if scripts are intended to be ala carte in 2.0. I’ll probably just write a few lines to move the files directly on the first run of my scripts.