Norns 2.0.0

Connect Norns to the internet.
Note your Norns ip address.
On your computer, I assume it’s a mac, open a terminal.
Type ssh we@(your norns ip address)
The password will be sleep.
You should now be connected to Norns!
run sudo raspi-config etc…

Hope this helps!

5 Likes

hi, thanks but @Justmat helped me with the info that I need to ssh…

All running now… Thanks a lot!
:partying_face:

2 Likes

Since the dust repo is deprecated - will the github dust repo be updated to the current 2.0 dust structure?

I did a github issue on this, but I’m not sure what the general plan was for that repo now.

1 Like

the dust repo will likely be deleted once all scripts are claimed and moved.

there is no need for a new version. see the folder structure at the top of the reference doc: https://monome.org/docs/norns/script-reference/

7 posts were merged into an existing topic: Norns: CM3+ installation

Haven was really simple, just required a oneliner fix for reverb input level. FYI, I posted an updated version as a gist here: https://gist.github.com/antonhornquist/83f074dfa5b27478895cc9a776cc7518

(hope that’s okay)

thanks for this!
with the help of @simonvanderveldt, I created a separate repository that also includes the engine. Details here: Haven

I’d be happy if someone could check if it works as I do not own a norns.

Question: is it ok to install the whole folder or, as the engine is already included in /we, it will mess up supercollider?

It will mess up SC :wink: so don’t install it yet (or if you do remove the lua file and engine from we as well).

I’ll check the script later today and I’ll make a PR for we to remove the engine and lua file if it’s working.

1 Like

AFAICS there is no lua file in we but I created a PR that’ll remove the engine.

Yeah, you’re right, only the engine lives in we it seems :slight_smile:

@zebra crowns is something else! im having too much fun with it

heh, glad you found it interesting. i made it super fast for a show last week… would like to clean / expand / tighten up but ofc. this kind of thing is forever backburnered… until the day of the next show

1 Like

Googles «zebra crowns norns»

Dissapointed with results :wink:

3 Likes

Hahah, I’ve even tried github catfact crowns. Same disappointment. :smirk_cat:

2 Likes

@AlessandroBonino the app can be found here:

7 Likes

Thanks a lot @glia!
:pray:

2 Likes

not sure what changed, but just wanted to say using norns.local has worked 100% of the time in placement of ip for everything. If anyone is curious (you have to be on the same wifi as norns):

  • access maiden at http://norns.local
  • ssh we@norns.local
  • for cyberduck: sftp norns.local (un/pw - we/sleep)
2 Likes

Welp, was setting up for an open mic and got the same infinite “loading…” on all scripts as mentioned above by @karst. Grabbed my laptop and gonna try a reset

I got that earlier today and resets did not help. I had to delete the last few library scripts I had added. Good luck

Thank you! I think it might have been haven (which is what I was using). I deleted it and then redownloaded it and started it from maiden—worked great!

2 Likes