Norns 2.0.0

norns
#284

this might be too late but fwiw, I was able to clean up all of these troubles on my machine with this:

(further reading:)

;restart returned a few errors that plainly stated where there were duplicate engines – after I deleted a few, I noticed that the remaining matron errors were due to scripts referencing engines that simply no longer existed in the places they were linked, so I did have to change the require line in a few scripts.

it’s possible that the scripts you’re trying to load require engines or other things that were (for whatever reason) in those folders – do you have any maiden or sc REPL output that you can share?

#285

it…did not occur to me to do this :upside_down_face:. since i had not thought of that, fyi @yobink i just pushed an update of traffic that ads some sound design parameters to the other two arc knobs, and also swaps out the broken commute mode to something that works. nothing big enough to warrant a new post

2 Likes
#286

until all of the engines are migrated to the authors’ personal repositories, you need to keep we/lib

just go download it again

#287

Thanks – okay looks like deleting things wasn’t the problem, it looks like I added Glut, not realizing I already had it installed by default. Would be cool to know which scripts in the Library/ part of the forum are part of the standard distribution.

The 3 scripts I’ve tried to load all haven’t worked (FM7, Haven, and Timber) – I’ll try and find more debugging info, but that might more appropriate for their respective threads in Library/

One quick note – it’s not clear to me (after reading the docs and SFTP guide) how to connect to Norns without using the hotspot, since Norns doesn’t display an IP address when connected to my Wifi.

#288

oh good good!

just a small heads up: these all include new engines, so a restart after install is required.

where to follow up might depend on the matron/sc REPL output. best vibes to you in the process!

weiiiiiiird. even when you hit K2 in the SELECT, SYSTEM, etc menu?

1 Like
#289

Didn’t realize that! Definitely good to know. Unfortunately didn’t fix the problem :frowning_face:

weiiiiiiird. even when you hit K2 in the SELECT , SYSTEM , etc menu?

Yes, although upon a closer look it seems like I’m stuck on STATUS: activating so perhaps it’s never actually connecting to my WiFi at all :thinking:

EDIT: Okay… so after seeing @tehn ’s comment here: FM7 (Norns)? I realized I needed to rename the folders & after checking the output in Matron the other problem was that I was installing them in the we/ folder, and they needed to be in the top level dust/code directory.

Thanks everyone!

2 Likes
#290

AH!
Thanks for clarifying all that!
I rely on everyone here to know more about this than I do!
That’s why I am crashing things and such.
:slight_smile:

I seriously need a “norns for dummies” thread in here somewhere.

I just want to make noiz and not have to fight with the noiz weapon to make the noiz.
:stuck_out_tongue:

1 Like
#291

@okyeron looks like github-created zip archives do not transfer the .git metadata as you mentioned.

I also think showing the hidden files still doesn’t transfer them in cyberduck

Here’s me dragging gemini from norns to my desktop. You can see that the .git forlder was present when in cyberduck, but not in my terminal when I ls -a on the desktop copy.


so a message for everyone, at least for the time being.

If you want to manage grabbing new script changes with git pull, make sure to git clone the repos while ssh’d into norns, instead of using sftp

1 Like
#292

I’m having trouble with WIFI as well. Hotspot works for now though. I was able to connect on 2.0 beta. Let me know if you find a solution!

#293

search on here for nmtui to fix

2 Likes
#294

Hi there, I’ve tried nmtui as well as fooling around with nmcli. I can see my network but i cannot connect. I was able to connect with nmtui in 2.0 beta.

edit: Oh my goodness. I got it to work. I tried nmtui again and kept removing and adding my network over and over. It was most likely timing out? Thanks @speakerdamage

1 Like
#295

I don’t have this problem with Transmit (which I’ve been using for FTP since the dark ages). It copies the whole folder (with .git, etc) no problem via drag-n-drop.

2 Likes
#296

That’s good to know. I’ve been using FileZilla since I’m usually at my work machine. I will go back to using transmit on OS X.

#297

do you know your networks settings? what is the signal strength shown on the norns wifi menu? we need to collect data for future troubleshooting.

#298

On boot up:

Status: activating
Network: lowerkananaskis
IP:
Signal: dBm

I then screen into norns and start running nmtui and start logging with journalctl -f -u NetworkManager > log.txt & tail -f log.txt.

after about 30-40 min I get success after repeated adding/removing/re-activating my network SSID in nmtui.

Status: activated
Network: lowerkananaskis
IP: 192.168.0.33
Signal: -54 dBm

I have attached the log. I apologize in advance that it contains all my attempts for around that length of time. log.txt (207.1 KB)

Let me know if I can provide any more information or assistance.

#299

Is it possible to rename tape recordings within norns?

#300

not yet, but @tehn is studying some fun naming function :smiley:

1 Like
#301

here’s a simple line that loops over every directory in dust/code and executes git pull origin master which will update it if it is a git repo (and the mainline branch is master). please use at your own risk, it is not the safest thing to pull in arbitrary code changes from a bunch of repos

ssh we@norns.local
// enter sleep
// from the home (~) directory, execute the line below
for dir in dust/code/*/; do cd $dir; git pull origin master; cd ../../..; done
1 Like
#302

We’ve seen some initial connection issues within the dev crew a couple of times whilst the reception wasn’t very good. I believe just moving norns closer to the accesspoint/router to connect the first time made it work all the time for those cases.

It’s working fine for me with a signal value of ±65 using nmcli device wifi list.

1 Like
#303

Took a second to understand the new script organizing / Library / SFTP vibe but now that I get it, its so great. Much faster and now I am more frequently engaged w/ Maiden. 2.0 is great - thank U all!

5 Likes