Norns 2.0.0

Hi. I can update this for 2.0 (hope I get the time later today)

1 Like

So trying to update to 2.0 and selecting Update in the menu doesn’t do anything, ideas? The new FW is installed on the USB stick at the root. :frowning:

update: when I hit update the norns somehow freezes (encoders 1 2 3 and knob 2-3 have no effects) until I hit the button 1

getting an error with trying to load less-concepts with librarian

I printed links_to_git on load and looks like the parse is not picking up the git url due to formatting or text before the link? (and thus the git link is empty for less-concepts)

lua: 
/home/we/dust/code/librarian/librarian.lua:29: attempt to concatenate a nil value (field '?')
stack traceback:
	/home/we/dust/code/librarian/librarian.lua:29: in upvalue 'get'
	/home/we/dust/code/librarian/librarian.lua:133: in function 'key'
	/home/we/norns/lua/core/menu.lua:164: in function </home/we/norns/lua/core/menu.lua:141>
>>

Currently, it parsing topic page for github link with .zip ending
I’ve wrote to @speakerdamage already. There was the same problem with Uhf
Also using github link to archive seems to be more convenient - you dont need to re-upload zip each script update

1 Like

Update was smooth. Feels much more polished. Well done everyone involved.

1 Like

Aha… Less concepts is using a pretty funky looking link for the .zip
https://llllllll.co/uploads/default/original/3X/0/a/0a2c788348fe21441ed011ecc6d81f2650901220.zip

1 Like

Great work! I had the same in mind when I wrote down those endpoints (what weirdly got deleted).
You may want to filter for the norns tag too (forgive me if I overlooked it)

20 characters of good idea!

just updated today, update itself went smoothly…

I get really laggy navigation of the new menu system. inconsistent amounts of encoder turns are required to switch between pages and levels seems to lock my norns up entirely. encoders don’t respond at all with visual feedback, but hitting k1 updates everything all at once and I am unable to exit levels with e1.

unsure if this is an encoder issue or an update issue, but help would be appreciated

edit - also just getting infinite engine loading on all scripts

1 Like

Is there anyway to list the available fonts? I saw that @zebra added a bunch, but the api docs are only registering 1-14. (I really just want to know what the magic number is for tom thumb :sweat_smile: )

fixed! thanks so much for the heads up! :revolving_hearts:

what version are you starting with? can you connect to maiden so we can see the potential error? was the USB stick inserted on boot? have your tried a different port?

@Justmat Tom is #25, thanks for the reminder to update the font list

@karst locking on levels is very unexpected. can you check maiden for errors?

1 Like

I get no reported errors on matron when it locks on levels.

I’m also getting no loading of any engines.

you need to check the maiden output from the sc tab. you likely have duplicate engines that need to be cleaned up.

the sc tab show no activity at all. I deleted dust-v1 over sftp and have done nothing else since installing, so I don’t know where engines could have been duplicated.

augh, that’s not good. did the original install go smoothly?

it might be worth re-running through installer which would need to be done via a serial connection. have you done this before?

version 181101, and yeah that’s the other issue I can’t seem to be able to maintain a connection to my network, I’ve tried hotspot and it even worse. keep loosing the connection. maybe I should try another wifi dongle?

i’d suggest skipping straight to doing a manual update:

Update in 10 simple steps

(edit of original post by @carvingcode)

Step 1: Download the update file.
Step 2: Copy the file to a FAT-formatted USB disk. Attach the USB disk to the norns and power up.
Step 3: Attach USB A to USB mini cable between the norns and the computer. The one that comes with norns for use with the power adapter works fine for this.
Step 4: Open a Terminal app. On MacOS, use the keyboard shortcut Command - Space, then enter “terminal” in the search window. On Windows, use Window + R, then type “cmd”. On Linux, there are several different methods. Search “How do I open Terminal in Linux with keyboard?” for the best way for your Linux version.

Step 5: Type (don’t copy/paste) this line into the Terminal window. Note: Replace (tab) with an actual press of the TAB key on your keyboard.

screen /dev/tty.usb(tab) 115200

Step 6: When you see the blank Terminal screen, press RETURN or ENTER.
Step 7: Log in to norns, using ‘we’ for login and ‘sleep’ for password.
Step 8: Check to see you have enough disk space to perform the update by enter the following into the Terminal window. You should see 80% or less in the top-right.

	df

Step 9: Enter the following, one line at a time. Wait for each line to complete before entering the next. Note: Some lines take up to a minute to complete. Be patient.

sudo cp /media/usb0/norns190405.tgz ~/update/
cd update
tar xzvf norns190405.tgz
tar xzvf 190405.tgz
cd 190405
./update.sh

Step 10: Lastly, enter the following to shutdown norns, then manually restart by holding Key 1 for 3 seconds.

	sudo shutdown now

That’s it. You should be up and running in v2

4 Likes

I thought it did, but apparently not. I haven’t done the serial connection yet for norns, but more or less comfortable with command line, so let me know what to do (assuming it’s different from the manual update instructions above).

there is an extra 0 hiding in the second tar command, just in case someone gets stuck there


update
doing the manual update the second time seems to have worked, thanks for the help

2 Likes

Updated to 2.0.0 - all went well though I’ve not tried any programs/scripts yet.
Big thanks all round to everyone for their efforts - so good to be part of this community.
Right - I going to work through the tutorials again to bring myself up to date.

Ah! have a problem from the off getting this error when selecting play

norns.script.load("code/DDD/study1%2001")

# script load: /home/we/dust/code/DDD/study1%2001

file not found: /home/we/dust/code/DDD/study1%2001

<ok>

actually probably best to report under Norns:Studies ? What do you think
Just brought it here as may be a norns 2.0 issue?

Solved can’t tell the difference between a ‘-’ and a ‘=’ - apols for clutter!