Norns 2.0.1

norns
#1

the future is now! 2.0 users, connect to your internet-network via wifi, execute SYSTEM > UPDATE and that’s it. updates will no longer touch dust. open maiden if you want to see slightly more progress info.

norns 1.x users, you must first udpate to 2.0.0 prior to running this update. if you do it wrong, fix it here.

190422

norns 2.0.1

  • NEW softcut phase_offset command
  • FIX polls work with no engine @catfact
  • FIX softcut reset now resets more params (properly)
  • FIX fileselect, empty folders display “no files” (less confusing)
  • FIX engine report @catfact

note: this is mostly an update to address a feature i forgot to migrate to softcut 2.0.0 which helps mlr make sense of the play positions.

32 Likes
#3

Wow, easiest update ever. Awesome. About to jam with mlr !!

7 Likes
#4

I still have the play head issue after updating. I updated over wifi and did a reset and still am seeing the issue on the grid.

Oops seems you need mlr 2.0.1 as well. Just replaced the old version and its going good.

3 Likes
#5

I’ve finished the update, but now Norns just says “complete” and then loops back to “update found: 190422 - install?”

Wondering if I should do the rude reboot here.

EDIT: Just rebooted via terminal and that seems to have made it happy

#6

Updated from 2.0 to 2.0.1 using the menu seems to have cleared my wifi settings. I assume this is expected? Although, it doesn’t seem to have cleared my scripts. Would be nice if wifi settings persisted through an update.

update

Ok weird. I just rebooted it and they’re back. Never mind. :slight_smile:

#7

…download link?..

#8

Just use SYSTEM/UPDATE
(It works om RPi as well, as long as you are on 2.0.0)

2 Likes
#9

wow :slight_smile: thanks!..

#10

Wow. It worked. So easy. So future.

Looking forward to the future. Next up, norns voice commands?

‘norns, update’
‘norns, help me prepare for Moogfest’
‘norns, organize a European tour’
‘norns, write a multi-platinum hit’

9 Likes
#11

thanks! this was very smooth!

#12

This update process is fantastic! :heart_eyes::heart_eyes::heart_eyes:

1 Like
#13

glad you all appreciate it. wouldn’t be possible without all of the wifi hacking by @ngwese and @simonvanderveldt and @artfwo

dynamic script updating/gathering system underway as well for maiden…

17 Likes
#14

hot frack!
it’s like some sort of VooDoo…it connected and auto updated fast!
:smile:

1 Like
#15

this is absolutely superb! many thanks for creating it. :partying_face::partying_face::partying_face:

#16

is anyone having trouble with MIDI clock?

i have tried several different different cables and tried both the Fairplay and Foulplay scripts.
checked sending clock from the Deluge into a Leploop and it works.

just no luck with norns reacting to incoming sync.
:frowning:

edit…
testing with LOOM and it’s reacting to MIDI play and pause and clock.

#17

I have had the same problems. When I will have the time I’m planning to try to isolate what works in Loom and hopefully crowbar this into the other scripts…

#18

I still haven’t been able to connect to WiFi properly, even with Norns right next to my router. Finds the network fine, enter my password and then it never gets past “activating”

Any ideas what could be going wrong? Or otherwise, what would be the best way to update without WiFi, can I do this via cyberduck instead?

1 Like
#19

Is this the first time you’re connecting to a network? I.e. you haven’t connected to any network (wired or wireless) before?
And did you update from an older version or flash the full image?

1 Like
#20

you can do it via cyberduck and ssh. basic instructions are similar to manual update

what router do you have?

#21

I’m on 2.0 right now, never successfully connected to WiFi, only via hotspot.

@tehn it’s a T-Mobile cellspot router, but it’s just mostly a rebranded ASUS (I can get the model number if you think it’s be helpful)