Norns 2.0 beta

I was getting audio and was able to adjust it via params. No errors in maiden. It did output a message showing that I plugged it in. Tried restarting and resetting too.

I should add the arc worked normally with ansible.

I’ll check out the syslog when I have a chance.

I reran the update via serial and things seem normal now. I had run it via wifi before and thought everything was fine, but I guess not?

1 Like

Sadly it’s not user error. Here another session at 115200 with the same results. Somehow Getty is broken on my unit.

are you using the included cable?

the serial uart of the pi I’d hooked up to an FTDI232 so this is not a custom/complicated setup.

can you simply run

screen /dev/ttyAMA0 115200

(fix for your port)

is getty sending modem chars?

3 posts were merged into an existing topic: Norns: ideas

Has anyone had trouble connecting to Maiden after the latest update 190314? I am able to get into Norns via cyberduck and the scripts appear to function as expected, I just can’t seem to connect to Maiden in a web browser (wifi is working). I get this error on Chrome… 192.168.0.33 refused to connect.

Highly recommend a USB to ethernet adaptor for anyone still having networking issues. I got this one and it works great, including being able to connect via norns.local: https://www.amazon.com/gp/product/B00MYT481C

1 Like

maybe too obvious but did you double-check the IP? mine changed recently, maybe due to an update.

yea, I checked, I think that it stayed the same but it is listed on the Norns menu screen along with the disk usage/battery/cpu screen. the previous update was working as expected, just hit a snag after the last update. strange that I can connect via SFTP but error out when connecting through the browser. seems to be getting blocked somehow.
when I ping via windows command prompt I see this…

Pinging 192.168.0.33 with 32 bytes of data:
Reply from 192.168.0.33: bytes=32 time=110ms TTL=64
Reply from 192.168.0.33: bytes=32 time=32ms TTL=64
Reply from 192.168.0.33: bytes=32 time=47ms TTL=64
Reply from 192.168.0.33: bytes=32 time=65ms TTL=64

Ping statistics for 192.168.0.33:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 32ms, Maximum = 110ms, Average = 63ms

@komicone
I had this issue after I updated to 190314, the solution was to run the update again via serial. Updating via ssh caused the networking changes to fail, which I believe caused the problem with maiden.

1 Like

Windows? Port fire walled? Random guess

@zebra, My system is windows, this is a new issue so could be a blocked port but was working just fine prior.
@Tyler, I’ll give a fresh install a try and see if it clears up. Thx!

I’m having a lot of pathing problems.

I’ve got this folder structure:
dust/agents/
dust/agents/random_walker.lua
dust/agents/lib/
dust/agents/lib/world.lua

According to the 2.0 wiki page I should be able to require "agents/lib/world" but that isn’t found. Neither is require "world" or require "lib/world"

See maiden output

Is it possible to go back to 1.0? I have had so many problems - It would have been a little wiser I think that i should wait for official release.

1 Like

16

This is how the params system saved my files when I used params:default(). Is it supposed to be /agents/data instead of /agentsdata?

(It seems like it would get really cluttered in Maiden pretty fast.)

1 Like

That’s a bug. Reported and fixed/changed.
As I understand it, there’s going to be some folder re-re-organization in the next beta release.

1 Like

Yes, you can always flash a full image, including the v1 images. Note that doing so will wipe the whole device so make sure to copy/backup the data you want to keep.

Can you elaborate on the issues you’re having? Any kind of feedback is always useful.

(btw I’ve just discovered that you can hotplug the wifi nub in 2.0, I don’t think I could do it in 1.0, can anyone confirm this?)

try pulling the newest norns repo, this was a quick fix.

new update wednesday night. thanks for your patience everyone, and for the bug reports. they’re very helpful.

3 Likes