Norns 2.0 beta

Can confirm the playfair sleep bug.

@AlessandroBonino, wifi is working now :slight_smile:

1 Like

It is worth noting that while the norns menu says WIFI the new network management logic supports wired networks as well. Once WIFI or a wired network is configured it should just auto connect via whatever is plugged into norns.

For those looking for wired network speed and reliability I am using this USB to gigabit adapter with great success:

UPDATE: I should add that currently the system assumes the network you are connecting to has DHCP setup. Wired connections should “just work” without configuration.

Another change is that multiple networks can be configured, this is particularly useful with WIFI setups if moving between different rooms (or home vs another venue) means connecting to a different network. Once configured norns should auto connect to whatever known network it can find automatically.

5 Likes

if you have maiden open you can see the error, that’d help me narrow the issue

this is basically correct. it restarts all of the norns-specific software without rebooting. so DSP and matron also.


re: WIFI. it generally seems like there’s a timeout or retry period where some patience is required before the list is populated. need to look into it.


EDIT: File browser request… can the sample browser remember the last open folder? It’s really slow loading up a specific folder of drum hits into Playfair.

this is a good idea.

Here it is

SLEEP
pset >> write: /home/we/dust/system.pset
lua:
/home/we/dust/scripts/we/playfair.lua:240: standard output file is closed
stack traceback:
[C]: in function ‘io.write’
/home/we/dust/scripts/we/playfair.lua:240: in global ‘playfair_save’
/home/we/dust/scripts/we/playfair.lua:266: in function ‘cleanup’
/home/we/norns/lua/core/menu.lua:1184: in field ‘key’
/home/we/norns/lua/core/menu.lua:169: in function </home/we/norns/lua/core/menu.lua:146>

FWIW - The bug didn’t happen to me with no samples loaded, but does with samples loaded

@tehn I notice in menu.lua that RESET does pcall(cleanup) while SLEEP does cleanup()

pcall(cleanup) seems to fix this for me

@okyeron that’s the correct fix, thanks. want to PR?

1 Like

Another thing: When I tried recording audio onto the internal tape (I tried twice, with play fair, with both reverb and compressor on) and after a while all I hear recorded is digital noise. Maiden does not show anything in this case. Can someone replicate this?

Edit: it happens also with Awake.

I got harsh digital noise in the one recording i made last night as well. was using mlr

will check tape. was working but perhaps something crept in over the last month.

(assuming I didn’t miss anything :sweat_smile:) foulplay, paths, and strides are now 2.0 ready!

14 Likes

One thing to keep in mind is that maiden still only displays the output of matron and sc (supercollider). Now that crone is an entirely separate process and not something built up inside supercollider we don’t have any means of seeing log output from crone within maiden.

3 Likes

Thanks for the update and all the hardworking from everyone involved. I’m finally able to connect to my weirdo wifi without resorting to my own dirty hacks!

1 Like

once again a massive community effort that makes me smile
most hyped about…

:grinning:

WOW

this + the equally elegant solution to storage expansion
come as a complete surprise

amazing work yall!

12 Likes

Updated strum for v2.x. Added in a few features I’ve been working on as well.

Edit: Added a few more features, mentioned in the readme. Grab the update at the link above.

4 Likes

@dan_derks submitted an updated less_concepts to the we

to update a repo (ie we) ssh (with internet connection) then

cd dust/we
git pull
7 Likes

any way to do disk image reset on Windows?

i haven’t tried it, but there are instructions here: https://www.raspberrypi.org/documentation/hardware/computemodule/cm-emmc-flashing.md

i haven’t tried cygwin (linux emulator) so i can’t comment on its complexity. but there are links to rpiboot.exe and win32diskimager. be sure to read carefully. the references to JP4 are just the RUN / DISK switch on the bottom of norns (once you remove the 4 screws)

I’ve used cygwin and these days I would recommend Windows Subsystem for Linux, which gives you a bash shell on windows. Under the covers, it’s ubuntu. Far better compatibility with most apps and libraries than cygwin was ever able to provide. Not really sure why the RPi folks are still recommending cygwin.

Agreed. I use it for compiling Linux plugin binaries for VCV. I haven’t had any trouble with it.

1 Like

This is so great. A lot of my favorite instruments are already ported in less than a day. whoa.

this is genius. It got me thinking: can it mean that someday it will be possible to add a menu item to sync we from repo? :exploding_head:

8 Likes