Norns 2.0 beta

norns

#251

okay, so when i put it back into run mode and held onto the power button (button1), i saw a new device pop up and then ran

screen /dev/tty.usbserial-A9053JN1 115200

which gave me an empty screen upon which i pressed enter, but got nothing.

ps again, the back light only turns on when i hold down on button1.


#252

ps again, the back light only turns on when i hold down on button1.

i guess you mean, holding down the button for >3s or whatever, then releasing it, doesn’t result in the orange light of disk access or anything - the light just goes off as soon as you release the button?

so, definitely doesn’t sound like linux is booting correctly. depending on how far it’s getting, you may be able to see kernel stuff by using the reset button with the serial port connected. if there’s really no sign of life, then i can’t suggest much besides double-checking everything (image checksum, &c), and maybe trying with a stock rpi image to make sure the process is sound.


#253

correct, maybe i should flash the CM3+ with the latest 1.0 image. anyhoo, thanks for the help, time for rest.


#254

if you mean the norns image posted on october 8, that will not work with CM3+, not having the required firmware patches.

i meant, try the vanilla raspbian stretch lite image. the norns screen and audio won’t work, and it will be slow to boot, but you should be able to log in through the serial port. this would be a good sanity check to make sure your hardware is working correctly.


#255

let me double-check the image. i had to update it.


#256

on the mix screen (out, in, mon, etc.) if I turn enc2 all the way down and keep going counterclockwise it jumps up to a higher level. enc3 doesn’t do that.


#257

Just installed norns 2.0 beta and loaded up maiden. No one mentioned you can now edit SC engines within maiden. This is huge!!!


#258

Just wanted to give a note (and thanks!) on fixing the wifi issues. As someone who always had issues with connecting to my home network (and would use the hotspot workaround), I have had 0 spottiness on my home network in 2.0. I left my norns on last night and just checked and I could still access maiden this morning!


#259

i have to second this

it feels like a little thing but i had never been able to connect till now
and i love it!


#260

Same as @glia and @jlmitch5, never been able to connect besides the hotspot, and now it connects everywhere (tried at home and in two of my workplaces). I can do anything anywhere, even while working. For me this is nothing short of massive.

P.S. load awake, head to parameters, lower the tempo, put a lot of reverb on the delay (reverb cut send, IIRC) and bliss out all day.


#261

I’m having the exact same issue as @zfigz .

put in cm3+, flashed according to instructions (tried both versions). then, when pushing the button for 3s nothing happens. indeed tty.usbserial[etc] is only visible to my host when holding down the button, and the led never turns yellow and immediately off when I release the button.

I also tried to flash latest raspbian image from https://www.raspberrypi.org/downloads/raspbian/ to it, as suggested by zebra (chose “stretch lite”, should be ok right?) and got the same behaviour, button doesn’t seem to really boot the thing. should it? are we facing a HW issues?

I gave up and updated the “old” CM… forgot to try and flash the latest norns image to the old CM, will maybe do this evening… though way more fun to check out all the great new things, massive thanks to everyone involved!

edit: forgot, I’m on macOS. usbboot compiled on 10.13 with a warning (not error) I can’t exactly remember. but this shouldn’t matter if I get to recognize norns in disk mode does it?


#262

you and @zfigz are experiencing problems i suspect because i updated the disk image (so that it works on normal CM3 modules, not just CM3+) but i believe i missed the part of the process that then makes it work for CM3+

i’m preparing a new beta with all the collected fixes, hold on until late this evening and i should have a working image (along with a new update). i apologize for the trouble.


#263

glad to hear that actually!!
I was lucky enough to grab a cm3+ in italy before they sold out everywhere and was already worried having to deal with return etc.


#264

Don’t know if this is specific to v2, but that’s what I’m on:

screen.text_center("text to center")

This displays a left justified " center" - first part is cut off.


#265

that’s probably normal. text_center centers text around your current location on the screen. So if you are at x == 1 half of your text will be off screen.


#266

ouf, so happy i’m not the only one. will wait for the drop tonight.


#267

OK… not expected behavior, but I understand now. Thanks.


#268

I haven’t personally tried this but for Engine code landing in the dust directories you can now see/edit the .sc files.

One somewhat under documented feature is the ability to restart Supercollider from maiden (in addition to using the RESET option in the on device menus. Switch to the sc REPL and type ;restart. Again this workflow is currently untested but it would be nice to know what stumbling blocks exist when trying to edit engines in maiden (other than the lack of syntax highlighting etc.)


#269

(for the record) sorry, i forgot that the power switch behavior is provided by a kernel overlay… you gotta flip a switch on the PCB to bypass it to always-on, but i’m not sure what this looks like on current production units.

@zfigz too

or just wait for the image verified for CM3+


#270

For users with CM3+ that installed the first beta image, will we need to re-image when the new version is posted?