Norns 2.0 beta

norns

#312

seeing this error a lot in scripts that were working prior to newest beta:

lua: /home/we/norns/lua/core/script.lua:96: attempt to concatenate a nil value (field '?') stack traceback: /home/we/norns/lua/core/script.lua:96: in function 'core/script.load'

here’s more from playfair (is this maybe an update issue on my end? it seemed fine when I did it via ssh and awake works):

# cleanup
# script clear
### SCRIPT ERROR: load fail
/home/we/dust/we/playfair.lua:20: module 'ack' not found:
	no field package.preload['ack']
	no file '/home/we/norns/lua/ack.lua'
	no file '/home/we/norns/lua/core/ack.lua'
	no file '/home/we/norns/lua/core/params/ack.lua'
	no file '/home/we/norns/lua/lib/ack.lua'
	no file '/home/we/norns/lua/softcut/ack.lua'
	no file '/home/we/dust//usr/local/share/lua/5.3/ack.lua'
	no file '/usr/local/share/lua/5.3/ack/init.lua'
	no file '/usr/local/lib/lua/5.3/ack.lua'
	no file '/usr/local/lib/lua/5.3/ack/init.lua'
	no file '/usr/share/lua/5.3/ack.lua'
	no file '/usr/share/lua/5.3/ack/init.lua'
	no file './ack.lua'
	no file './ack/init.lua'
	no file '/usr/local/lib/lua/5.3/ack.so'
	no file '/usr/lib/arm-linux-gnueabihf/lua/5.3/ack.so'
	no file '/usr/lib/lua/5.3/ack.so'
	no file '/usr/local/lib/lua/5.3/loadall.so'
	no file './ack.so'
stack traceback:
	/home/we/norns/lua/core/norns.lua:185: in function </home/we/norns/lua/core/norns.lua:185>
	[C]: in function 'require'
	/home/we/dust/we/playfair.lua:20: in main chunk
	[C]: in function 'dofile'
	/home/we/norns/lua/core/script.lua:135: in function </home/we/norns/lua/core/script.lua:135>
	[C]: in function 'xpcall'
	/home/we/norns/lua/core/norns.lua:186: in field 'try'
	/home/we/norns/lua/core/script.lua:135: in function 'core/script.load'
	(...tail calls...)
# script clear```

#313

Looks like the ack Engine lua file isn’t being found?

Might be related to a path bug I ran into earlier. Will double check when I get home


#314

yeah I think its a path bug. seems like it isn’t looking in /home/we/dust/we/lib where the engines appear to be now


#315

I had thought my wifi issues were over, but it doesn’t seem like they are. :frowning: norns consistently refuses to connect to the wifi networks at home or at the office.

The UI on norns is sluggish and often displays empty screens for CONNECT / ADD / DEL; using the nmtui is more responsive but still unable to connect to a discovered network.

I can connect to norns using screen; are there logs I can be looking at to try and work out what’s going on?

[Posting here because I’m running beta 2 (190314), but I had the same problems previous to beta 2, so maybe this should be in the norns help thread?]


#316

Anyone else is getting Audio Engine error?
I cannot start crone and here is the message that I got:

we@norns:~/norns$ ./crone.sh
we@norns:~/norns$ attempting to bind socket at url ws://:5556*
*ws-wrapper: …/ws-wrapper/src/main.c:43: bind_sock: Assertion `( *eid = nn_bind(sock, url) ) >= 0’ failed.
constructed Client: crone
constructed Client: softcut
setting up jack clients…
Cannot read socket fd = 5 err = Success
CheckRes error
JackSocketClientChannel read fail
Cannot open crone client
JackShmReadWritePtr1::~JackShmReadWritePtr1 - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
jack_client_open() failed; status = 33
terminate called without an active exception

Updated to 190314 but same error occurred in 190303


#317

many apologies everyone— i missed numerous testing points (i’ll be following a checklist from now on).

fixed update coming shortly.


#318

no worries
thanks for your efforts to put this out!


#319

quick fixes:

  • paths work correctly (psets, requires, tape)
  • playfair and less_concepts fixed

manual update via ssh/screen:

cd ~/norns
git pull
cd ~/dust/we
git pull

fixed update installer forthcoming. again i apologize for the trouble.


script updating addendum, important!

in an effort to facilitate script sharing we moved folders around, again (i’m sorry!)

with engines and engine libs now living in /dust/we/lib you now need to change some require paths if they use engine libs:

require 'ack'

needs to change to

require 'we/lib/ack'

this seems more complicated, but it actually introduces a lot of sensible correlation to the dust file tree, and allows many people to have the same-named lua files without conflicts.

so if your scripts are not seeing engine lua files, this is this fix!


#320

Trying to update my scripts to the new require syntax, but running into errors. in Foulplay,
require 'we/lib/ack' throws a lot of module not found errors, as does
require 'we/lib/er'. It seems that playfair also suffers from these errors.

edit: it seems less concepts is also throwing module not found errors…


#321

perhaps i missed a commit… let me check. make sure you do a reboot or SYSTEM > RESET after git pull (though i assume you’re doing this already!)

for er that’s a core system module so require 'er' is ok. only the engine modules moved


#322

Looks like my problem was two-fold. I didn’t immediately reset or reboot, and I changed every require to the 'we/lib/ack' style syntax. Everything is up and working now, sorry for the noise!


#323

i cant get norns to copy an image to disk
termnal prints the following:
sudo dd if=norns190314.img of=/dev/rdisk2 bs=32m conv=sparse
dd: norns190314.img: No such file or directory


#324

You need to put the image in usbboot folder if it is not the case.


#325

how?
drag and drop or via command?

should the drive be formatted in any way?


#326

it can’t find the img at current location. you probably need to go to your download folder first. try

cd ~/Downloads  (or wherever you downloaded it to) 

then above command. (!! assuming you carefully followed the instructions and know for sure disk2 is correct !!)

or probably just needs unzipping…


#327

FYI - here’s a short list of scripts that need this update:

  • molly_the_polly
  • passerby
  • loom
  • jah-scripts (r, bob, moln, rymd, shifty)

#328

same here 20 characters


#329

I assume that, in the v2 release, none of these edits will be required on included scripts?


#330

I think that’s up to the individual script writers - as those are separate repos.

I believe the scripts in the “included” we repo have already been updated (playfair, less_concepts)


#331

v2 release will only have 100% working scripts.

i can assist anyone needing help. but i’d also say that i do not plan to have the updates include everyone’s scripts. a big part of v2 is facilitating collection and sharing of scripts, so people will not have to rely on big updates. this will become more clear when the docs are finished and the new Library category here on lines is established. i apologize for the intermediary confusion.