Norns 2.0 beta

norns

#105

Did I read somewhere that v2 was adding a grid rotation function? Did it get added?


#106

I have also noticed this with Firefox, using the IP address seems to work


#107

Found it in grid.ua:

-- set grid rotation.
-- @tparam integer val : rotation 0,90,180,270 as [0, 3]
function Grid:rotation(val)
  grid_set_rotation(self.dev, val)
end

Here a demo:


#108

Running into this too. Maiden is spitting out these errors:

lua: 
/home/we/norns/lua/core/screen.lua:130: bad argument #1 to 's_text' (string expected, got table)
stack traceback:
	[C]: in function 's_text'
	/home/we/norns/lua/core/screen.lua:130: in function 'core/screen.text'
	/home/we/norns/lua/core/menu.lua:585: in field 'redraw'
	/home/we/norns/lua/core/menu.lua:671: in field 'event'
	/home/we/norns/lua/core/metro.lua:165: in function </home/we/norns/lua/core/metro.lua:162>

If I then switch to the Awake script, it seems to continue outputting errors related to MLR:

lua: /home/we/dust/scripts/mlr/mlr.lua:431: attempt to index a nil value (global 'track')
stack traceback:
	/home/we/dust/scripts/mlr/mlr.lua:431: in function </home/we/dust/scripts/mlr/mlr.lua:429>

#109

Seems super smart to me.


#110

i plan on implementing a “starred” script view, where you can have a short-list of commonly used scripts. even if this “all” list gets long, i prefer it greatly to folder diving.


re: github tutorials, i’m sure tons of good ones exist already. would appreciate suggestions for those people like and are relevant/concise. of course git knowledge won’t be strictly necessary once the extra integrations are in, but honestly git feels like a computer literacy life skill at this point.


thanks, i’ll check this out

this is probably not just safari, but a general system-level zeroconf/bonjour problem. i’ve also found it inconsistent and i’m not sure there’s too much we can do about it— which is why we moved to displaying the IP address on the screen

it does not yet exist. i will be creating it with guidelines and templates within the next two weeks. in the meantime this thread will have informal links to updated scripts.

it’s in the lib but there’s no global UI interface via the menu. https://github.com/monome/norns/blob/master/lua/grid.lua#L83

it could easily be added as a param in your script using an OPTION.


thanks for the bug reports, they seem easy to fix… will update the repos in a bit


#111

Try to clear browser cookies for norns.local

That fixed a “blank screen” problem for me


#112

It isn’t the white screen issue. Just the browser not refreshing itself. Seems good so far this AM tho… might be operator malfunction. :wink:


#113

Yeah! Just downloaded - took about a minute :grinning:


#114

re git tutorials: I discovered this person here at lines, in a discussion about learning git, and I have been highly rewarded.

much :hearts: to daniel shiffman and the coding train


#115

having issues with wifi - can’t connect to home or work. did not have this issue pre-2.x and I’m seeing the networks, so it’s not the nub. I was able to do the update via sftp since the wifi was working at the time, but now I can’t update.

I’ve tried serial connection but am getting hung up when I try a git pull:
fatal: unable to access 'https://github.com/monome/we.git/': Could not resolve host: github.com
when I ping github.com:
ping: github.com: Temporary failure in name resolution

I’ve tried unsetting proxy and that hasn’t helped. I went a bit deeper at home last night on my old macbook but that didn’t work (and hopefully unrelated, but it appears to be totally dead today!).

any thoughts?

slightly more info:


#116

can you ping 8.8.8.8?

(IOW, the ‘name resolution’ bit suggests a DNS problem maybe?)


#117

@zebra not within norns (I can ping both successfully outside of serial connection)

we@norns:~$ ping 8.8.8.8
connect: Network is unreachable


#118

serial in and then try running

nmtui

try switching USB ports for the wifi nub. make sure it’s inserted when you boot.


#119

Cool, I’m getting the NetworkManager TUI screen, not familiar enough with this stuff from here tho (edit: oh, duh)


#120

wifi connection issues in more detail:

ADD

  • networks only show sometimes, when STATUS: activating appears. otherwise STATUS says unavailable and ADD is a blank screen.
    • I’ve found that toggling scripts can get this working

CONNECT

  • When I select the added network, sometimes it will show the NETWORK. A fraction of those times the SIGNAL will start to show. Shortly thereafter, connection is lost. IP has never shown.

this is using multiple USB ports after sleeping.


#121

This sounds remarkably similar to what I’m experiencing. The update went smoothly but connecting to wifi isn’t happening for me. Given time (a LOT of time!), the ADD screen will be populated with some of the available wifi networks.

When my network has been found and added, connecting to it is a fairly hit-&-miss affair. When I choose the network in the CONNECT screen, the network name will be displayed alongside NETWORK, the STATUS will change to activating, and then after a minute or two, the network name will disappear and the STATUS will either display unavailable, or more often nothing at all.

If I do manage to find, add, and connect to my network, it’s not saved; after a reset or a sleep and restart, I come back to SYSTEM>WIFI and then have to start the whole process all over again.

I can ssh to norns OK; is there a config file that I can delete, or permissions that I can change or even some logs that might show what’s happening? Might the wifi dongle be damaged?

I just tried the nmtui on norns and that worked first time without a problem.

EDIT : All of the above goes for trying the wifi nub in multiple ports and booting norns with it connected.


#122

go to Activate a Connection and you should get a list of available networks. it’s standard enter-your-password like Macos/etc.

just a note that wifi dongle isn’t super strong and you may try moving closer to your wifi router. though you suggested it was working fine in 1.0? or was that hotspot only?

@scrag did the settings from nmtui save?


#123

fixes pushed to norns. to update (internet required on norns)

cd ~/norns
git pull
  • sleep fix on bad cleanup() (ie, playfair)
  • more reset of softcut (ie, errors switching between mlr and other scripts)
  • @markeats lib updates
  • midi param change now in API @okyeron

also pushed minor fix to mlr which fixes the param menu (dumb typo)

cd ~/dust/scripts/mlr
git pull

i wasn’t able to reproduce the TAPE record/playback noise that some people reported. can anyone replicate this repeatedly?


#124

@tehn - It looks like it… I’ve just restarted norns and it detected and connected to my network automatically.