Norns 2.0 beta

norns

#125

What got me over the hump (what always does, as it turns out) was finding a reason to need to use it myself. I’m not sure how much I have in common with the average bear lines user in this regard, but once I am actively attempting to use a tool, Googling around for various explanations of it / opening the manual starts to be an attractive proposition.

All of which is to say, maybe a So You Want to Be a Power User study for Norns could be a useful tool, even if it’s just a recipe like “Step 1) Learn how to do this: (link), Step 2) Do this for your collection of Lua scripts” etc.


#126

I have not been able to reproduce the tape glitch since it first happened.

Can anybody help me fix this? I can see the mlr folder in scripts while using STFP, i’m just trying to improve me git chops.

172.20.10.3 ~/norns $ cd dust/scripts/mlr
-bash: cd: dust/scripts/mlr: No such file or directory

#127

updated the instructions above for absolute paths.

i heard the noise explosion after recording 4 minutes of audio to TAPE.

successive TAPE recordings are all noise, even if short.


#128

is there a way to make ignore this? I dont mind if my changes get overwritten

172.20.10.3 ~/dust/scripts/mlr $ git pull
Updating 07cf6c2..97b459e
error: Your local changes to the following files would be overwritten by merge:
mlr.lua
Please commit your changes or stash them before you merge.
Aborting

#129

updated with ssh, resetted and everything worked. playfair lets it sleep.
Tape did not produce any more glitches at the moment in a 2 minutes and a half recording but I’ll try harder.


#130

@rdfm
git reset --hard HEAD will discard your changes forever
git stash will temporarily store your changes

i’ll check it out. add more data points here if you have them
[ https://github.com/monome/norns/issues/739 ]


#131

(maybe it has always been like that but I haven’t used it for months, or maybe it’s user error) MLR parameter page does not appear to scroll correctly, it goes abruptly from one page to another when I rotate ENC2, while other scripts correctly scroll line by line.


#132

I got a wifi connection w/ IP, but it didn’t seem to work. I used the norns system menu > reset option and it started working after that.


#133

That’s MIDI program change messages are now supported by helper functions.

So as an example, you’d send a program change like this.

md = midi.connect()
-- send program change
md:program_change (value, channel)

#134

just fixed this error. update mlr (described above)

fixed a few more on norns branch also. @simonvanderveldt optimized a reset issue.


#135

I can confirm that the menu now works for MLR. Still getting some MLR oddness though.

I’m noticing that MLR only records using the second audio input (left input?).

EDIT – things seem fine except for left/right recording in - I was under the impression that both inputs should work?


#136

Will there be a significant advantage to having a cm3+ moving forward into 2.0?


#137

The only real difference is storage space. The cm3+ has 32G, compared to the 4G of the cm3.


#138

@tehn
was getting audio engine errors after this most recent pull
from crone.sh

ERROR: duplicate Class found: 'Engine_Sway'
/home/we/norns/sc/engines/Engine_Sway.sc
/home/we/dust/scripts/sway/Engine_Sway.sc

Looks like Engine_Sway.sc got added to the norns distro, but it’s also in carltesta’s distro.

So - does the engine loading stuff need to error check to see if the engine already exists or…?

EDIT:

SuperCollider does not allow duplicate class definitions and will fail to compile if you’ve accidentally installed conflicting packages.

so I guess we just need to be aware that engines can’t be in more than one place?


#139

Some first pass updates to my scripts are here:
https://github.com/markwheeler/loom
https://github.com/markwheeler/molly_the_poly
https://github.com/markwheeler/passersby
https://github.com/markwheeler/tuner

Still some things to resolve…


#140

I updated a 2nd norns just now. Got the blank screen after selecting “add” in wifi. Dropped back and chose ‘reset’. Then went back to wifi and ‘add’ and was able to select the network, apply password and log in fine.

Tested by sleeping norns and wifi auto-connected as expected.

Seems like there may be something not getting set properly during the update process that’s causing wifi to act up initially.

I did notice that right after the update and before I tried to set wifi, the display indicated there was a problem with “AUDIO” (I forget the exact wording). So maybe instructions to immediately choose reset prior to activating wifi would help.


#141

aha thanks for the reminder. that’s an easy bugfix.

@okyeron need to remove sway from norns repo

anyone who wants their engines removed from norns main repo please request


#142

Whoops! Didn’t realize the old dust was included in the 2.0 image. @okyeron, did you install via the new repo I posted earlier? I guess I think long-term it will be easier for me to have a separate repository so it might be best to remove it from the we norns repo. @tehn do I just request that via GitHub or email?


#143

requests here are fine and we can remove them, thanks! sorry for the confusion.


#144

Is function cleanup () new to v2? If not, please move this post.

Desiring to play well with others, here’s a question:

Using the cleanup() function, is it good practice to set all local variables to nil when leaving the script? Only tables? What is the recommendation for leaving the norns world as clean as possible?

Thanks.