Norns 2.0 beta

norns

#167

Confirming that it is fixed for me and both channels work for recording.


#168

when you say pull the update, do you mean build or download from github? (trying to figure out if keeping up with the “latest” beta will be put on the first post in this thread, or on there)


#169

i’ll update the first post.

to update, connect to wifi (w/ internet), SSH in then:

cd norns
git pull

and you should be ready to go!

edit: yes, likely prior to “release” i’ll update the files at the top post when there is a kernel change/etc


#170

ah word sweet. so you no longer need to do ./update.sh?

EDIT: just saw your edit, I think I understand. Basically, the change didn’t require a rebuild of the kernel or whatever else the ./update.sh script does, so just pulling in the code in this case fixed it.


#171

I also went into the MLR directory in dust and pulled there too, which brought in some more changes.


#172

correct. this is for changes in the norns repo that are lua-only. if changes to matron/crone happen you’ll need to re-run ./waf but that hasn’t happened yet. i’ll alert everyone if so.


#173

maiden spits out this error when trying to turn on midi out in awake

Summary

lua:
/home/we/norns/lua/core/vport.lua:5: attempt to index a number value (local ‘self’)
stack traceback:
/home/we/norns/lua/core/vport.lua:5: in field ‘note_on’
/home/we/dust/scripts/awake/awake.lua:109: in field ‘on_step’
/home/we/norns/lua/lib/beatclock.lua:70: in function ‘beatclock.advance_step’
/home/we/norns/lua/lib/beatclock.lua:76: in function ‘beatclock.tick’
/home/we/norns/lua/lib/beatclock.lua:22: in field ‘event’
/home/we/norns/lua/core/metro.lua:165: in function </home/we/norns/lua/core/metro.lua:162>

Anyone have an idea on how to fix this?


#174

aha, i haven’t tested this. will get it working.


#175

thanks brian, you all are on fire


#176

I was using Awake and grid key presses didn’t seem to do anything. I’ve pulled the latest down from git for the script and Norns.


#179

fixed bug. git pull from /dust/scripts/awake


#180

also just fixed this. git pull to update.

basically didn’t follow the syntax update guide. some midi things had periods instead of colons.


#181

Thats kinda what i thought when poking around in the code! i’m starting to get my head around some of this stuff and it’s quite exciting/inspiring


#182

if you all haven’t tried it yet—

load a script which uses an sc engine (ie playfair)

in maiden:

h = require 'halfsecond'
h.init()

now softcut is running an echo on your engine. bonus: the rate cut1rate is now in the param menu.


#183

Found this earlier today! The new softcut availability is very exciting, and this easy require really shows the tape like nature of it off. :slight_smile:


#184

All - For those of us not yet familiar with Softcut, where is the clif notes? Not the code functions, saw those earlier. What is it and what will it do?


#185

it is a flexible, multi-voiced, varispeed audio buffer-manipulation framework. it has many features including sample-accurate crossfaded looping and built-in filters. can be configured as an echo / looper effect, granulator, sample playback unit, weird “live wavetable” oscillator, tape emulation, chorusy thing, &c, and provides the audio backend for norns MLR implementation.

in norns 1.0 there was a rather limited implementation of this thing available as an Engine in the supercollider environment. in 2.0 it is available in the mixing process (pre-fx), and can affect an arbitrary mix of Engine output, ADC signals, and/or Tape playback. (sorry, my bad, i did not add that mixing route.) softcut voices can also be cross-patched.

(i know… i need to write up a good manual for this thing, not to mention a guide to the overall signal flow in the current norns architecture. as soon as i fix the Tape bug.)


#186

so excited to dig into the new softcut.

Is fourwaves an example of the “live wavetable” oscillator?


#187

Am I correct to say that in the future Norns will be able to run multiple engines (or rather scripts) at once?
Also, I’m curious about porting sc patches onto Norns. I recently found 303 patch online but I’m kinda lost on where to start. I remember someone mentioned that they are porting Amiga2600 engine.


#188

Sleep menu option is broken after update.

UPDATE! Loading the Awake patch made the sleep option work as expected.